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Basic tutorial
This tutorial provides a step by step walk−through of the Java development tooling.


Notices


The material in this guide is Copyright (c) IBM Corporation and others 2000, 2004.


Terms and conditions regarding the use of this guide.


About This Content


20th June, 2002


License


Eclipse.org makes available all content in this plug−in ("Content"). Unless otherwise indicated below, the
Content is provided to you under the terms and conditions of the Common Public License Version 1.0
("CPL"). A copy of the CPL is available at http://www.eclipse.org/legal/cpl−v10.html. For purposes of the
CPL, "Program" will mean the Content.


Contributions


If this Content is licensed to you under the terms and conditions of the CPL, any Contributions, as defined in
the CPL, uploaded, submitted, or otherwise made available to Eclipse.org, members of Eclipse.org and/or the
host of Eclipse.org web site, by you that relate to such Content are provided under the terms and conditions of
the CPL and can be made available to others under the terms of the CPL.


If this Content is licensed to you under license terms and conditions other than the CPL ("Other License"),
any modifications, enhancements and/or other code and/or documentation ("Modifications") uploaded,
submitted, or otherwise made available to Eclipse.org, members of Eclipse.org and/or the host of Eclipse.org,
by you that relate to such Content are provided under terms and conditions of the Other License and can be
made available to others under the terms of the Other License. In addition, with regard to Modifications for
which you are the copyright holder, you are also providing the Modifications under the terms and conditions
of the CPL and such Modifications can be made available to others under the terms of the CPL.
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Preparing the workbench
In this section, you will verify that the workbench is properly set up for Java development.


The following is assumed:


You are starting with a new workbench installation with default settings.• 
You are familiar with the basic workbench mechanisms, such as views and perspectives.• 


If you're not familiar with the basic workbench mechanisms, please see the Getting Started chapter of the
Workbench User Guide.


Verifying JRE installation and classpath variables


Select the menu item Window > Preferences to open the workbench preferences. 1. 
Select Java > Installed JREs in the tree pane on the left to display the Installed Java Runtime
Environments preference page. Confirm that a JRE has been detected. By default, the JRE used to
run the workbench will be used to build and run Java programs. It should appear with a check mark in
the list of installed JREs. We recommend that you use a Java SDK instead of a JRE. An SDK is
designed for development and contains the source code for the Java library hence easing debugging.
Additional SDKs can be added by searching the harddrive for installed SDKs. To do so simply click
the Search button and specify a root folder for the search.


2. 


Select Workbench in the tree pane to display the Workbench preference page. Confirm that the Build
automatically option is checked.


3. 


Select Java > Build Path in the tree pane to display the Build Path preference page. Confirm that
Source and output folder is set to Project.


4. 
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Select Java > Editor in the tree pane to display the Java Editor preference page. On the preference
page, press the Typing tab. Confirm that option Analyze annotations while typing is checked.


5. 


Click on OK to save the preferences.6. 


Note: The following screenshots exercise the advance highlighting feature in version 3.0. In order for your
syntax highlighting to look exactly like the screenshots make sure that Window > Preferences > Java >
Editor > Syntax has Enable advance highlighting checked on.


Java projects
Classpath variables
Build classpath


Working with build paths
Working with JREs


JRE Installations Preferences
New Project Preferences
Java Editor Preferences


 Basic tutorial
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Java projects
A Java project contains source code and related files for building a Java program. It has an associated Java
builder that can incrementally compile Java source files as they are changed.


A Java project also maintains a model of its contents. This model includes information about the type
hierarchy, references and declarations of Java elements. This information is constantly updated as the user
changes the Java source code. The updating of the internal Java project model is independent of the Java
builder; in particular, when performing code modifications, if autobuild is turned off, the model will still
reflect the present project contents.


You can organize Java projects in two different ways:


Using the project as the source container. This is the recommended organization for simple projects.• 
Using source folders inside the project as the source container. This is the recommended organization
for more complex projects. It allows you to subdivide packages into groups.


• 


Java builder
Refactoring support


Creating a new Java project
Creating a Java project as its own source container
Creating a Java project with source folders
Creating a new source folder
Creating Java elements
Copying and moving Java elements
Generating getters and setters
Filtering elements


New Java Project wizard
New Project preferences
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Java builder
The Java builder builds Java programs using a compiler that implements the Java Language Specification. 
The Java builder can build programs incrementally as individual Java files are saved.


Problems detected by the compiler are classified as either warnings or errors. The existence of a warning does
not affect the execution of the program; the code executes as if it were written correctly. Compile−time errors
(as specified by the Java Language Specification) are always reported as errors by the Java compiler. For
some other types of problems you can, however, specify if you want the Java compiler to report them as
warnings, errors or to ignore them. To change the default settings, use the Window > Preferences > Java >
Compiler preference page.


The Java compiler can create CLASS files even in presence of compilation errors. However, in the case of
serious errors (for example, references to inconsistent binaries, most likely related to an invalid build path),
the Java builder does not produce any CLASS files.


Build classpath
Java development tools (JDT)


Building a Java program
Building automatically
Building manually
Viewing compilation errors and warnings
Working with build paths Viewing and editing a project's build path
Adding a JAR file to the build path
Adding a library folder to the build path


Java Build Path properties
Java Compiler preferences
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Build classpath
The build classpath is the path which is used to find classes that are referenced by your source code. During
compilation, this path is used to search for classes outside of your project. The build classpath is specified for
each project. In the project properties, it is referred to as the "Java Build Path."


Java builder
Classpath variable


Adding a JAR file to the build path
Adding a library folder to the build path
Building a Java program
Building automatically
Building manually
Viewing and editing a project's build path
Working with build paths
Creating a new source folder with exclusion filter
Creating a new source folder with specific output folder


Classpath Variables preferences
Java Build Path properties
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Classpath variables
The build path for a Java project can include source code files, other Java projects, and JAR files. JAR files
can be specified using file system paths, or by using variables that refer to locations on the network. 


Classpath variables allow you to avoid references to the location of a JAR file on your local file system. By
using a classpath variable, you can specify a JAR file or library using only a variable name, such as JRE_LIB,
rather than specifying the location of the JRE on your workstation. In this way, you can share build paths
across teams and define the variables to refer to the correct location for your particular computer.


Java development tools (JDT)
Build classpath


Adding a variable classpath entry
Attaching source to a classpath variable
Defining a classpath variable
Deleting a classpath variable


Classpath Variables preferences
Java Build Path properties
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Java development tools (JDT)
The Java development tools (JDT) are a set of extensions to the workbench that allow you to edit, compile,
and run Java programs.


Build classpath
Classpath variables
Debugger
Java builder
Java editor
Java projects
Java perspectives
Java views
Java search
Refactoring support
Scrapbook


Adding source code as individual files
Creating Java elements
Formatting Java code
Restoring a deleted workbench element
Showing and hiding files
Working with JREs


JDT actions
Frequently asked questions on JDT
JDT glossary
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Debugger
The JDT includes a debugger that enables you to detect and diagnose errors in your programs running either
locally or remotely.


The debugger allows you to control the execution of your program by setting breakpoints, suspending
launched programs, stepping through your code, and examining the contents of variables.


The debugger has a client/server design so you can debug programs running remotely on other systems in the
network as well as programs running locally on your workstation. The debug client runs inside the workbench
on your workstation.  The debugger server runs on the same system as the program you want to debug.  This
could be a program launched on your workstation (local debugging) or a program started on a computer that is
accessible through a network (remote debugging).


Java development tools (JDT)
Breakpoints
Remote debugging
Local debugging


Adding breakpoints
Changing debugger launch options
Connecting to a remote VM with the Remote Java application launch configuration
Disconnecting from a VM
Evaluating expressions
Launching a Java program
Preparing to debug
Resuming the execution of suspended threads
Running and debugging
Suspending threads


Debug preferences
Debug view
Run and debug actions
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Breakpoints
A breakpoint causes the execution of a program thread to suspend at the location where the breakpoint is set.


Breakpoints can be enabled and disabled via their context menus in the Breakpoints view.


When a breakpoint is enabled, it will cause a thread to suspend whenever the breakpoint is reached.
Enabled breakpoints are indicated with a blue circle. Enabled breakpoints are shown with a
checkmark overlay after their class is loaded by the VM and the breakpoint is successfully installed.


• 


When a breakpoint is disabled, it will not cause threads to suspend. Disabled breakpoints are indicated
with a white circle.


• 


Breakpoints are displayed in the vertical editor ruler and in the Breakpoints view.


Adding breakpoints
Resuming the execution of suspended threads
Running and debugging
Suspending threads


Debug preferences
Debug view
Run menu
Run and debug actions
Breakpoints view
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Adding breakpoints
Line breakpoints are set on an executable line of a program.


In the editor area, open the file where you want to add the breakpoint.1. 
Directly to the left of the line where you want to add the breakpoint, open the marker bar (vertical
ruler) pop−up menu and select Toggle Breakpoint.   You can also double−click on the marker bar
next to the source code line.  A new breakpoint marker appears on the marker bar, directly to the left
of the line where you added the breakpoint. Also, the new breakpoint appears in the Breakpoints view
list.


2. 


While the breakpoint is enabled, thread execution suspends before that line of code is executed. The debugger
selects the thread that has suspended and displays the stack frames on that thread's stack. The line where the
breakpoint was set is highlighted in the editor in the Debug perspective.


Debugger
Java perspectives
Java editor


Applying hit counts
Catching Java exceptions
Removing breakpoints
Enabling and disabling breakpoints
Managing conditional breakpoints
Setting method breakpoints
Stepping through the execution of a program


Breakpoints view
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Java perspectives
The Java development tools contribute the following perspectives to the workbench:


Java


A perspective designed for working with Java projects. It consists of an editor area and the following views:


Package Explorer• 
Hierarchy• 
Outline• 
Search• 
Console• 
Tasks• 


Java Browsing


A perspective designed for browsing the structure of Java projects. It consists of an editor area and the
following views:


Projects• 
Packages• 
Types• 
Members• 


Java Type Hierarchy


A perspective designed for exploring a type hierarchy. It can be opened on types, compilation units, packages,
projects or source folders and consists of the Hierarchy view and an editor.


Debug


A perspective designed for debugging your Java program. It includes an editor area and the following views.


Debug• 
Breakpoints• 
Expressions• 
Variables• 
Display• 
Outline• 
Console• 


Java development tools (JDT)
Java views
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Adding breakpoints
Opening a type hierarchy in its own perspective
Suspending threads


Breakpoints view
Console view
Debug view
Display view
Expressions view
Outline view for Java
Package Explorer view
Type Hierarchy view
Variables view


 Basic tutorial
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Java views
The Java development tools contribute the following views to the workbench:


Package Explorer view


The Package Explorer view shows the Java element hierarchy of the Java projects in your workbench. It
provides you with a Java−specific view of the resources shown in the Navigator. The element hierarchy is
derived from the project's build class paths.
For each project, its source folders and referenced libraries are shown in the tree. You can open and browse
the contents of both internal and external JAR files.


Hierarchy view


The Hierarchy view allows you to look at the complete hierarchy for a type, only its subtypes, or only its
supertypes.


Projects view


The Projects view shows Java projects, source folders, external and internal libraries.
Note: source folders and libraries (both internal and external) presented in this view are not expandable. When
they are selected, their contents are shown in the Packages view.


Packages view


The Packages view shows a list of Java packages from the currently selected Java projects, source folders or
libraries. Typically, the Projects view is used to make this selection.


Types view


The Types view shows a list of Java types from the currently selected packages. Typically, the Packages view
is used to make this selection.


Members view


The Members shows the content of a type, compilation unit or CLASS file. Typically, the Types view is used
to make this selection.


Java perspectives


Changing the appearance of the Console view
Changing the appearance of the Hierarchy view
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Breakpoints view
Console view
Debug view
Display view
Expressions view
Outline view for Java
Package Explorer view
Type Hierarchy view
Variables view
Views and editors


 Basic tutorial
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Changing the appearance of the console view
To set the types of output (and their colors) in the Console view:


From the menu bar, select Window > Preferences > Debug > Console to view the Console
Preferences page.


1. 


Checking the Show when program writes to standard out checkbox will make the Console view
visible each time new output is written to the console from the program's standard output stream. If
there is no Console view in the current perspective, one will be created.


2. 


Checking the Show when program writes to standard err checkbox will make the Console view
visible each time new output is written to the console from the program's standard error stream. If
there is no Console view in the current perspective, one will be created.


3. 


Click any of the color buttons to change the color for the corresponding text stream.  4. 


To set the fonts used in the Console view:


From the menu bar, select Window > Preferences > Workbench > Fonts to view the Fonts
Preferences page.


1. 


Select Debug Console Text Font from the list of fonts and use the Change... button to change the
font.  (The Detail Pane Text Font can be used to change the font of the debugger's detail pane).


2. 


Debugger
Java views


Console view
Views and editors
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Console view
This view shows the output of a process and allows you to provide keyboard input to a process. The console
shows three different kinds of text, each in a different color.


Standard output• 
Standard error• 
Standard input• 


You can choose the different colors for these kinds of text on the preferences pages (Window > Preferences >
Debug > Console).


Java views
Java perspectives


Changing the appearance of the console view
Stepping through the execution of a program


Run menu Breakpoints view Views and editors
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Stepping through the execution of a Java program
When a thread is suspended, the step controls can be used to step through the execution of the program
line−by−line. If a breakpoint is encountered while performing a step operation,  the execution will suspend at
the breakpoint and the step operation is ended.


Step over


Select a stack frame in the Debug view. The current line of execution in that stack frame is
highlighted in the editor in the Debug perspective.


1. 


Click the Step Over button in the Debug view toolbar, or press the F6 key. The currently−selected
line is executed and suspends on the next executable line.


2. 


Step into


Select a stack frame in the Debug view. The current line of execution in the selected frame is
highlighted in the editor in the Debug perspective.


1. 


Click the Step Into button in the Debug view toolbar, or press the F5 key. The next expression on the
currently−selected line to be executed is invoked, and execution suspends at the next executable line
in the method that is invoked.


2. 


Step into Selection


Select a stack frame in the Debug view. The current line of execution in the selected frame is
highlighted in the editor in the Debug perspective.


1. 


In the Java editor, within the current line of execution, place the cursor on the name of a method that
you would like to step into.


2. 


Click the Step into Selection action in the Run menu or Java editor context menu, or press the
Ctrl−F5 key. Execution resumes until the selected method is invoked.


3. 


Step with filters


Toggle the Use Step Filters button in the Debug view toolbar, or use Shift+F5. When the action is
toggled on, each of the step actions (over, into, return) will apply the set of step filters which are
defined in the user preferences (see Window > Preferences > Java > Debug > Step Filtering). When
a step action is invoked, stepping will continue until an unfiltered location is reached or a breakpoint
is encountered.


1. 


Run to return


Select a stack frame in the Debug view. The current line of execution in the selected frame is
highlighted in the editor in the Debug perspective.


1. 


Click the Run to Return button in the Debug view toolbar or press the F7 key. Execution resumes
until the next return statement in the current method is executed, and execution suspends on the next
executable line.


2. 
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Run to line


When a thread is suspended, it is possible to resume execution until a specified line is executed. This is a
convenient way to suspend execution at a line without setting a breakpoint.


Place your cursor on the line at which you want the program to run.1. 
Select Run to Line from the pop−up menu or use Ctrl+R. Program execution is resumed and
suspends just before the specified line is to be executed.


2. 


It is possible that the line will never be hit and that the program will not suspend. 


Breakpoints and exceptions can cause the thread to suspend before reaching the specified line.


Breakpoints
Java perspectives


Adding breakpoints
Launching a Java program
Resuming the execution of suspended threads
Running and debugging
Setting execution arguments
Suspending threads


Debug view


 Basic tutorial
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Launching a Java program
The simplest way to launch a Java program is to run it using a Java Application launch configuration. This
launch configuration type uses information derived from the workbench preferences and your program's Java
project to launch the program.


In the Package Explorer, select the Java compilation unit or class file you want to launch.1. 
From the pop−up menu, select Run > Java Application. Alternatively, select Run > Run As > Java
Application in the workbench menu bar, or Select Run As > Java Application in the drop−down
menu on the Run tool bar button.


2. 


Your program is now launched, and text output is shown in the Console.3. 


You can also launch a Java program by selecting a project instead of the compilation unit or class file.  You
will be prompted to select a class from those classes that define a main method.  (If only one class with a main
method is found in the project, that class is launched as if you selected it.)


Java views
Java editor
Debugger


Connecting to a remote VM with the Java Remote Application launcher
Re−launching a program
Running and debugging
Setting execution arguments
Stepping through the execution of a program


Debug view
Package Explorer
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Java editor
The Java editor provides specialized features for editing Java code.


Associated with the editor is a Java−specific Outline view, which shows the structure of the active Java
compilation unit. It is updated as the user edits the compilation unit.


The Java editor can be opened on binary CLASS files. If a JAR file containing the CLASS files has a source
attachment, then the editor shows the corresponding source.


The editor includes the following features:


Syntax highlighting• 
Content/code assist• 
Code formatting• 
Import assistance• 
Quick fix• 
Integrated debugging features• 


The Java editor can be configured to either show an entire compilation unit or a single Java element only. To
change the setting, use the toolbar button Show Source of Selected Element Only.


The most common way to invoke the Java editor is to open a Java file from the Navigator or Package explorer
using pop−up menus or by clicking the file (single or double−click depending on the user preferences). You
can also open the editor by opening Java elements, such as types, methods, or fields, from other views.


Java development tools (JDT)


Opening an editor for a selected element
Using the Java editor
Using content/code assist
Formatting Java code
Adding required import statements
Generating getters and setters
Viewing compilation errors and warnings
Viewing runtime exceptions
Evaluating expressions


Java editor actions
Java editor preferences
Outline view for Java
Views and editors
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Opening an editor for a selected element
You can select the name of a type, method, or field in the Java source editor or in the scrapbook and open an
editor on the definition of the element.


In the Java editor, select the name of a type, method, or field.1. 
Do one of the following:


From the menu bar, select Navigate > Open Declaration♦ 
From the editor's pop−up menu, select Open Declaration♦ 
Press F3♦ 


2. 


If there are multiple definitions of the same name, a dialog is shown, and you can select one definition that
you want to open. An editor opens containing the selected element.


Java editor


Using the Java editor


Navigate menu
Views and editors


 Opening an editor for a selected element 24







Using the Java editor
Note: Keyboard shortcuts used in the section (Java editor−related tasks) are the default key bindings.
You can change between the Standard and the Emacs key binding sets by using the Active configuration
combo box on Window > Preferences > Workbench > Keys.


Java editor


Generating getters and setters
Managing import statements
Using the local history
Formatting Java code
Viewing documentation and information
Using templates
Writing your own templates
Converting line delimiters
Finding and replacing
Changing the encoding used to show the source
Using quick fix
Using Structured Selection
Commenting and uncommenting lines of code
Shifting lines of code left and right
Using Surround with try/catch
Showing single elements or whole Java files
Opening an editor for a selected element
Using content/code assist


Java Editor
Outline view for Java
Java editor actions
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Generating getters and setters
The Java editor allows you to generate accessors ("getters and setters") for the fields of a type inside a
compilation unit.


In the editor, select the field for which you want to generate accessors (or a type in which you want to
create these methods).


1. 


Select Generate Getter and Setter from the Source pop−up menu.2. 
A dialog will open to let you select which methods you want to create.3. 
Select the methods and press OK.4. 


Java editor
Java projects


Using the Java editor
Creating a class in an existing compilation unit


Generate Getter and Setter
Outline view for Java


 Generating getters and setters 26







Creating a new class in an existing compilation
unit
An alternative way to create a new class is to add it to an existing compilation unit.


In the Package Explorer, double−click a compilation unit to open it in an editor.1. 
Type the code for the class at the desired position in the compilation unit.2. 


Java projects


Creating a new Java class
Creating a top−level class
Creating a nested class
Renaming a class, field, or interface
Renaming a compilation unit
Setting execution arguments


Package Explorer
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Creating a new Java class
Use the New Java Class wizard to create a new Java class. There are a number of ways to open this wizard:


Select the container where you want the new class to reside.1. 
Click the New Java Class button in the workbench toolbar.2. 


or


Select the container where you want the new class to reside.1. 
From the container's pop−up menu, select New > Class.2. 


or


Select the container where you want the new class to reside.1. 
From the drop−down menu on the New button in the workbench toolbar, select Class.2. 


or


Click the New button in the workbench toolbar to open the New wizard. In the left pane, select Java, and in
the right pane, select Class.


or


Select the container where you want the new class to reside. Then, select from the menu bar File > New >
Class.


Java projects


Creating Java elements
Creating a new Java project
Creating a top−level class
Creating a nested class
Creating a class in an existing compilation unit
Setting execution arguments


New Java Project wizard
New Source Folder wizard
New Java Package wizard
New Java Class wizard
Java Toolbar actions
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Creating Java elements


Java projects
Java development tools (JDT)


Organizing Java projects
Creating a Java project as its own source container
Creating a Java project with source folders
Creating a new source folder
Creating a new Java package
Creating a new Java class Creating a new Java interface
Creating a Java scrapbook page
Adding a variable class path entry
Copying and moving Java elements
Defining a class path variable


New Java Project wizard
New Source Folder wizard
New Java Package wizard
New Java Class wizard
New Java Interface wizard
New Scrapbook Page wizard
Java Toolbar actions
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Creating a new Java project
You can organize Java projects in two different ways.


Use the project as the container of packages. In this organization, all Java packages are created
directly inside the project. This is the selected organization by default. The generated CLASS files are
stored along with the JAVA source files.


• 


Use source folders as the container for packages. In this project organization, packages are not created
directly inside the project but in source folders. You create source folders as children of the project
and create your packages inside these source folders.


• 


The default organization for new projects can be changed on the preference pages (Window > Preferences >
Java > New Project).


Java projects


Creating a Java project as its own source container
Creating a Java project with source folders
Creating a new Java class
Creating a new Java interface
Creating a new source folder
Creating Java elements
Working with build paths


New Java Project wizard
New Project preference page
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Creating a Java project as its own source
container
For simple projects, the project itself acts as the source container.


From the main workbench window, click File > New > Project. The New Project wizard opens.1. 
Select Java from the left pane and Java Project from the right pane, then click Next. The New Java
Project wizard opens.


2. 


In the Project Name field, type a name for your new Java project.3. 
Select or clear the Use default check box  to indicate whether you want to use the default location for
your new project. If you clear this check box, then type or click Browse to select a location for the
project.


4. 


Click Next. The Java Settings Page opens.5. 
On the Source tab, check that the project is the only source folder and the default output folder.6. 
Optionally, on the Projects tab, select the required projects to be on the build path for this project. Use
these options only if your project depends on other projects.


7. 


Optionally, on the Libraries tab, select JAR files and CLASS folders to add to the build path for this
new project and attach source to the JAR files. Use these options only if your project requires
additional libraries.


8. 


On the Order and Export tab, use the Up and Down buttons to move the selected JAR file or CLASS
folders up or down in the build path order for this new project.


9. 


Click Finish when you are done.10. 


Java projects


Creating Java elements
Creating a new Java project
Creating a Java project with source folders
Creating a new Java package
Creating a new Java class
Creating a new interface in a compilation unit
Working with build paths


New Java Project wizard
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Creating a Java project with source folders
For larger projects, create a project with source folders.


Note: When using source folders, non−Java resources are copied to the output folder by the
Java builder. If you have non−Java resources (documentation, for example) that should not
be copied into the output folder, you can create an ordinary folder and store the resources
there. You can also use the preferences page Window > Preferences > Java > Compiler >
Build Path to specify a list of resources that will not be automatically copied to the output
folder.


From the main workbench window, click File > New > Project. The New Project wizard opens.1. 
Select Java from the left pane and Java Project from the right pane, then click Next. The New Java
Project wizard opens.


2. 


In the Project name field, type a name for your new Java project.3. 
Check or clear the Use default check box to indicate whether you want to use the default location for
your new project. If you clear this check box, then type a path or click Browse to select a location for
the project. Click Next. The Java Settings Page opens.


4. 


On the Source tab, click the Add Folder button. The Source Folder Selection dialog opens.5. 
Click the Create New Folder button to create new source folder. You can also create new source
folders at any time later.


6. 


Select the newly created folders in the Source Folder Selection and press OK7. 
Optionally, replace the default name in the Default output folder field to use a different name for the
output folder.


8. 


On the Projects tab, select the required projects to be on the build path for this project.9. 
On the Libraries tab, select JAR files and CLASS file containers to add to the build path for this new
project and attach source to the JAR files.


10. 


On the Order and Export tab, use the Up and Down buttons to move the selected JAR file or CLASS
file container up or down in the build path order for this new project.


11. 


Click Finish when you are done.12. 


Note: When you are using CVS as your repository, it is recommended that you create a
.cvsignore file inside the project. In this file, add a line with the name of the output folder
("bin" for example). Adding the output folder in the .cvsignore file ensures that the CVS
versioning support ignores the output folder in versioning operations.


Java projects
Java builder


Creating Java elements
Creating a new Java project
Creating a new source folder
Creating a Java project as its own source container
Creating a new Java package
Creating a new Java class
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Creating a Java scrapbook page
Working with build paths


New Java Project wizard


 Basic tutorial
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Creating a new source folder
You can create a new folder to contain Java source code using the New Source Folder wizard.


In the Package Explorer, select the project where you want the new source folder to reside.1. 
From the project's pop−up menu, select New > Source Folder. The New Source Folder wizard opens.2. 
In the Project Name field, the name of the selected project appears. If you need to edit this field, you
can either type a path or click Browse to choose a project that uses source folders.


3. 


In the Folder Name field, type a name for the new source folder.4. 
If the new folder nests with an existing source folder you can check Update exclusion filters in other
source folders to solve nesting. Otherwise you have to use the Java build path page (Project >
Properties > Java Build Path) to fix the nesting conflict by removing other source folders.


5. 


Click Finish when you are done.6. 


Java projects


Creating Java elements
Creating a new Java project
Creating a new Java package
Creating a Java project as its own source container
Creating a Java project with source folders


New Source Folder wizard
Java Toolbar actions
Package Explorer
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Creating a new Java package
To create new Java packages in the Package Explorer:


Optionally, select the project or source folder where you want the package to reside.1. 
Click the New Java Package button in the workbench toolbar. The New Java Package wizard opens.2. 
Edit the Source Folder field to indicate in which container you want the new package to reside. You
can either type a path or click Browse to find the container. If a folder was selected when you chose to
create the new package, that folder appears in the Source Folder field as the container for the new
package.


3. 


In the Name field, type a name for the new package.4. 
Click Finish when you are done.5. 


Note: the default (unnamed) package always exists and does not need to be created.


Java projects


Creating Java elements
Moving folders, packages, and files
Organizing Java projects
Opening a package
Renaming a package


New Java Package wizard
New Source Folder wizard
Java Toolbar actions
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Moving folders, packages, and files
In the Package Explorer, select the folder, package or file you want to move.1. 
Drag−and−drop the selected resources onto the desired location.2. 


Note: You can use drag−and−drop to move resources between different workbench windows. Select a
resource you want to move, and drag−and−drop it onto the desired destination. If you want to copy rather than
move, hold the Ctrl key down while dragging.


You can also use drag−and−drop to copy resources between the workbench and the desktop (both ways), but
you cannot move files from the desktop to the workbench using drag−and−drop.


Java projects
Refactoring support


Using the Package Explorer
Creating a new Java package
Copying and moving Java elements
Opening a package
Renaming a package


Package Explorer
Refactoring actions
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Refactoring support
The goal of Java program refactoring is to make system−wide code changes without affecting the behavior of
the program. The Java tools provide assistance in easily refactoring code.


The refactoring tools support a number of transformations described in Martin Fowler's book Refactoring:
Improving the Design of Existing Code, Addison Wesley 1999, such as Extract Method, Inline Local
Variable, etc.


When performing a refactoring operation, you can optionally preview all of the changes resulting from a
refactoring action before you choose to carry them out. When previewing a refactoring operation, you will be
notified of potential problems and will be presented with a list of the changes the refactoring action will
perform. If you do not preview a refactoring operation, the change will be made in its entirety and any
resultant problems will be shown. If a problem is detected that does not allow the refactoring to continue, the
operation will be halted and a list of problems will be displayed.


Refactoring commands are available from the context menus of several Java views (e.g. Package Explorer,
Outline) and editors. Many "apparently simple" commands, such as Move and Rename, are actually
refactoring operations, since moving and renaming Java elements often require changes in dependent files.


Java development tools (JDT)


Refactoring
Refactoring without preview
Refactoring with preview
Previewing refactoring changes
Undoing a refactoring operation
Redoing a refactoring operation


Refactoring actions
Refactoring wizard
Refactoring preferences
Extract Method Errors
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Refactoring


Refactoring support


Refactoring without preview
Refactoring with preview
Previewing refactoring changes
Undoing a refactoring operation
Redoing a refactoring operation


Copying and moving Java elements
Extracting a method
Extracting a local variable
Extracting a constant
Renaming a package
Renaming a compilation unit
Renaming a class or interface
Renaming a method
Renaming a field
Renaming a local variable
Renaming method parameters
Changing method signature
Inlining a local variable
Inlining a method
Inlining a constant
Self encapsulating a field
Replacing a local variable with a query
Pulling members up to superclass
Pushing members down to subclasses
Moving static members between types
Moving an instance method to a component
Converting a local variable to a field
Converting an anonymous inner class to a nested class
Converting a nested type to a top level type
Extracting an interface from a type
Replacing references to a type with references to one of its subtypes


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Refactoring without preview
Activate a refactoring command. For example, rename a type by selecting it in the Outline view and
choosing Refactor > Rename from its pop−up menu.


1. 


The Refactoring Parameters page prompts you for information necessary for the action. For example,
the Rename Type Refactoring dialog asks you for a new name for the selected type.


2. 


Provide the necessary data on the parameters page, and click OK.3. 
If no problems more severe than the default level set in the Refactoring Preferences page (Window >
Preferences > Java > Refactoring) are anticipated, then the refactoring is carried out.
If you chose in the Refactoring Preferences page to be notified of any problems after refactoring, then
any detected problems are displayed at this time.
If problems more severe than the default level set in the refactoring preferences are anticipated, then
the problems page comes to the front to display the errors.


4. 


If a Stop problem was anticipated, then only the Back and Cancel buttons are enabled, and you are
prevented from carrying out the refactoring. If the problems are related to data provided on the
parameters page, click Back and attempt to remedy the problem. Otherwise, click Cancel to close the
dialog.


5. 


If other kinds of problems were anticipated, you can click Continue to acknowledge the problems.
The refactoring is carried out, and the dialog closes.


6. 


Refactoring support


Refactoring with preview
Undoing a refactoring operation
Redoing a refactoring operation


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Refactoring with preview
Activate a refactoring command. For example, rename a type by selecting it in the Outline view and
choosing Refactor > Rename from its pop−up menu.


1. 


The Refactoring Parameters page prompts you for information necessary for the action. For example,
the Rename Type Refactoring dialog asks you for the new name for the selected type.


2. 


Provide the necessary data on the parameters page, and then click Preview.3. 
If problems more severe than the default level set in the Refactoring Preferences page (Window >
Preferences > Java > Refactoring) are anticipated, then the problems page comes to the front to
display anticipated errors.


If a Stop problem was anticipated, then only the Back and Cancel buttons are enabled, and
you are prevented from carrying out the refactoring. If the problems are related to data
provided on the parameters page, click Back and attempt to remedy the problem. Otherwise,
click Cancel to close the dialog.


♦ 


If other kinds of problems were anticipated, you can click Continue to acknowledge the
problems and move on to the preview page.


♦ 


The Refactoring Preview page opens.


4. 


Click OK to execute the refactoring and close the dialog.5. 


Refactoring support


Refactoring without preview
Previewing refactoring changes
Undoing a refactoring operation
Redoing a refactoring operation


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Previewing refactoring changes
The Preview page shows the proposed effects of a refactoring action. You can use this page as follows.


Select a node in the tree to examine a particular change.• 
To examine a change inside a compilation unit, expand a compilation unit node in the tree and select
one of its children.


• 


When selecting nodes, the compare viewer is adjusted only to show a preview for the selected node.• 
Deselect a node to exclude it from the refactoring.• 


Note: Deselecting a node can result in compile errors when performing the refactoring. Only deselect a
change if you are sure you want to exclude it from the refactoring.


Refactoring support


Refactoring with preview
Undoing a refactoring operation
Redoing a refactoring operation


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Undoing a refactoring operation
The most recent refactoring can be undone as long as you have not modified any Java elements in the
workbench. After performing a refactoring operation, you can build the project, run and debug it, and execute
any test cases, and still undo the refactoring action.


To undo the most recent refactoring, select Refactor > Undo from the menu bar.


Note: If the workbench contains unsaved files that affect undoing the refactoring, an error dialog appears. The
dialog contains a list of files that must be reverted to their saved editions before the refactoring can be
completed.


Refactoring support


Refactoring without preview
Refactoring with preview
Previewing refactoring changes
Redoing a refactoring operation


Refactoring actions
Refactoring dialog
Refactoring preferences


 Undoing a refactoring operation 42







Redoing a refactoring operation
To redo a previously undone refactoring operation, select Refactor > Redo from the menu bar.


Refactoring support


Refactoring without preview
Refactoring with preview
Previewing refactoring changes
Undoing a refactoring operation


Package Explorer
Outline view for Java
Refactoring actions
Refactoring dialogs
Refactoring preferences
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Package Explorer view
The Package Explorer view, shown by default in the Java perspective, shows the Java element hierarchy of
the Java projects in your workbench. It provides you with a Java−specific view of the resources shown in the
Navigator. The element hierarchy is derived from the project's build paths.


For each project, its source folders and referenced libraries are shown in the tree. You can open and browse
the contents of both internal and external JAR files. Opening a Java element inside a JAR opens the CLASS
file editor, and if there is a source attachment for the JAR file, its corresponding source is shown.
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Toolbar buttons


Button Command Description


Back Navigates to the most recently−displayed state of the view
with a different element at the top level.


Forward Navigates to the state of the view with a different element at
the top level that was displayed immediately after the current
state.


Up Navigates to the parent container of the package that is
currently displayed at the top level in the view.


Collapse All Collapses all tree nodes.


Link with Editor Links the package explorer's selection to the active editor.


n/a Select Working Set... Opens the Select Working Set dialog to allow selecting a
working set.


n/a Deselect Working Set Deselects the current working set.


n/a Edit Active Working Set Opens the Edit Working Set wizard..


n/a Hide Non−Public
Members


Shows or hides the static fields and methods.


n/a Hide Static Members Shows or hides the static fields and methods.


n/a Hide Fields Shows or hides fields.


n/a Filters... Opens the Java Element Filters dialog.


See Java Element Filters dialog


Java views
Java perspectives


Using the Package Explorer
Showing and hiding elements


Java Element Filters dialog
Views and editors
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Java element filters dialog
This dialog lets you define Java element filters for the Package Explorer view.


Option Description Default


Name filter patterns If enabled, a comma separated list of patterns can
be specified additionally.


Off


Select the elements to exclude
from the view


List of pre−defined filters which can be enabled. .* files
Empty parent
packages
Import declarations
Inner class files
Package
declarations


The Filter description field displays the description for the currently selected filter.


Filtering elements
Showing and hiding elements
Package Explorer view
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Filtering elements
To filter elements:


On the Package Explorer toolbar, click the Menu button and choose Filters.1. 
Select or clear the filters that you want to apply to the view (read Filter description to learn about the
selected filter's functionality).


2. 


Optionally, you can select patterns for filtering the view:
Select the Name filter patterns checkbox at the top of the dialog.♦ 
In the text field below, specify the desired patterns (names matching one of the patterns will
be hidden).


♦ 


3. 


Java projects


Using the Package Explorer
Showing and hiding system files


Java Element Filters
Package Explorer
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Using the Package Explorer view


Filtering elements
Showing and hiding elements
Moving folders, packages and files


Package Explorer
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Showing and hiding elements
You can use filters to control which files are displayed in the Package Explorer.


Showing and hiding system files
Showing and hiding CLASS files generated for inner types
Showing and hiding libraries
Showing single elements or whole Java files
Showing and hiding empty packages
Showing and hiding empty parent packages
Showing and hiding Java files
Showing and hiding non−Java elements
Showing and hiding non−Java projects in Java views
Showing and hiding members in Java views
Showing and hiding override indicators
Showing and hiding method return types in Java views
Showing and hiding import declarations in Java views
Showing and hiding package declarations in Java views


Java Element Filters
Package Explorer
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Showing and hiding system files
To show system files:


Select the Filters command from the Package Explorer view drop−down menu.1. 
In the exclude list clear the checkbox for .* files.2. 


To hide system files:


Select the Filters command from the Package Explorer view drop−down menu.1. 
In the exclude list select the checkbox for .* files. This hides files that have only a file extension but
no file name, such as .classpath.


2. 


Showing and hiding elements
Filtering elements


Java Element Filters
Package Explorer
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Showing and hiding CLASS files generated for
inner types
To show CLASS files for inner types:


Select the Filters command from the Package Explorer drop−down menu.1. 
Ensure that the Inner class files filter is not selected.2. 


To hide CLASS files for inner types:


Select the Filters command from the Package Explorer drop−down menu.1. 
Ensure that the Inner class files filter is selected.2. 


Showing and hiding elements
Filtering elements


Java Element Filters
Package Explorer
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Showing and hiding libraries
To show libraries:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list clear the checkbox for Referenced libraries.2. 


To hide libraries:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list select the checkbox for Referenced libraries.2. 


Showing and hiding elements
Filtering elements


Java Element Filters
Package Explorer
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Showing single elements or whole Java files
To display the selected Java file in a single element view, click the Show Source of Selected Element
Only button in the workbench toolbar, so that it is pressed.


• 


To display the selected Java file in a whole (non−segmented) view, click the Show Source of Selected
Element Only button in the workbench toolbar, so that it is not pressed.


• 


Note: this toolbar button is enabled only when a Java editor is open.


Java editor


Using the Java editor


Java editor
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Java editor


Toolbar actions


Command Description


Show Source of
Selected Element
Only


This option can be toggled to display a segmented view of the source of the selected
Java element. This button applies to the currently−active editor and to all editors
opened in the future; other currently−open editors are not affected.


For example, if a method is selected in the Outline view, the Show Source Of
Selected Element Only option causes only that method to be displayed in the editor,
as opposed to the entire class.


Off:
The entire compilation unit is displayed in the editor, with the selected Java
element highlighted in the marker bar with a range indicator.


On:
Only the selected Java element is displayed in the editor, which is linked to
the selection in the Outline or Hierarchy view.


Go to Next Problem This command navigates to the next problem marker in the active editor.


Go to Previous
Problem


This command navigates to the previous problem marker in the active editor.


Key binding actions


The following actions can only be reached through key bindings. The Key bindings field in Window >
Preferences > Workbench > Keys must be set to 'Emacs'.


Key binding Description


Alt+0 Ctrl+K, Esc 0 Ctrl+K Deletes from the cursor position to the beginning of the line.


Ctrl+K Deletes from the cursor position to the end of the line.


Ctrl+Space, Ctrl+2 Sets a mark at the current cursor position.


Ctrl+X Ctrl+X Swaps the cursor and mark position if any.


Java editor


Using the Java editor
Viewing documentation and information
Showing single elements or whole Java files
Opening an editor for a selected element
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Outline view for Java Java editor preferences JDT actions Views and editors


 Basic tutorial
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Viewing documentation and information
You can view different kinds of documentation information while working in the workbench.


Java development tools (JDT)


Using the Java editor
Viewing Javadoc information
Viewing marker help
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Viewing Javadoc information
The JDT provides easy access to Javadoc information for the code edited in the Java editor.


Open the Java editor on a Java file.1. 
Place the mouse pointer over the element whose Javadoc information you want to view (a method
name, for example).


2. 


If Javadoc information is available, a pop−up window opens, displaying the Javadoc information.
HTML Javadoc can be viewed as any other resource in the workbench, through an embedded or
external editor or viewer. Import the Javadoc into the workbench and double−click it in the Package
Explorer.


3. 


You can also view Javadoc information by:


Opening the Java editor on a Java file.1. 
Placing the mouse pointer over the element whose Javadoc information you want to view (a method
name, for example).


2. 


Pressing F2 or selecting Edit > Show Tooltip Description from the menu bar.3. 


To view Javadoc in an external browser:


Opening the Java editor on a Java file.1. 
Placing the caret over the element whose Javadoc information you want to view (a method name, for
example).


2. 


Pressing Shift+F2 or selecting Navigate > Open External Javadoc from the menu bar.3. 


Java editor


Using the Java editor
Using content/code assist
Viewing documentation and information
Viewing marker help


Package Explorer
Javadoc Location
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Using content/code assist
You can use content assist (also called code assist) when writing Java code or Javadoc comments.


Place your cursor in a valid position on a line of code in an editor and either
Press Ctrl+Space♦ 
Select Edit > Content Assist from the menu bar♦ 


If the Java editor finds valid candidates for this position, a list of possible completions is shown in a
floating window. You can type further to narrow the list. You can also hover over the selected list
items to view its Javadoc information, if it is available.


1. 


Use the arrow keys or the mouse pointer to navigate through the possible completions.2. 
Select an item in the list to complete the fragment by doing one of the following:


Selecting it and pressing Enter♦ 
Double−clicking it♦ 
Note: When a list item is selected, you can view any available Javadoc information for this
item in hover help. Note that you must click an item to select it in the list before you can view
Javadoc hover help for it.


♦ 


3. 


Java editor
Scrapbook


Using the Java editor
Formatting Java code
Using the Java editor
Viewing Javadoc information
Views and editors


Java Content Assist
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Scrapbook
The JDT contributes a scrapbook facility that can be used to experiment and evaluate Java code snippets
before building a complete Java program. Snippets are edited and evaluated in the Scrapbook page editor,
with resultant problems reported in the editor.


From a Java scrapbook editor, you can select a code snippet, evaluate it, and display the result as a string. You
can also show the object that results from evaluating a code snippet in the debugger's expressions view.


Java development tools (JDT)
Debugger


Creating a Java scrapbook page
Displaying the result of evaluating an expression
Inspecting the result of evaluating an expression
Using content/code assist
Viewing compilation errors and warnings


New Java Scrapbook Page wizard
Java scrapbook page
Expressions view
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Creating a Java scrapbook page
The scrapbook allows Java expressions, to be run, inspected, and displayed under the control of the debugger.
Breakpoints and exceptions behave as they do in a regular debug session.


Code is edited on a scrapbook page.  A VM is launched for each scrapbook page in which expressions are
being evaluated. The first time an expression is evaluated in a scrapbook page after it is opened, a VM is
launched. The VM for a page will remain active until the page is closed, terminated explicitly (in the debugger
or via the Stop the Evaluation button in the editor toolbar), or when a System.exit() is evaluated.


There are several ways to open the New Java Scrapbook Page wizard.  


Create a file with a .jpage extension• 
From the menu bar, select File > New > Other. Then select Java > Java Run/Debug > Scrapbook
Page. Then click Next.


• 


Once you've opened the New Java Scrapbook Page wizard:.


In the Enter or select the folder field, type or click Browse to select the container for the new page.1. 
In the File name field, type a name for the new page. The .jpage extension will be added
automatically if you do not type it yourself.


2. 


Click Finish when you are done. The new scrapbook page opens in an editor.3. 


Scrapbook
Java projects


Creating a new source folder
Creating Java elements
Running and debugging


Java scrapbook page
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Running and debugging
You may launch your Java programs from the workbench.  The programs may be launched in either run or
debug mode.


In run mode, the program executes, but the execution may not be suspended or examined.• 
In debug mode, execution may be suspended and resumed, variables may be inspected, and
expressions may be evaluated.


• 


Debugger
Remote debugging
Local debugging


Changing debugger launch options
Choosing a JRE for launching a project
Creating a Java scrapbook page
Disconnecting from a VM
Launching a Java program
Local debugging
Preparing to debug
Re−launching a program
Remote debugging
Resuming the execution of suspended threads
Setting execution arguments
Stepping through the execution of a program
Suspending threads
Viewing compilation errors and warnings


Run and debug actions
Debug view
Debug preferences
Console preferences
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Remote debugging
The client/server design of the Java debugger allows you to launch a Java program from computer on your
network and debug it from the workstation running the platform.  This is particularly useful when you are
developing a program for a device that cannot host the development platform.  It is also useful when
debugging programs on dedicated machines such as web servers. 


Note:  To use remote debugging, you must be using a Java VM that supports this feature.


To debug a program remotely, you must be able to launch the program in debug mode on the remote machine
so that it will wait for a connection from your debugger.  The specific technique for launching the program
and connecting the debugger are VM−specific.  The basic steps are as follows:


Ensure that you are building your Java program with available debug information.  (You can control
these attributes from Window > Preferences > Java > Compiler). 


1. 


After you build your Java program, install it to the target computer.  This involves copying the
.CLASS files or .JAR files to the appropriate location on the remote computer.


2. 


Invoke the Java program on the remote computer using the appropriate VM arguments to specify
debug mode and a communication port for the debugger.


3. 


Start the debugger using a remote launch configuration and specify the address and port of the remote
computer.


4. 


More specific instructions for setting up a launch configuration for remote debugging should be obtained from
your VM provider. 


Using the remote Java application launch configuration
Disconnecting from a VM
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Using the remote Java application launch
configuration
The Remote Java Application launch configuration should be used when debugging an application that is
running on a remote VM.  Since the application is started on the remote system, the launch configuration does
not specify the usual information about the JRE, program arguments, or VM arguments.  Instead, information
about connecting to the application is supplied.


To create a Remote Java Application launch configuration, do the following:


Select Run >Debug....from the workbench menu bar (or Debug... from the drop−down menu on the
Debug tool bar button) to show the launch configuration dialog.


1. 


Select the Remote Java Application in the list of configuration types on the left.2. 
Click the New button. A new remote launch configuration is created and three tabs are shown:
Connect, Source, and Common.


3. 


In the Project field of the Connect tab, type or browse to select the project to use as a reference for
the launch (for source lookup). A project does not need to be specified.


4. 


In the Host field of the Connect tab, type the IP address or domain name of the host where the Java
program is running.
If the program is running on the same machine as the workbench, type localhost.


5. 


In the Port field of the Connect tab, type the port where the remote VM is accepting connections.
Generally, this port is specified when the remote VM is launched.


6. 


The Allow termination of remote VM flag is a toggle that determines whether the Terminate
command is enabled in the debugger. Select this option if you want to be able to terminate the VM to
which you are connecting.


7. 


Click Debug. The launch attempts to connect to a VM at the specified address and port, and the result
is displayed in the Debug view. If the launcher is unable to connect to a VM at the specified address,
an error message appears.


8. 


Specific instructions for setting up the remote VM should be obtained from your VM provider. 


Debugger


Launching a Java program
Disconnecting from a VM
Setting execution arguments


Debug view
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Disconnecting from a VM
To disconnect from a VM that was connected to with a Remote Java Application launch configuration:


In the Debug view, select the launch.1. 
Click the Disconnect button in the view's toolbar. Communication with the VM is terminated, and all
threads in the remote VM are resumed. Although the remote VM continues to execute, the debug
session is now terminated.


2. 


Debugger


Connecting to a remote VM with the Remote Java application launch configuration
Running and debugging


Debug view
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Debug view
This view allows you to manage the debugging or running of a program in the workbench. It displays the
stack frame for the suspended threads for each target you are debugging. Each thread in your program appears
as a node in the tree. It displays the process for each target you are running.


If the thread is suspended, its stack frames are shown as child elements.


Debug View Commands


Command
Name Description


Resume This command resumes a suspended thread.


Suspend This command suspends the selected thread of a target so that you can browse
or modify code, inspect data, step, and so on.


Terminate This command terminates the selected debug target.


Context
menu only


Terminate &
Remove


This command terminates the selected debug target and removes it from the
view.


Context
menu only


Terminate All This command terminates all active launches in the view.


Disconnect This command disconnects the debugger from the selected debug target when
debugging remotely.


Remove All
Terminated
Launches


This command clears all terminated debug targets from the view display.


Use Step Filters This command toggles step filters on/off. When on, all step functions apply step
filters.


Step Into This command steps into the highlighted statement.


Step Over This command steps over the highlighted statement. Execution will continue at
the next line either in the same method or (if you are at the end of a method) it
will continue in the method from which the current method was called.


The cursor jumps to the declaration of the method and selects this line.


Run to Return This command steps out of the current method. This option stops execution
after exiting the current method.


Show Qualified
Names


This option can be toggled to display or hide qualified names.


Context
menu only


Copy Stack This command copies the selected stack of suspended threads as well as the
state of the running threads to the clipboard.


Drop to Frame This command lets you drop back and reenter a specified stack frame. This
feature is similar to "running backwards" and restarting your program part−way
through.


To drop back and reenter a specified stack frame, select the stack frame that you
want to "drop" to, and select Drop to Frame.
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Some caveats apply to this feature:


You cannot drop past a native method on the stack.• 
Global data are unaffected and will retain their current values. For
example, a static vector containing elements will not be cleared.


• 


Note: This command is only enabled if the underlying VM supports this feature.


Context
menu only


Relaunch This command re−launches the selected debug target.


Context
menu only


Properties This command displays the properties of the selected launch. It also allows you
to view the full command line for a selected process.


Debugger
Java views
Local debugging
Remote debugging


Changing debugger launch options
Connecting to a remote VM with the Remote Java application launch configuration
Disconnecting from a VM
Launching a Java program
Preparing to debug
Resuming the execution of suspended threads
Running and debugging
Stepping through the execution of a program
Suspending threads


Debug preferences
Run and debug actions
Views and editors


 Basic tutorial
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Local debugging
The Java debugger has a client/server design so that it can be used to debug programs that run locally (on the
same workstation as the debugger) or remotely (on another computer on the network).


Local debugging is the simplest and most common kind of debugging.  After you have finished editing and
building your Java program, you can launch the program on your workstation using the Run > Debug... menu
item on the workbench.  Launching the program in this way will establish a connection between the debugger
client and the java program that you are launching.  You may then use breakpoints, stepping, or expression
evaluation to debug your program.


Breakpoints


Adding breakpoints
Resuming the execution of suspended threads
Running and debugging
Suspending threads


Debug preferences
Debug view
Run and debug actions
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Resuming the execution of suspended threads
To resume the execution of a suspended threads:


Select the thread or its stack frame in the Debug view.1. 
Click the Resume button in the Debug view toolbar (or press the F8 key). The thread resumes its
execution, and stack frames are no longer displayed for the thread.  The Variables view is cleared.


2. 


Debugger


Evaluating expressions
Stepping through the execution of a program
Suspending threads


Debug view
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Evaluating expressions
When the VM suspends a thread (due to hitting a breakpoint or stepping through code), you can evaluate
expressions in the context of a stack frame.


Select the stack frame in which an evaluation is to be performed. For the detail panes of the Variables
and Expressions views, the evaluation context will be a selected variable. If no variable is selected,
the selected stack frame will be the context.


1. 


Expressions can be entered and evaluated in the following areas:
Display view♦ 
Detail pane of the Expressions view♦ 
Detail pane of the Variables view♦ 
Java editor when it is displaying source and it is not read−only♦ 


2. 


Select the expression to be evaluated and select Display, Inspect or Execute from the context pop−up
menu. The result of a Display or Inspect evaluation is shown in a popup window. Note that Execute
does not display a result − the expression is just executed.


3. 


The result popup window can be dismissed by clicking outside of the popup window or by pressing
Esc. The result can be persisted to the Display view (if Display was chosen) or Expressions view (if
Inspect was chosen) by pressing the key sequence shown at the bottom of the popup window. For
example, to move the result of an Inspect evaluation to the Expressions view press CTRL−Shift−I.
Note that when the Display action is used from the Display view the result is written to the Display
view rather than a popup


4. 


Note: Evaluations cannot be performed in threads that have been manually suspended.


Debugger
Java editor


Suspending threads
Resuming the execution of suspended threads


Display view
Expressions view
Expressions view Show Detail Pane
Variables view
Variables view Show Detail Pane
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Suspending threads
To suspend an executing thread:


Select the thread in the Debug view.1. 
Click the Suspend button in the Debug view toolbar. The thread suspends its execution. The current
call stack for the thread is displayed, and the current line of execution is highlighted in the editor in
the Debug perspective.


2. 


When a thread suspends, the top stack frame of the thread is automatically selected.  The Variables view
shows the stack frame's variables and their values.  Complex variables can be further examined by expanding
them to show the values of their members.


When a thread is suspended and the cursor is hovered over a variable in the Java editor, the value of that
variable is displayed.


Debugger
Java editor
Java perspectives


Catching Java exceptions
Evaluating expressions
Resuming the execution of suspended threads
Stepping through the execution of a program


Debug view
Variables view
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Catching Java exceptions
It is possible to suspend the execution of thread when an exception is thrown by specifying an exception
breakpoint. Execution can be suspended at locations where the exception is uncaught, caught, or both.


Choose Add Java Exception Breakpoint from the Breakpoints view or the workbench Run menu.  1. 
A dialog listing all of the available exceptions is shown.2. 
Either type the name of the exception you want to catch or select it from the list.3. 
At the bottom of the page, use the check boxes to specify how you want execution to suspend at
locations where the exception is thrown.


Select Caught if you want execution to suspend at locations where the exception is thrown
but caught.


♦ 


Select Uncaught if you want execution to suspend at locations where the exception is
uncaught.


♦ 


4. 


Note: Exception breakpoints can be enabled and disabled and have hit counts just like regular breakpoints.


Java development tools (JDT)
Breakpoints


Suspending threads
Adding breakpoints
Removing breakpoints
Enabling and disabling breakpoints
Setting method breakpoints


Breakpoints view
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Removing breakpoints
Breakpoints can be easily removed when you no longer need them.


In the editor area, open the file where you want to remove the breakpoint.1. 
Directly to the left of the line where you want to remove the breakpoint, open the marker bar pop−up
menu and select Toggle Breakpoint. The breakpoint is removed from the workbench.  You can also
double−click directly on the breakpoint icon to remove it.


2. 


Breakpoints can also be removed in the Breakpoints view. Select the breakpoint(s) to be removed and from
the context menu select Remove.
All breakpoints can be removed from the workbench using the Remove All action in the context menu of the
Breakpoints view.


If you find yourself frequently adding and removing a breakpoint in the same place, consider disabling the
breakpoint when you don't need it (using Disable Breakpoint in the breakpoint context menu or the
Breakpoints view) and enabling it when needed again.  


Debugger
Java perspectives
Java editor


Adding breakpoints
Enabling and disabling breakpoints
Applying hit counts
Catching Java exceptions
Managing conditional breakpoints
Setting method breakpoints
Stepping through the execution of a program


Breakpoints view


 Removing breakpoints 72







Enabling and disabling breakpoints
Breakpoints can be enabled and disabled as needed.  When a breakpoint is enabled, thread execution suspends
before that line of code is executed.  When a breakpoint is disabled, thread execution is not suspended by the
presence of the breakpoint.


To disable a breakpoint in the Breakpoints view:


Open the breakpoint's context menu and select Disable, or deselect the breakpoint's checkbox.1. 
The breakpoint image will change to a white circle and its checkbox will be empty.2. 


To disable a breakpoint in the marker bar of an editor:


Open the breakpoint's context menu and select Disable Breakpoint.1. 
The breakpoint image will change to a white circle.2. 


To enable the breakpoint in the Breakpoints view:


Open the breakpoint's context menu and select Enable, or select the breakpoint's checkbox.1. 
The breakpoint image will change back to a blue circle, and its checkbox will be checked.2. 


To enable a breakpoint in the marker bar of an editor:


Open the breakpoint's context menu and select Enable Breakpoint.1. 
The breakpoint image will change to a white circle.2. 


Debugger
Java perspectives
Java editor


Applying hit counts
Catching Java exceptions
Removing breakpoints
Setting method breakpoints
Managing conditional breakpoints
Stepping through the execution of a program


Breakpoints view
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Applying hit counts
A hit count can be applied to line breakpoints, exception breakpoints, watchpoints and method breakpoints.
When a hit count is applied to a breakpoint, the breakpoint suspends execution of a thread the nth time it is
hit, but never again, until it is re−enabled or the hit count is changed or disabled.


To set a hit count on a breakpoint:


Select the breakpoint to which a hit count is to be added.1. 
From the breakpoint's pop−up menu, select Hit Count.2. 
In the Enter the new hit count for the breakpoint field, type the number of times you want to hit the
breakpoint before suspending execution.


Note: When the breakpoint is hit for the nth time, the thread that hit the breakpoint suspends. The
breakpoint is disabled until either it is re−enabled or its hit count is changed.


3. 


Breakpoints


Adding breakpoints
Removing breakpoints
Enabling and disabling breakpoints
Setting method breakpoints


Breakpoints view


 Applying hit counts 74







Setting method breakpoints
Method breakpoints are used when working with types that have no source code (binary types).


Open the class in the Outline view, and select the method where you want to add a method
breakpoint.


1. 


From the method's pop−up menu, select Toggle Method Breakpoint.2. 
A breakpoint appears in the Breakpoints view. If source exists for the class, then a breakpoint also
appears in the marker bar in the file's editor for the method that was selected.


3. 


While the breakpoint is enabled, thread execution suspends when the method is entered, before any
line in the method is executed. 


4. 


Method breakpoints can also be setup to break on method exit.  In the Breakpoints view, select the breakpoint
and toggle the Exit  item in its context menu.


Method breakpoints can be removed, enabled, and disabled just like line breakpoints.


Breakpoints


Adding breakpoints
Removing breakpoints
Enabling and disabling breakpoints
Applying hit counts
Catching Java exceptions


Breakpoints view
Outline view for Java
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Breakpoints view
The Breakpoints view lists all the breakpoints you have set in the workbench projects. You can double−click a
breakpoint to display its location in the editor. In this view, you can also enable or disable breakpoints, delete
them, or add new ones.


This view also lists Java exception breakpoints, which suspend execution at the point where the exception is
thrown. You can add or remove exceptions.


Breakpoints
Java views


Adding breakpoints
Applying hit counts
Catching Java exceptions
Removing breakpoints
Enabling and disabling breakpoints
Managing conditional breakpoints
Setting method breakpoints


Views and editors
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Managing conditional breakpoints
An enabling condition can be applied to line breakpoints, so that the breakpoint suspends execution of a
thread in one of these cases:


when the enabling condition is true• 
when the enabling condition changes• 


To set a condition on a breakpoint:


Find the breakpoint to which an enabling condition is to be applied (in the Breakpoints view or in the
editor marker bar).


1. 


From the breakpoint's pop−up menu, select Breakpoint Properties....  The Breakpoint properties
dialog will open.


2. 


In the properties dialog, check the Enable Condition checkbox. 3. 
In the Condition field enter the expression for the breakpoint condition.4. 
Do one of the following:


If you want the breakpoint to stop every time the condition evaluates to true, select the
condition is 'true' option.  The expression provided must be a boolean expression.


♦ 


If you want the breakpoint to stop only when the result of the condition changes, select the
value of condition changes option.


♦ 


5. 


Click OK to close the dialog and commit the changes. While the breakpoint is enabled, thread
execution suspends before that line of code is executed if the breakpoint condition evaluates to true. 


6. 


A conditional breakpoint has a question mark overlay on the breakpoint icon.
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Views and editors


Java editor
Java views
Java Development Tools (JDT)


Changing the appearance of the console view
Changing the appearance of the Hierarchy view
Opening an editor for a selected element
Opening an editor on a type
Using content/code assist


Java editor actions
Breakpoints view
Console view
Debug view
Display view
Expressions view
Outline view for Java
Package Explorer view
Type Hierarchy view
Variables view
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Changing the appearance of the Hierarchy view
The Hierarchy view offers three different ways to look at a type hierarchy (use the toolbar buttons to alternate
between them):


Show the Type Hierarchy displays the type hierarchy of a type. This view shows all super− and
subtypes of the selected type. Type java.lang.Object is shown in the top−left corner. Interfaces are not
shown.


• 


Show the Supertype Hierarchy displays the supertype hierarchy of a type. This view shows all
supertypes and the hierarchy of all implemented interfaces. The selected type is always shown in the
top−left corner.


• 


Show the Subtype Hierarchy displays the subtype hierarchy of a type. This view shows all subtypes
of the selected type and all implementers of the selected interface (if the view is opened on an
interface). The selected type is always shown in the top−left corner.


• 


Java views


Using the Hierarchy view


Views and editors
Type Hierarchy view
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Using the Hierarchy view


Changing the appearance of the Hierarchy view
Opening a type hierarchy on a Java element
Opening a type hierarchy on the current text selection
Opening a type hierarchy in its own perspective
Overriding a method using the Hierarchy view
Finding overridden methods


Views and editors
Type Hierarchy view
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Opening a type hierarchy on a Java element
There are several ways to open a type hierarchy. Select a Java element in a Java view and:


Press F4 or• 
Choose Open Type Hierarchy from the view's pop−up menu or• 
Drag and drop the element to the Hierarchy view or• 
Press Ctrl+Shift+H and select a type from the list in the resulting dialog (this works only for classes
and interfaces) or


• 


Select Navigate > Open Type in Hierarchy from the menu bar or• 
Select Focus On... from the pop−up menu of the type hierarchy viewer.• 


Java development tools (JDT)


Changing new type hierarchy defaults
Creating Java elements
Using the Hierarchy view
Opening a type hierarchy on a Java element
Opening a type hierarchy on the current text selection
Opening a type hierarchy in the workbench
Opening a type hierarchy in its own perspective


Views and editors
Type Hierarchy view
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Changing new type hierarchy defaults
New type hierarchies can open in a Hierarchy view or in a Java Hierarchy perspective. You can indicate
which is the default method for opening new type hierarchies on the preferences pages.


Select Window > Preferences, and select the Java category. The general Java Preferences page
opens.


1. 


Use the radio buttons that appear under When opening a Type Hierarchy to indicate your preference.2. 


Java development tools (JDT)


Opening a type hierarchy on a Java element
Opening a type hierarchy on the current text selection
Opening a type hierarchy in the workbench
Opening a type hierarchy in its own perspective


Java Base preference page
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Opening a type hierarchy on the current text
selection
To open a type hierarchy on a text selection, select the name of a Java element in the editor, and do one of the
following:


Press F4• 
select Open Type Hierarchy from the editor's pop−up menu• 
select Navigate > Open Type Hierarchy from the menu bar• 


Note: If the selected Java element (or editor selection) is not a type or a compilation unit, the hierarchy opens
on the type enclosing the current selection.


Java editor


Using the Hierarchy view
Changing new type hierarchy defaults
Changing the appearance of the Hierarchy view
Opening a type hierarchy on a Java element
Opening a type hierarchy in the workbench
Opening a type hierarchy in its own perspective


Views and editors
Type Hierarchy view
Edit menu
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Opening a type hierarchy in the workbench
You can open a type hierarchy from a button in the workbench toolbar.


In the workbench toolbar, click the Open a Type in the Editor button.1. 
Select a type in the dialog.2. 
Select the Open in Type Hierarchy check box.3. 
Click OK.4. 


Java development tools (JDT)


Changing new type hierarchy defaults
Opening a type hierarchy on a Java element
Opening a type hierarchy on the current text selection
Opening a type hierarchy in its own perspective


Views and editors
Type Hierarchy view
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Opening a type hierarchy in its own perspective
The default behavior for opening the Hierarchy view is to replace the Hierarchy view that is already open in
the perspective. If there are no open Hierarchy views, one is opened automatically.


Sometimes, it is useful to look at or work with several type hierarchies in different perspectives. This can be
achieved by changing a workbench preference.


From the menu bar, select Window > Preferences and select the Java category. The general Java
Preferences page opens.


1. 


In the When Opening a Type Hierarchy category, select the radio button Open a new Type
Hierarchy Perspective.


2. 


Java perspectives


Using the Hierarchy view
Changing new type hierarchy defaults
Opening a type hierarchy on a Java element
Opening a type hierarchy on the current text selection
Opening a type hierarchy in the workbench


Views and editors
Type Hierarchy view
Java Base preference page
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Type Hierarchy view
This view shows the hierarchy of a type. The Type Hierarchy view consists of two panes:


Type Hierarchy tree pane• 
Member list pane (optional)• 


Type Hierarchy tree pane toolbar buttons


Button Command Description


Previous Hierarchy
Inputs


This menu displays a history of previously displayed type hierarchies.


Show the Type
Hierarchy


This command displays the type in its full context (i.e., superclasses
and subclasses) in the Hierarchy view. To see for which type the
hierarchy is shown, hover over the view title (e.g., "Types").


Show the Supertype
Hierarchy


This command displays the supertypes and the hierarchy of all
implemented interfaces of the type in the Hierarchy view. The tree
starts at the selected type and displays the result of traversing up the
hierarchy.


Note: The selected type is always at the top level, in the upper−left
corner.


Show the Subtype
Hierarchy


This command displays the subtypes of the selected class and/or all
implementers of the interface in the Hierarchy view. The tree starts at
the selected type and displays the result of traversing down the
hierarchy


Note: The selected type is always at the top level, in the upper−left
corner.


Vertical View
Orientation


Arranges the two panes vertically.


Horizontal View
Orientation


Arranges the two panes horizontally.


Hierarchy View Only Hides the member list pane.


Member list pane toolbar buttons


The member list pane displays the members of the currently selected type in the type hierarchy tree pane.


Button Command Description


Lock View and Show
Members in Hierarchy


Shows the members implementing the selected method Only
types implementing the method are shown.
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When the view is locked, the member list pane no longer
tracks the selection in the hierarchy pane above.


Show All Inherited Members Shows or hides all methods and fields inherited by base
classes. When this option is set, the name of the type that
defines the method is appended to the method name.


Sort Members by the
Defining Type


Sorts the members according to the type in which they are
defined.


Hide Fields Shows or hides the fields.


Hide Static Members Shows or hides the static fields and methods.


Hide Non−Public Members Shows or hides the static fields and methods.


Views and editors


 Basic tutorial
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Java
On this page, indicate your preferences for the general Java settings.


Java Preferences


Option Description Default


Update Java views
On save only:


Java elements displayed in all views except the Outline
view are not updated until a compilation unit is saved.
The views reflect the current state of the workspace,
without consideration of working copies.


While editing:
Java elements displayed in all views always reflect the
current state of the workspace, including working
copies.


While editing


Action on double
click in the
Package Explorer


Go into the selected element:
When you double click a container, a Go Into
command is executed.
See Go Into from the Navigate menu.


Expand the selected element:
When you double click a container, it is expanded and
its children are revealed.


Expand the selected
element


When opening a
Type Hierarchy Open a new Type Hierarchy Perspective


Opens a new Type Hierarchy perspective whenever a
Type Hierarchy view is opened.


Show the Type Hierarchy View in the current perspective
The Type Hierarchy view is displayed in the current
perspective.


Note: On the Workbench preferences page, you can choose
whether new perspectives open in a new window, in the current
window, or as a replacement for the current perspective.


Show the Type
Hierarchy View in
the current
perspective


Java views


Using the Package Explorer


Using the Hierarchy view
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Package Explorer view Hierarchy view
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Navigate actions
Navigate menu commands:


Name Function
Keyboard
Shortcut


Go Into Sets the view input to the currently selected element. Supported by the
Packages Explorer view.


Go To
Back: Sets the view input to the input back in history: Only enabled
when a history exists (Go Into was used)


• 


Forward: Sets the view input to the input forward in history: Only
enabled when a history exists (Go Into,  Go To > Back were used)


• 


Up One Level: Sets the input of the current view to its input's parent
element


• 


Referring Tests: Browse for all JUnit tests that refer to the currently
selected type


• 


Type: Browse for a type and reveal it in the current view. Supported
by the Package Explorer view


• 


Package: Browse for a package and reveal it in the current view.
Supported by the Package Explorer view


• 


Resource: Browse for a resource and reveal it in the current view.• 
Open Tries to resolve the element referenced at the current code selection and opens


the file declaring the reference. 
F3


Open Type
Hierarchy


Tries to resolve the element referenced at the current code selection and opens
the element in the Type Hierarchy view. Invoked on elements, opens the type
hierarchy of the element. Supported in the Java editor and views showing
Java elements.


F4


Open Super
Implementation


Open an editor for the super implementation of the currently selected method
or method surrounding the current cursor position. No editor is opened if no
method is selected or the method has no super implementation.


Open External
Javadoc


Opens the Javadoc documentation of the currently selected element or text
selection. The location of the Javadoc of a JAR or a project is specified in the
Javadoc Location property page on projects or JARs. Note that this external
Javadoc documentation may not be up to date with the Javadoc specified in
the current code. You can create Javadoc documentation for source files in a
Java project using the Javadoc export wizard. 


Shift + F2


Open Type Brings up the Open Type selection dialog to open a type in the editor.The
Open Type selection dialog shows all types existing in the workspace.


Ctrl +
Shift + T


Open Type In
Hierarchy


Brings up the Open Type selection dialog to open a type in the editor and the
Type Hierarchy view. The Open Type selection dialog shows all types that
exist in the workspace.


Ctrl +
Shift + H


Show in >
Package Explorer


Reveals the currently selected element (or the element surrounding the current
cursor position) in the Package Explorer view.


Show Outline Opens the lightweight outliner for the currently selected type. Ctrl + O


Go to Next
Problem


Selects the next problem. Supported in the Java editor. Ctrl + .
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Go to Previous
Problem


Selects the previous problem. Supported in the Java editor. Ctrl + ,


Go to Last Edit
Location


Reveal the location where the last edit occurred. Ctrl + Q


Go to Line
Opens an a dialog which allows entering the line number to which the editor
should jump to. Editor only.


Ctrl + L


Java views
Java development tools (JDT)


Opening an editor for a selected element
Showing an element in the Package Explorer
Opening a type in the Package Explorer
Opening an editor on a type
Opening a package
Opening a type hierarchy on a Java element
Opening a type hierarchy on the current text selection
Opening a type hierarchy in the workbench
Opening a type hierarchy in its own perspective


Package Explorer view
Type Hierarchy view
Javadoc Location properties
Javadoc export wizard
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Javadoc generation
This wizard allows you to generate Javadoc Generation.It is a user interface for the javadoc.exe tool available
in the Java JDK. Visit Sun's Javadoc Tool page for a complete documentation of the Javadoc tool.


First page


Type Selection:


Option Description


Select types for which
Javadoc will be generated


In the list, check or clear the boxes to specify exactly the types that you want to
export to the JAR file. This list is initialized by the workbench selection. Only
one project can be selected at once as only one project's classpath can be used
at a time when running the Javadoc tool.


Create Javadoc for members
with visibility Private: All members will be documented• 


Package: Only members with default, protected or public visibility will
be documented


• 


Protected: Only members with protected or public visibility will be
documented


• 


Public: Only members with public visibility will be documented
(default)


• 


Use Standard Doclet Start the Javadoc command with the standard doclet (default) 


Destination: select the destination to which the standard doclet will
write the generated documentation. The destination is a doclet specific
argument, and therefore not enabled when using a custom doclet.


• 


Use Custom Doclet Use a custom doclet to generate documentation 


Doclet name: Qualified type name of the doclet• 
Doclet class path: Classpath needed by the doclet class• 


Standard doclet arguments


Standard Doclet Arguments (available when Use standard doclet has been selected):


Option Description


Document title Specify a document title.
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Generate use page
Selected this option if you want the documentation to contain a
Use page.


Generate hierarchy tree
Selected this option if you want the documentation to contain a
Tree page.


Generate navigator bar Selected this option if you want the documentation to contain a
navigation bar (header and footer).


Generate index
Selected this option if you want the documentation to contain a
Index page.


Generate index per letter
Create an index per letter. Enabled when Generate Index is
selected. 


@author
Selected this option if you want to the @author tag to be
documented.


@version
Selected this option if you want to the @version tag to be
documented.


@deprecated
Selected this option if you want to the @deprecated tag to be
documented.


deprecated list
Selected this option if you want the documentation to contain a
Deprecated page. Enabled when the @deprecated option is
selected.


Select referenced classes to which Javadoc
should create links


Specify to which other documentation Javadoc should create
links when other types are referenced. 


Select All: Create links to all other documentation
locations


• 


Clear All: Do not create links to other documentation
locations


• 


Configure: Configure the Javadoc location of a
referenced JAR or project.


• 


Style sheet Select the style sheet to use


General arguments


General Javadoc Options:


Option Description


Overview Specifies that Javadoc should retrieve the text for the overview
documentation from the given file. It will be placed in
overview−summary.html.


Extra Javadoc options Add any number of extra options here: Custom doclet options,VM
options or JRE 1.4 compatibility options.
Note that arguments containing spaces must enclosed in quotes. For
arguments specifying html code (e.g. −header) use the &nbsp; or &quot;
to avoid spaces and quotes.


Save the settings of this Javadoc
export as an Ant script


Specify to store an Ant script that will perform the specified Javadoc
export without the need to use the wizard. Existing Ant script can be
modified with this wizard (Use Open Javadoc wizard' from the context
menu on the generated Ant script)
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Open generated index file in
browser


Opens the generated index.html file in the browser (Only available
when using the standard doclet)


Press Finish to start the Javadoc generation. If the destination is different to the location configured the
project's Javadoc Location page , you will be asked if you want to set the project's Javadoc location to the new
destination folder. By doing this, all invocations of Open External Javadoc will use the now created
documentation.


A new process will be started and the generation performed in the background. Open the Console view
(Window > Show View > Console) to see the progress and status of the generation.


Creating Javadoc documentation
File actions
Javadoc preferences
Javadoc Location properties


 Basic tutorial


 General arguments 94







Javadoc location page
This dialog lets you define the location of the Javadoc documentation for a JAR or a Java project.


You can reach this dialog the following ways:


Select a JAR or Java project, open the context menu and select Properties > Javadoc Location or
use Properties from the File menu


• 


In the Javadoc generation wizard, on the Standard doclet settings page, choose Configure• 


Javadoc can be attached to JARs or Java projects. For projects it documents the elements of all source folders,
for JARs, elements contained in the JAR are documented. The location is used by


Open External Javadoc in the Navigate menu to find the Javadoc location of an element• 
Context Help (F1) to point to a Javadoc location• 
Javadoc Export Wizard to link to other documentation or as default destination for a project's
documentation


• 


Valid locations are URLs that point to a folder containing the API documentation's index.html
and package−list file. Examples are:


file:///M:/JAVA/JDK1.2/DOCS/API/
http://java.sun.com/j2se/1.4/docs/api/


Option Description Default


Javadoc
Location


Specify the location of the generated Javadoc documentation. You can Browse
in the local file system for a Javadoc location (will result in a file:// URL) 


<empty>


Validate Validate the current location by trying to access the index.html and package−list
file with the given URL. If the validation was successful, you can directly open
the documentation. 


Creating Javadoc documentation
Specifying the location of the Javadoc command
Viewing Javadoc information
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Creating Javadoc documentation


Specifying the location of the Javadoc command
Using the Generate Javadoc wizard


Javadoc Generation wizard
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Specifying the location of the Javadoc command
The JDT uses the Javadoc command (typically available in JRE distributions) to generate Javadoc
documentation from source files.


To set the location of the Javadoc command:


Use the Window > Preferences > Java > Javadoc preferences page to enter the absolute (e.g.
C:\Java\14\jdk1.4\bin\javadoc.exe) path to the Javadoc command.


• 


Creating Javadoc documentation
Using the Generate Javadoc wizard


Javadoc Generation wizard
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Using the Generate Javadoc Wizard
Select the set (containing one or more elements) of packages, source folders or projects for which you want to
generate Javadoc documentation.


Open the Export wizard by doing one of the following:


Selecting Export from the selection's pop−up menu or• 
Selecting File > Export from the menu bar.• 


In the resulting dialog, select Javadoc from the list and press Next.


Creating Javadoc documentation
Specifying the location of the Javadoc command
Selecting types for Javadoc generation


Javadoc Generation wizard
Javadoc Location property page


Using the Generate Javadoc Wizard 98







Selecting types for Javadoc generation


In the tree control, select the elements for which you want to generate Javadoc.• 
Select the visibility using the radio buttons listed under Create Javadoc for members with visibility• 
Leave the Use Standard Doclet radio button selected• 
Specify the location for the generated Javadoc using the Destination field.• 
Press Finish to create generate Javadoc for the elements you selected or press Next to specify more
options.


• 


Creating Javadoc documentation
Using the Generate Javadoc wizard
Configuring Javadoc arguments for standard doclet
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Javadoc Generation wizard
Javadoc Location property page
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Configuring Javadoc arguments for standard
doclet


Use the checkboxes listed under Basic Options to specify Javadoc options.• 
You can change the tags that will be documented by using the checkboxes in the Document these tags
group.


• 


If you want references to classes from a library to be linked to the library's Javadoc, select the library
in the list and press Configure to specify the location of the library's Javadoc.


• 


Press Finish to generate Javadoc or press Next to specify additional Javadoc generation options.• 


Creating Javadoc documentation
Using the Generate Javadoc wizard
Selecting types for Javadoc generation
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Configuring Javadoc arguments


Javadoc Generation wizard
Javadoc Location property page
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Configuring Javadoc arguments


You can specify more specific options for the Javadoc command by entering them in the text area.• 
Select the Save the settings of this Javadoc export as an Ant script checkbox.• 
Specify the location for the Ant Script.• 
Select the Open generated index file in browser checkbox.• 
Press Finish to generate Javadoc.• 


Note: The output produced by the Javadoc command (including errors and warning) is shown in the Console
view.


Creating Javadoc documentation
Using the Generate Javadoc wizard
Selecting types for Javadoc generation
Configuring Javadoc arguments for standard doclet
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Javadoc Generation wizard
Javadoc Location property page
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File actions
File Menu Commands:


Name Function
Keyboard
Shortcut


New Create a Java element or a new resource. Configure which elements are shown in
the submenu in Window > Customize Perspective. In a Java perspective, by default
action for creating a project, package, class, interface , source folder, scrapbook, file
and folder are available.


Ctrl + N


Close Close the current editor. If the editor contains unsaved data, a save request dialog
will be shown.


Ctrl + F4


Close All Close all editors. If editors contains unsaved data, a save request dialog will be
shown.


Ctrl + Shift
+ F4


Save Save the content of the current editor. Disabled if the editor does not contain
unsaved changes.


Ctrl + S


Save As Save the content of the current editor under a new name.


Save All
Save the content of all editors with unsaved changes. Disabled if no editor contains
unsaved changes.


Ctrl + Shift
+ S


Revert Revert the content of the current editor back to the content of the saved file.
Disabled if the editor does not contain unsaved changes.


Move Move a resource. Disabled on Java Elements. To move Java elements use Refactor
> Move (with updating all references to the file) or Edit > Cut / Paste (no updating
of references).


Rename Renames a resource. Disabled on Java Elements. To rename Java elements use
Refactor > Rename (with updating all references to the file).


Refresh
Refreshes the content of the selected element with the local file system.When
launched from no specific selection, this command refreshes all projects.


Print Prints the content of the current editor. Enabled when an editor has the focus.Ctrl + P


Import Opens the import wizard dialog. JDT does not contribute any import wizards.


Export Opens the export wizard dialog. JDT contributes the JAR file export wizard and the
Javadoc generation wizard.


PropertiesOpens the property pages of the select elements. Opened on Java projects the Java
Build Path page and the Javadoc Location page are available. For JAR archives,
configure the JAR's Source Attachment and Javadoc Location here.


Alt + Enter


Exit Exit Eclipse


Java development tools (JDT)


Creating Java elements
Creating JAR Files
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New Java Project wizard
New Java Package wizard
New Java Class wizard
New Java Interface wizard
New Java Scrapbook Page wizard
JAR file exporter
Javadoc generation
Javadoc Location properties
Java Build Path properties
Source Attachment properties


 Basic tutorial
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New Java Package Wizard
This wizard helps you create a folder corresponding to a new Java package. The corresponding folder of the
default package always exists, and therefore doesn't have to be created.


Java Package Options


Option Description Default


Source
folder


Type or browse to select a container (project or
folder) for the new package.


The source folder of the element that was selected
when the wizard has been started.


Name Type a name for the new package <blank>


Creating a new Java package
File actions
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New Java Scrapbook Page Wizard
This wizard helps you to create a new Java scrapbook page in a project.


Create Java Scrapbook Page Options


Option Description Default


Enter or select the
parent folder


Type or browse the hierarchy below to select a container
(project or folder) for the scrapbook page.


The container of the
selected element


File name Type a name for the new file. The ".jpage " extension is
appended automatically when not added already.


<blank>


File actions
Java Scrapbook page
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Java scrapbook page
The scrapbook allows Java expressions to be run, inspected, and displayed, under the control of the debugger.


Note: Content assist (such as code assist) is available on scrapbook pages.


Java Scrapbook page buttons


Command
Name Description


Run Snippet Running an expression evaluates an expression but does not
display a result.


Display Displaying shows the result of evaluating an expression as a
string in the scrapbook editor.


Inspect Inspecting shows the result of evaluating an expression in the
Expressions view.


Terminate This command terminates the Java VM that is used to evaluate
expressions.


Set the Import DeclarationsThis commands sets the import declarations to be used for the
context of evaluating the code


Scrapbook


Creating a Java scrapbook page
Displaying the result of evaluating an expression
Inspecting the result of evaluating an expression
Executing an expression


New Java Scrapbook Page wizard
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Displaying the result of evaluating an expression
Displaying shows the result of evaluating an expression in the scrapbook editor.


In the scrapbook page, either type an expression or highlight an existing expression to be displayed.
For example: System.getProperties();


1. 


Click the Display button in the toolbar (or select Display from the selection's pop−up menu.)2. 
The result of the evaluation appears highlighted in the scrapbook editor. The result displayed is either


the value obtained by sending toString() to the result of the evaluation, or♦ 
when evaluating a primitive data type (e.g., an int ), the result is the simple value of the result.♦ 


3. 


For example:


Type and highlight new java.util.Date() in the editor, and click Display. A result such as
(java.util.Date) Tue Jun 12 14:03:17 CDT 2001 appears in the editor.


• 


As another example, type and highlight 3 + 4 in the editor, and press Display. The result (int) 7
is displayed in the editor.


• 


Scrapbook


Executing an expression
Inspecting the result of evaluating an expression
Viewing runtime exceptions


Java scrapbook page
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Executing an expression
Executing an expression evaluates an expression but does not display a result.


If you select the expression to execute and click the Execute button in the toolbar, no result is displayed, but
the code is executed.  


For example, if you type and highlight System.out.println("Hello World"), and click the
Execute button, Hello World appears in the Console view, but no result is displayed in the scrapbook editor or
the Expressions view.


Java views


Displaying the result of evaluating an expression
Inspecting the result of evaluating an expression
Viewing runtime exceptions


Expressions view
Console view
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Inspecting the result of evaluating an expression
Inspecting shows the result of evaluating an expression in the Expressions view.


In the scrapbook page, either type an expression or highlight an existing expression to be inspected.
For example: System.getProperties();


1. 


Click the Inspect button in the toolbar (or select Inspect from the selection's pop−up menu).2. 
The result of the inspection appears in a pop−up. 3. 
The result can be inspected like a variable in the debugger (for example, children of the result can be
expanded).


4. 


Scrapbook


Creating a Java scrapbook page
Displaying the result of evaluating an expression
Executing an expression
Viewing runtime exceptions


Expressions view
Java scrapbook page
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Viewing runtime exceptions
If an expression you evaluate causes a runtime exception, the exception will be reported in the editor. For
example:


Type and select the expression Object x = null; x.toString() in the editor and click Display in
the toolbar.


The error message:


An exception occurred during evaluation: java.lang.NullPointerException


will be displayed in the editor.


Java editor


Displaying the result of evaluating an expression
Inspecting the result of evaluating an expression
Executing an expression
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Expressions view
Data can be inspected in the Expressions view. You can inspect data from a scrapbook page, a stack frame of
a suspended thread, and other places. The Expressions view opens automatically when an item is added to the
view.


Java views
Java perspectives
Scrapbook


Evaluating expressions
Suspending threads


Views and editors
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JAR file exporter
This wizard allows you to create a JAR file.


JAR package specification


JAR Specification Options:


Option Description


Select the resources to exportIn the list, check or clear the boxes to specify exactly the files that you want to
export to the JAR file. This list is initialized by the workbench selection.


Export generated class files
and resources


If you want to export generated CLASS files and resources, select this option.


Export java source files and
resources


If you want to export JAVA source files and resources, select this option.


Select the export destinationEnter an external file system path and name for a JAR file (either new or
existing). Either type a valid file path in the field or click Browse to select a
file via a dialog.


Options You can select any of the following options:


Compress the contents of the JAR file : to create a compressed JAR
file


• 


Overwrite existing files without warning : if an existing file might be
overwritten, you are prompted for confirmation. This option is
applied to the JAR file, the JAR description, and the manifest file.


• 


JAR packaging options


JAR Options:


Option Description


Select options for handling
problems


Choose whether to export classes with certain problems:


Export class files with compile errors• 
Export class files with compile warnings• 


Create source folder structure
Selected this option if you want the source folder structure to be rebuilt
in the JAR. This option is only enabled when source files but no class
files are exported. 


Build projects if not build
automatically


Select this option to force a rebuild before exporting. It is recommended
to build be before exporting so the exported class files ar up to date.


Save the description of this JAR in
the workspace


If you select this option, you can create a file in the workbench
describing the JAR file you are creating. Either type and/or browse to
select a path and name for this new file.
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JAR manifest specification


JAR Manifest Specification Options (Available when class file are exported):


Option Description


Specify the manifest Choose the source of the manifest file for this JAR file:


Generate the manifest file (you can also choose either to save or reuse
and save the new manifest file)


• 


Use existing manifest from workspace• 
Seal contents Choose which packages in the JAR file must be sealed:


Seal the JAR: to seal the entire JAR file; click Details to exclude
selectively


• 


Seal some packages; click Details to choose selectively• 


Note: This option is only available if the manifest is generated.


Select the class of the
application entry point 


Type or click Browse to select the main class for the JAR file, if desired.


Note: This option is only available if the manifest is generated.


Creating JAR Files


File actions


 Basic tutorial
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Creating JAR files
You can create and regenerate JAR files in the workbench.


Creating a new JAR file
Regenerating a JAR file


JAR file exporter
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Creating a new JAR file
To create a new JAR file in the workbench:


In the Package Explorer, you can optionally pre−select one or more Java elements to export. (These
will be automatically selected in the JAR Package Specification wizard page, described in Step 4.)


1. 


Either from the context menu or from the menu bar's File menu, select Export.2. 
Select JAR file, then click Next.3. 
In the JAR Package Specification page, select the resources that you want to export in the Select the
resources to export field.


4. 


Select the appropriate check box to specify whether you want to Export generated class files and
resources or Export java source files and resources. Note: Selected resources are exported in both
cases.


5. 


In the Select the export destination field, either type or click Browse to select a location for the JAR
file.


6. 


Select or clear the Compress the contents of the JAR file check box.7. 
Select or clear the Overwrite existing files without warning check box. If you clear this check
box, then you will be prompted to confirm the replacement of each file that will be overwritten.


8. 


Note: The overwrite option is applied when writing the JAR file, the JAR description, and the
manifest file.


9. 


You have two options:
Click Finish to create the JAR file immediately.♦ 
Click Next to use the JAR Packaging Options page to set advanced options, create a JAR
description, or change the default manifest.


♦ 


10. 


Java development tools (JDT)


Adding a JAR file to the build path
Attaching source to a JAR file
Defining the JAR file's manifest
Setting advanced options


JAR file exporter
Package Explorer
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Adding a JAR file to the build path
You can add a JAR file stored either in the workbench or anywhere in your file system to the build class path.


To add a JAR to your build class path follow these steps:


Select the project, and from its pop−up menu, select Properties. In the Properties dialog, select the
Java Build Path page.
Click the Libraries tab.
You can now either add a JAR file which is contained in your workspace or which is somewhere else:


to add a JAR file which is inside your workspace click the Add JARs button♦ 
to add an external JAR file click the Add External JARs button♦ 


1. 


In the dialog that appears, select the JAR file that you want to add. Note that you can add multiple
JARs at once.


2. 


Java builder
Build classpath


Adding a library folder to the build path
Building a Java program
Building automatically
Building manually
Creating a new JAR file
Viewing and editing a project's build path
Working with build paths


Java Build path
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Adding a library folder to the build path
A library folder is an ordinary folder containing a collection of class files inside the workbench. Use this
format for a library when a library is not packaged as a JAR file.


To add a library folder to the project's build class path, follow these steps:


Select the project, and from its context menu, select Properties.1. 
In the Properties dialog, select the Java Build Path page.2. 
Click the Libraries tab.3. 
Click the Add Class Folder button.4. 
In the dialog that appears, select a folder to add press the OK button. If you want to add a not yet
existing folder use first Create New Folder. After the folder is created select the new folder and press
the OK button


5. 


Java builder
Build classpath


Adding a JAR file to the build path
Building a Java program
Building automatically
Building manually
Viewing and editing a project's build path
Working with build paths


Java Build Path
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Building a Java program
A build command compiles workbench resources. A build command can be triggered in different ways:


Building automatically: If auto build is turned on (Window > Preferences > Perform build
automatically on resource modification), then an incremental build occurs every time you save a
modified workbench resource.


• 


Building manually: You can perform a manual build using a keyboard shortcut, a project's pop−up
menu or the Project menu in the menu bar.


• 


Build classpath
Java builder


Building automatically
Building manually
Adding a JAR file to the build path
Adding a library folder to the build path
Viewing and editing a project's build path
Working with build paths


Java Build Path
Project menu
Compiler preferences
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Building automatically
To enable automatic building:


Select the Window > Preferences > Perform build automatically on resource modification
check box.


To disable automatic building:


Clear the Window > Preferences > Perform build automatically on resource modification
check box.


Java builder
Build class path


Building a Java program
Building manually
Viewing compilation errors and warnings
Working with build paths
Adding a JAR file to the build path
Adding a library folder to the build path
Viewing and editing a project's build path


Java Build path
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Building manually


Incremental build


The Build command performs an incremental build that compiles all resources modified since the last build.
To trigger an incremental build, either:


press Ctrl+B or• 
from the menu bar, select Project > Build All• 


Incremental project build


You can also incrementally build single projects. Select the project that you want to build and:


Select Project > Build Project from the menu bar or• 
Select Build Project from the project's pop−up menu• 


Full build


To rebuild all workbench resources that have an associated builder (e.g. Java projects), select Project >
Rebuild All from the menu bar.


Full project build


To rebuild all resources contained in a project, select the project and select Project > Rebuild Project from the
menu bar.


Java builder
Build classpath


Building a Java program
Building automatically
Working with build paths
Adding a JAR file to the build path
Adding a library folder to the build path
Viewing and editing a project's build path


Java Build path
Project menu
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Working with build paths
Setting up the proper Java build path is an important task when doing Java development. Without the correct
Java build path, you cannot compile your code. In addition, you cannot search or look at the type hierarchies
for Java elements.


Java builder
Build classpath


Viewing and editing a project's build path
Adding a JAR file to the build path
Adding a library folder to the build path
Adding source code as individual files
Assigning the default JRE for the workbench
Building a Java program
Building automatically
Building manually
Choosing a JRE for launching a project


Java Build path
Installed JREs preference page
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Viewing and editing a project's Java build path
A project's Java build path can either be defined when creating the project with the New Wizard or later in the
project's property dialog. The Java build path settings dialog is the same in both cases. To view and edit a
project's Java build path, follow these steps:


Select the project you want to view or edit1. 
From the project's pop−up menu, select Properties2. 
Select the Java Build Path page3. 
Define the source entries for the build path on the Source page:


Click the Add Folder button to add source folders to the Java build path.
The Remove button removes the selected folder(s) from the build path.
Edit lets you modify the selected entry.


♦ 
4. 


On the Projects page, identify the other projects that are required for building this project. The list
shows all the existing Java projects from the workbench. Note: Each selected project is automatically
added to the list of referenced projects.


5. 


On the Libraries page, define the libraries required by your project. Libraries come in different forms.
There are buttons for adding a library in each form. By default, each Java project has a 'JRE System
Library' entry on the build path. This entry stands for the workbench's default JRE.


6. 


On the Order and Export page, define the Java build path order. The recommended ordering is to
have source entries before the library entries and the required projects.


7. 


Java builder
Build classpath


Adding a JAR file to the build path
Adding a library folder to the build path
Adding a variable class path entry
Building a Java program
Working with build paths
Working with JREs


Java Build path
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Adding a classpath variable to the build path
To add a classpath variable to the Java build path of a project, follow these steps:


Select the project to which you want to add the classpath variable1. 
From the project's pop−up menu, select Properties2. 
In the Properties page, select the Java Build Path page.3. 
On the Libraries tab, click Add Variable for adding a variable that refers to a JAR file.
The New Variable Classpath Entry dialog appears which shows all available classpath variables.


4. 


Select a classpath variable then press OK.
If the variable resolves to a folder, you can specify a path extension that points to a JAR. To
do this press the Extend... button.


♦ 


Press Edit... to create a new classpath variable or edit an existing one.♦ 


5. 


Hint: You can add multiple variable entries at once to the Java build path: Select more than one variable in the
New Variable Classpath Entry dialog, or multiple JAR files in the Variable Extension dialog.


Classpath variables
Build classpath
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Attaching source to a class path variable
Creating Java elements
Defining a class path variable
Deleting a class path variable
Viewing and editing a project's build path


Classpath Variables preference page
Build path properties page


 Basic tutorial
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Attaching source to a class path variable
When attaching source for a class path variable entry, both the path to the Archive and the Root Path must be
defined by variables. Follow these steps to make a source attachment for a variable:


Select the project, and from its pop−up menu, select Properties.
In the Properties dialog, select the Java Build Path page.


1. 


On the Libraries tab, select the class path variable to which you want to attach source.
Expand the node by clicking on the plus and select the node Source Attachment. Click the Edit button
to bring up the source attachment dialog.


2. 


In Location variable path field, use a variable to define the location of the archive. Use the Variable
button to select an existing variable and the Extension button to append an optional path extension.


3. 


Click OK.4. 


Classpath variables


Adding a variable class path entry
Defining a class path variable
Deleting a class path variable


Classpath Variables preference page
Source Attachment dialog
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Defining a classpath variable
Classpath variables are stored global to the workbench; in other words, all projects in the workbench can share
the classpath variables.


To add or change a class path variable, follow these steps:


From the menu bar, select Window > Preferences.
Expand the Java category in the left pane, and select Classpath Variables.


1. 


This page allows you to add, edit, or remove class path variables.
To add a new class path variable, click the New... button. The New Variable Entry page
opens.


♦ 


To edit an existing class path variable, select the variable in the Defined class path variables
list and click the Edit... button. The Edit Variable Entry page opens. Note: The reserved class
path variables, JRE_LIB, JRE_SRC, and JRE_SRCROOT cannot be edited in this page. To
change them, change the default workbench JRE on the Installed JREs page (Window >
Preferences > Java > Installed JREs).


♦ 


Type a name for the variable in the Name field.


2. 


Type a path to be referenced by the variable in the Path field. You can also click the File or Folder
buttons to browse the file system.


3. 


Click OK when you are done. The new or modified variable appears in the Defined class path
variables list on the Preferences page.


4. 


Classpath variables


Adding a variable class path entry
Attaching source to a class path variable
Creating Java elements
Deleting a class path variable


Classpath Variables preference page
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Deleting a classpath variable
To delete an existing class path variable:


From the menu bar, select Window > Preferences.1. 
Expand the Java category in the left pane, and select Classpath Variables.2. 
Select the variable(s) you want to delete in the Defined class path variables list and click the Remove
button. The variable(s) are removed from the classpath variables list on the preferences page.


3. 


Note: The reserved class path variables, JRE_LIB, JRE_SRC, and JRE_SRCROOT cannot be deleted. 


Classpath variables


Adding a variable class path entry
Attaching source to a class path variable
Creating Java elements
Defining a class path variable


Classpath Variables preference page
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Classpath variables


Configurable variables


Classpath variables can be used in a Java Build Path to avoid a reference to the local file system. Using a
variable entry, the classpath only contains a variable and the build path can be shared in a team. The value of
the variable has to be configured on this page.


Command Description


New... Adds a new variable entry. In the resulting dialog, specify a name and path for the new
variable. You can click the File or Folder buttons to browse for a path. 


Edit... Allows you to edit the selected variable entry. In the resulting dialog, edit the name and/or path
for the variable. You can click the File or Folder buttons to browse for a path. 


Remove Removes the selected variable entry. 


Reserved class path variables


Certain class path variables are set internally and can not be changed in the Classpath variables preferences:


JRE_LIB: The archive with the runtime JAR file for the currently used JRE.• 
JRE_SRC: The source archive for the currently used JRE.• 
JRE_SRCROOT: The root path in the source archive for the currently used JRE.• 


Classpath variables


Working with JREs
Working with build paths
Adding a variable classpath entry
Attaching source to a classpath variable
Defining a classpath variable
Deleting a classpath variable


Installed JREs
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Working with JREs
You can install as many different Java Runtime Environments (JREs) as you like. A JRE definition consists
of:


The type of the JRE (e.g. Standard VM or Standard 1.x.x VM)• 
A name• 
The location where the JRE is installed• 
The location (URL) of the Javadoc• 
The system libraries containing the Java system classes (like java.lang.Object). Optionally, the system
libraries can be associated with the source file containing the source for the classes in the JRE's
CLASS files


• 


You can switch the default JRE for the workbench. The default JRE is the JRE to which the pre−defined
classpath variables JRE_LIB, JRE_SRC and JRE_SRCROOT are bound.


Java development tools (JDT)
Classpath variable


Adding a new JRE definition
Assigning the default JRE for the workbench
Choosing a JRE for launching a project
Deleting a JRE definition
Editing a JRE definition
Overriding the default system libraries for a JRE definition
Viewing and editing a project's build path


Installed JREs preference page
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Adding a new JRE definition
You can add any number of JRE definitions.


From the menu bar, select Window > Preferences.1. 
In the left pane, expand the Java category and select Installed JREs.2. 
Click the Add... button. The Create JRE dialog opens.3. 
In the JRE type field, select the type of JRE you want to add from the drop−down list.4. 
In the JRE name field, type a name for the new JRE definition. All JREs of the same type must have
a unique name.


5. 


In the JRE home directory field, type or click Browse to select the path to the root directory of the
JRE installation (usually the directory containing the bin and lib directories for the JRE). This location
is checked automatically to make sure it is a valid path.


6. 


In the Javadoc URL field, type or click Browse to select the URL location. The location is used by
the Javadoc export wizard as a default value and by the 'Open External Javadoc' action.


7. 


If you want to use the default libraries and source files for this JRE, select the Use default system
libraries check box. Otherwise, clear it and customize as desired. Source can be attached for the
referenced JARs as well.


8. 


Click OK when you are done.9. 


Java development tools (JDT)


Working with JREs
Assigning the default JRE for the workbench
Editing a JRE definition
Overriding the default system libraries for a JRE definition


Installed JREs preference page
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Assigning the default JRE for the workbench
The default JRE is used for compiling and launching Java programs in all projects unless you specifically
override the default JRE. The default JRE is the installed JRE to which JRE_LIB, JRE_SRC and
JRE_SRCROOT are bound. A project is not compiled against the default JRE if the JRE_LIB variable has
been removed from its build path. A program is not launched with the default JRE if a custom runtime JRE
has been set for its project.


Here is how you can change the default JRE:


From the workbench's menu bar, select Window > Preferences.1. 
Expand the Java category in the left pane and select Installed JREs.2. 
Check the box on the line for the JRE that you want to assign as the default JRE in your workbench. If
the JRE you want to assign as the default does not appear in the list, you must add it.


3. 


Click OK.4. 


Note: The JRE_LIB, JRE_SRC and JRE_SRCROOT system variables are automatically updated when you
change the default JRE. This may cause a build to occur if you have auto build enabled (Window >
Preferences > Workbench > Perform build automatically on resource modification).


Java development tools (JDT)


Adding a new JRE definition
Choosing a JRE for launching a project
Working with build paths
Working with JREs


Installed JREs preference page
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Choosing a JRE for a launch configuration
Instead of using the default JRE for running and debugging all Java Application launch configurations, you
can specifically assign a JRE for launching an individual configuration.


With a Java Application configuration selected in the Launch Configuration Dialog, select the JRE
tab.


1. 


In the list of available JREs, select the JRE you want to use to launch this configuration and click
Apply, Run, or Debug.


2. 


Note: Changing the JRE used for running does not affect the way Java source is compiled. You can adjust the
build path to compile against custom libraries. 


Java development tools (JDT)


Assigning the default JRE for the workbench
Running and debugging
Working with build paths
Working with JREs
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JRE installations
Classpath Variable Preferences


Option
Description


Add... Adds a new JRE definition to the workbench. In the resulting dialog, specify the following:


JRE type: (select a VM type from the drop−down list)• 
JRE name: Type a name for this JRE definition• 
JRE home directory: Type or browse to select the root directory for this JRE installation• 
Javadoc URL: Type or browse to select the URL location. The location is used by the
Javadoc export wizard as a default value and by the 'Open External Javadoc' action.
Debugger timeout: Type the default timeout for this JRE's debugger (in ms)


• 


Either check the box to use the default library locations for this JRE or clear the check box
and type or browse to select library locations for the following:


JAR file (e.g., classes.zip)♦ 
Source file (e.g., source.zip)♦ 


• 


You can click the Browse buttons to browse for paths.


Edit... Allows you to edit the selected JRE.


Remove Removes the selected JRE from the workbench.


Search...Automatically searches for JREs installed in the local file system and creates corresponding JRE
definitions in the workspace.


Classpath variables


Working with JREs


Source Attachment
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Source attachments
To browse the source of a type contained in library you can attach a source archive or source folder to this
library. The editor will then show the source instead of a the decompiled code. Having the source attachment
set the debugger can offer source level stepping in this type.


The Source Attachment dialog can be reached in several ways:


Select a JAR in the Package Explorer and choose Properties > Java Source Attachment from the
context menu or the Project menu


• 


Open the Java Build Path page of a project (Projects > Properties > Java Build Path). On the
Libraries page expand the library's node and select the Source attachment attribute and press Edit


• 


Open an editor on a class file. If the source attachment has not already been configured for this JAR,
the editor contains a button Attach Source


• 


Depending of how a JAR was contributed to the classpath, you can see different types of Source attachment
dialogs:


JAR


In the Location path field, enter the path of an archive or a folder containing the source. Use either the
Workspace, External File or the External Folder button to browse for a location.


Variable


In the Location Variable Path field enter a variable path that points to the source attachment's location. A
variable path has as first segment a variable (which will resolve to a folder or file), the rest is an optional path
extension (e.g.MYVARIABLE/src.jar ). Use either the Variable button to select an existing variable and the
Extension button to select the extension path. The Extension button is only enabled when the variable can be
extended (resolves to a folder)


JRE_SRC is a reserved variable that points to a JRE selected in the Installed JREs preference page (Window
> Preferences > Java > Installed JREs). Go to this preference page to configure the source attachment for the
JRE's library..


Build classpath


Working with build paths
Attaching source to variables
Attaching source to a JAR file
Installed JREs preferences
Java Build Path properties
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Project actions
Project menu commands:


Name Function
Keyboard
Shortcut


Open Project Shows a dialog that can be used to select a closed project and open it


Close Project Closes the currently selected projects


Build Project Builds the currently selected project. This is an incremental build, means that
the builder analyzes the changes since the last time of build and minimizes the
number of changed files.


Rebuild
Project


Rebuilds the currently selected project. This is a full build, all files in the
project are rebuild.


Build All Builds the all projects in the workspace. This is an incremental build, means
that the builder analyzes the changes since the last time of build and minimizes
the number of changed files.


Ctrl + B 


Rebuild All Rebuilds all projects in the workspace. This is a full build, all files are rebuild.


Generate
Javadoc...


Opens the Generate Javadoc wizard on the currently selected project.


Properties Opens the property pages on the currently selected project.


Java projects
Java builder


Building a Java program


Java projects
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Attaching source to a JAR file
You can attach source to a JAR file to enable source−level stepping and browsing of classes contained in a
binary JAR file. Unless its source code is attached to a JAR file in the workbench, you will not be able to view
the source for the JAR file.


To attach source to a JAR file:


Select the project, and from its pop−up menu, select Properties.
In the Properties dialog, select the Java Build Path page.


1. 


On the Libraries tab, select the JAR file to which you want to attach source.
Expand the node by clicking on the plus and select the node Source Attachment. Click the Edit button
to bring up the source attachment dialog.


2. 


Fill in the Location path field depending on the location, choose between the workspace, an external
file or external folder.


3. 


Click OK.4. 


Java development tools (JDT)


Attaching source to variables
Creating a new JAR file
Stepping through the execution of a program


Java Build Path
Source Attachment dialog
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Java Build Path page
The options in this page indicate the build path settings for a Java project.
You can reach this page through


the New Java Project wizard• 
the Java Build Path property page (Project > Properties > Java Build Path) from the context menu on
a created project or the File menu


• 


The build class path is a list of paths visible to the compiler when building the project.


Source tab


Source folders are the root of packages containing .java files. The compiler will translate the contained files to
.class files that will be written to the output folder. The output folder is defined per project except if a source
folder specifies an own output folder. Each source folder can define an exclusion filter to specify which
resources inside the folder should not be visible to the compiler.
Resources existing in source folders are also copied to the output folder unless the setting in the Compiler
preference page (Window > Preferences > Java > Compiler > Build Path) specifies that the resource is
filtered.


Source folder options


Option Description


Add Folder Creates a new folder to contain source


Edit Allows to modify the currently selected source folder or source folder
attribute.


Remove
Removes the selected folders from the class path. This does not delete the
folders nor their contents.


Allow output
folder per source
folder


Shows/Hides the 'output folder' attribute of the source folders


Source folder have the following attributes (Source Folders have the following attributes (presented as source
folder children nodes):


Source folder attributes


Attribute Description


Exclusion filter Selects which resources are not visible to the compiler


Output folder Only available when Allow output folder per source folder is checked.
Defines a source folder specific output location. If not set the project's
default output folder is used.


The source folders offered as default by the New Java Project wizard are configured in the New Project
preference page (Window > Preferences > Java > New Project).
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Projects tab


In the Required projects on the build path list, you can add project dependencies by selecting other
workbench projects to add to the build path for this new project. The Select All and Deselect All buttons can
be used to add or remove all other projects to or from the build path.


Adding a required project indirectly adds all its classpath entries marked as 'exported'. Setting a classpath
entry as exported is done in the Order and Export tab.


The projects selected here are automatically added to the referenced projects list. The referenced project list is
used to determine the build order. A project is always build after all its referenced projects are built.


Libraries tab


On this page, you can add libraries to the build path. You can add:


Workbench−managed (internal) JAR files• 
File system (external) JAR files• 
Folders containing CLASS files• 
Predefined libraries like the JRE System Library• 


JAR files can also be added indirectly as class path variables.


By default, the library list contains an entry representing the Java runtime library. This entry points to the JRE
selected as the default JRE. The default JRE is configured in the Installed JREs preferences page (Window >
Preferences > Java > Installed JREs)


Libraries tab options


Option Description


Add JARs Allows you to navigate the workbench hierarchy and select JAR files to add
to the build path.


Add External
JARs


Allows you to navigate the file system (outside the workbench) and select
JAR files to add to the build path.


Add Variable Allows you to add classpath variables to the build path. Classpath variables
are an indirection to JARs with the benefit of avoiding local file system paths
in a classpath. This is needed when projects are shared in a team.
Variables can be created and edited in the Classpath Variable preference
page (Window > Preferences > Java > Classpath Variables)


Add Library
Allows to add a predefined libraries like the JRE System Library. Such
libraries can stand for an arbitrary number of entries (visible as children node
of the library node)


Add Class Folder
Allows to navigate the workbench hierarchy and select a class folder for the
build path. The selection dialog also allows you to create a new folder.


Edit Allows you to modify the currently selected library entry or entry attribute


Remove Removes the selected element from the build path. This does not delete the
resource.
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 Libraries have the following attributes (presented as library entry children nodes):


Library entry attributes


Attribute Description


Javadoc location Specifies where the library's Javadoc documentation can be found. If
specified you can use Shift+F2 on an element of this library to open its
documentation.


Source attachmentSpecifies where the library's source can be found.


Order and Export tab


In the Build class path order list, you can click the Up and Down buttons to move the selected path entry up
or down in the build path order for this new project.


Checked list entries are marked as exported. Exported entries are visible to projects that require the project.
Use the Select All and Deselect All to change the checked state of all entries. Source folders are always
exported, and can not be deselected.


Default output folder


At the bottom of this page, the Default output folder field allows you to enter a path to a folder path where
the compilation output for this project will reside. The default output is used for source folders that do not
specify an own output folder. Use Browse to select an existing location from the current project. The default
for this field is configured in the New Project preference page (Window > Preferences > Java > New Project).


Build classpath
Classpath variables


Working with build paths
Attaching source to variables
Attaching source to a JAR file
Frequently asked questions on JDT
Classpath Variables preferences
Java Compiler properties
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New Java Project Wizard
This wizard helps you create a new Java project in the workbench.


Project name page


Option Description Default


Project
name


Type a name for the new project. <blank>


Use defaultIf checked, the default workbench location is used as location for new projectSelected


Directory The location of the project contents. If the Use default checkbox is unchecked, the
location can be set to an existing directory on the file system. The new project will
contain files and folders existing at the given directory.


<workbench
directory>


Java settings page


You can skip this page by pressing Finish on the first page. The project will then be configured with default
options specified in the New Project preference page. Otherwise press Next to configure the Java Build Path.
If the project location on the first page has been set to an existing directory, you will be prompted if the New
Java Project wizard should try to detect existing classpath settings. To do this the project will be created early
on the invocation of the Next button, and the Back will be disabled on the Java Settings page.


Java projects


Creating a new Java project
File actions
New Project preferences
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New project


Option Description Default


Source and output
folder Project:


Both source and output locations are set to the project's root.
Folders:


Source and output locations can be set individually.


To specify the source and output locations, set Source folder
name and Output location name.


Project


Source folder name The location of source files. 'src'


Output location
name


The location of output files. 'bin'


As JRE library use Specify which JRE library to use.


JRE container
A JRE container.


JRE_LIB variable
The JRE specified by the JRE_LIB variable.


JRE
container


Java projects


Creating a new Java project
Working with JREs


New Java Project wizard
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Compiler
The compiler preferences are separated in the following sections:


Problems• 
Style• 
Compliance and Class files• 
Build Path• 


Problems


Option Description Default


Unreachable code Unreachable code can optionally be
reported as an error, warning or
simply ignored. The byte code
generation will always optimized it
out. Note that according to the Java
language specification, unreachable
code should be an error.


Error


Unresolvable import statements An import statement that cannot be
resolved might optionally be reported
as an error, as a warning or ignored.
Note that according to the Java
language specification, unresolved
import statements should be an error.


Error


Unused local variables (i.e. never read) When enabled, the compiler will
issue an error or a warning for unused
local variables (i.e. variables never
read from).


Ignore


Unused parameters (i.e. never read) When enabled, the compiler will
issue an error or a warning for unused
method parameters (i.e. parameters
never read from).


Ignore


Unused imports When enabled, the compiler will
issue an error or a warning for unused
import reference.


Warning


Unused private types, methods or fields When enabled, the compiler will
issue an error or a warning whenever
a private method or field is declared
but never used within the same unit.


Ignore


Usage of non−externalized strings When enabled, the compiler will
issue an error or a warning for non
externalized String literal (i.e. non
tagged with //$NON−NLS−<n>$). 


Ignore
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Usage of deprecated API When enabled, the compiler will
signal use of deprecated API either as
an error or a warning.


Warning


Signal use of deprecated API inside
deprecated code


When enabled, the compiler will
signal use of deprecated API inside
deprecated code. The severity of the
problem is controlled with option
"Usage of deprecated API".


Off


Maximum number of problems reported
per compilation unit


Specifies the maximum number of
problems reported per compilation
unit. 


100


Style


Option Description Default


Methods overridden but
not package visible


A package default method is not visible in a different
package, and thus cannot be overridden. When enabling
this option, the compiler will signal such scenario either as
an error or a warning.


Warning


Methods with a constructor
name


Naming a method with a constructor name is generally
considered poor style programming. When enabling this
option, the compiler will signal such scenario either as an
error or a warning.


Warning


Conflict of interface
method with protected
'Object' method


When enabled, the compiler will issue an error or a
warning whenever an interface defines a method
incompatible with a non−inherited Object method. Until
this conflict is resolved, such an interface cannot be
implemented, e.g.


interface I {
   int clone();
}


Warning


Hidden catch blocks Locally to a try statement, some catch blocks may hide
others , e.g.


try { throw new
java.io.CharConversionException();
} catch
(java.io.CharConversionException e) {
} catch (java.io.IOException e) {}.


When enabling this option, the compiler will issue an error
or a warning for hidden catch blocks corresponding to
checked exceptions.


Warning
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Non−static access to a
static member


When enabled, the compiler will issue an error or a
warning whenever a static field or method is accessed with
an expression receiver. A reference to a static member
should be qualified with a type name.


Warning


Access to a non−accessible
member of an enclosing
type


When enabled, the compiler will issue an error or a
warning whenever it emulates access to a non−accessible
member of an enclosing type. Such accesses can have
performance implications.


Ignore


Assignment has no effect
(e.g. 'x = x')


When enabled, the compiler will issue an error or a
warning whenever an assignment has no effect (e.g. 'x =
x').


Warning


Using a char array in
string concatenation


When enabled, the compiler will issue an error or a
warning whenever a char[] expression is used in String
concatenations,


"hello" + new
char[]{'w','o','r','l','d'}


Warning


Compliance and Class files


Option Description Default


Compiler compliance
level


Specifies the JDK compiler compliance level. 1.3


Use default compliance
settings


If enabled, the default compliance settings for the compiler compliance
level are applied. 


On


Generated class files
compatibility


Specifies the generated class file compatibility. 1.1


Source compatibility Specify whether source is 1.3 or 1.4 compatible. From 1.4 on, 'assert' is
a keyword reserved for assertion support.


1.3


Report 'assert' as
identifier


When enabled, the compiler will issue an error or a warning whenever
'assert' is used as an identifier (reserved keyword in JDK 1.4).


Ignore


Add variable attributes
to generated class files


If enabled, variable attributes are added to the class file. This will
enable local variable names to be displayed in the debugger (in places
where variables are definitely assigned) The resulting .class file is then
bigger.


On


Add line number
attributes to generated
class files


If enabled, line number information is added to the class file. This will
enable source code highlighting in the debugger.


On


Add source file name to
generated class file


If enabled, the source file name is added to the class file. This will
enable the debugger to present the corresponding source code.


On


Preserve unused local
variables


If enabled, unused local variables (i.e. never read) are not stripped
from the class file. If stripped this potentially alters debugging.


On
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Build Path


Option Description Default


Incomplete build path Indicate the severity of the problem reported when an entry on
the classpath does not exist, is not legitimate or is not visible
(e.g. a reference project is closed).


Error


Circular dependencies Indicate the severity of the problem reported when a project is
involved in a cycle.


Error


Duplicated resources Indicate the severity of the problem reported when more than
one occurrence of a resource is to be copied into the output
location.


Warning


Abort building on build path
errors


Allow to toggle the builder to abort if the classpath is invalid. On


Scrub output folders on full
build


Indicate whether the Java Builder is allowed to clean the output
folders when performing full build operations.


On


Enable using exclusion
patterns in source folders


When disabled, no entry on a project classpath can be associated
with an exclusion pattern.


On


Enable using multiple output
locations for source folders


When disabled, no entry on a project classpath can be associated
with a specific output location, preventing thus usage of
multiple output locations.


On


Filtered resources A comma separated list of file patterns which are not copied to
the output folder. 


''


Java builder


Building a Java program
Working with build paths
Working with JREs


Classpath Variables preferences
Java Build Path properties
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Installed JREs
Check the box for the JRE that you want to act as your default for running and debugging Java programs in
the workbench.


This JRE defines the values for the three reserved classpath variables (JRE_LIB, JRE_SRC,
JRE_SRCROOT).
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Frequently asked questions on JDT


Can I use a Java compiler other than the built−in one (javac for example)
with the workbench?


No. The JDT provides a number of sophisticated features including fully automatic incremental
recompilation, code snippet evaluation, code assist, type hierarchies, and hot code replace. These features
require special support found in the workbench Java compiler (an integral part of the JDT's incremental
project builder), but not available in standard Java compilers.


Where do Java packages come from?


A project contains only files and folders. The notion of a Java package is introduced by a Java project's class
path (at the UI, the Package Explorer presents the packages as defined by the classpath). Tip: If the package
structure is not what you expect, check out your class path. The Java search infrastructure only finds
declarations for and references from Java elements on the class path.


When do I use an internal vs. an external JAR library file?


An internal resource resides in some project in the workbench and is therefore managed by the workbench;
like other resources, these resources can be version managed by the workbench. An external resource is not
part of the workbench and can be used only by reference. For example, a JRE is often external and very large,
and there is no need to associate it with a VCM system.


When should I use source folders within a Java project?


Each Java project locates its Java source files via one or more source type entries on the project's class path.
Use source folders to organize the packages of a large project into useful grouping, or to keep source code
separate from other files in the same project. Also, use source folders if you have files (documentation for
example) which need not be on the build path.


What are source attachments, How do I define one?


Libraries are stored as JAR files containing binary class files (and perhaps other resources). These binary class
files provide signature information for packages, classes, methods, and fields. This information is sufficient to
compile or run against, but contains far less information that the original source code. In order to make it
easier to browse and debug binary libraries, there is a mechanism for associating a corresponding source JAR
(or ZIP) file with a binary JAR file.


Why are all my resources duplicated in the output folder (bin, for
example)?


If your Java project is using source folders, then in the course of compiling the source files in the project, the
Java compiler copies non−Java resources to the output folder as well so that they will be available on the class
path of the running program. To avoid certain resources to be copied to the output location you can set a
resource filter in the compiler preferences: Window > Preferences > Java > Compiler > Build Path
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How do I prevent having my documentation files from being copied to
the project's output folder?


Use source folders and put any resources that you do not want to be copied to the output folder into a separate
folder that is not included on the class path.You can also set a resource filter in the compiler preferences:
Window > Preferences > Java > Compiler > Build Path to for example *.doc.


How do I create a default package?


You don't have to. Files in the root folder of a source folder or project are considered to be in the default
package. In effect, every source folder has the capability of having a fragment of the default package.


What is refactoring?


Refactoring means behavior−preserving program transformations. The JDT supports a number of
transformations described in Martin Fowler's book Refactoring: Improving the Design of Existing Code,
Addison Wesley 1999.


When do I use code select/code resolve (F3)?


To find out the Java element that corresponds to a source range with the help of the compiler.


Is the Java program information (type hierarchy, declarations,
references, for example) produced by the Java builder? Is it still updated
when auto−build is off?


The Java program information is independent from the Java builder. It is automatically updated when
performing resource changes or Java operations. In particular, all the functionalities offered by the Java
tooling (for example, type hierarchies, code assisting, search) will continue to perform accurately when
auto−build is off; for example, when doing heavy refactoring which require to turn off the builders, you can
still use code assist, which will reflect the latest changes (not yet build). Other than the launching (that is,
running and debugging) of programs, the only functionality which requires the Java builder is the evaluation
of code snippets.


After reopening a workbench, the first build that happens after editing a
Java source file seems to take a long time. Why is that?


The Java incremental project builder saves its internal state to a file when the workbench is closed. On the
first build after the project is reopened, the Java incremental project builder will restore its internal state.
When this file is large, the user experiences an unusually long build delay.


I can't see a type hierarchy for my class. What can I do?


Check that you have your build class path set up properly. Setting up the proper build class path is an
important task when doing Java development. Without the correct build path, you will not be able to compile
your code. In addition, you will not be able to search or look at the type hierarchies for Java elements.
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How do I turn off "auto compile" and do it manually when I want?


Clear the Window > Preferences > Workbench > Perform build automatically on resource modification
checkbox. When you want to build, press Ctrl+B, or select Project > Build All from the menu bar.


Hint: when you turn "auto compile" off and build manually, you may also want to select the Window
>Preferences > Workbench > Save all modified resources automatically prior to manual build checkbox.


When I select a method or a field in the Outline view, only the source for
that element is shown in the editor. What do I do to see the source of the
whole file?


There is a toolbar button Show Source of Selected Element Only − all you have to do is un−press it.


Can I nest source folders?


Yes, you can use exclusion filters to create nested source folders.


Can I have separate output folders for each source folder?


Yes, select the Allow output folders for source folders checkbox in the Java Build Path > Source property
page of your Java project.


Can I have an output or source folder that is located outside of the
workspace?


Yes, you can create a linked folder that points to the desired location and use that folder as the source or
output folder in your Java project.


Java development tools (JDT)


Java Build Path page
JDT glossary
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JDT glossary
CLASS file


A compiled Java source file.


compilation unit


A Java source file.


field


A field inside a type.


import container


Represents a collection of import declarations. These can be seen in the Outline view.


import declaration


A single package import declaration.


initializer


A static or instance initializer inside a type.


JAR file


JAR (Java archive) files are containers for compiled Java source files. They can be associated with an archive
(such as, ZIP, JAR) as a source attachment. The children of JAR files are packages. JAR files can be either
compressed or uncompressed.


JAVA elements


Java elements are Java projects, packages, compilation units, class files, types, methods and fields.


JAVA file


An editable file that is compiled into a byte code (CLASS) file.


Java projects


Projects which contain compilable Java source code and are the containers for source folders or packages.


JDT


Java development tools. Workbench components that allow you to write, edit, execute, and debug Java code.


JRE
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Java runtime environment (for example, J9, JDK, and so on).


method


A method or constructor inside a type.


package declaration


The declaration of a package inside a compilation unit.


packages


A group of types that contain Java compilation units and CLASS files.


refactoring


A comprehensive code editing feature that helps you improve, stabilize, and maintain your Java code. It
allows you to make a system−wide coding change without affecting the semantic behavior of the system.


type


A type inside a compilation unit or CLASS file.


source folder


A folder that contains Java packages.


VCM


Version control management. This term refers to the various repository and versioning features in the
workbench.


VM


Virtual machine.


Java development tools (JDT)


Frequently asked questions on JDT
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Java Compiler page
The options in this page indicate the compiler settings for a Java project.
You can reach this page through


the Java Compiler property page (File > Properties > Java Compiler) from the context menu on a
created project or the File menu


• 


A project can either reuse workspace default settings or use its own custom settings.


Option Description


Use workspace
settings


Default mode indicating that the project is using the global workspace settings. When
selected, it allows to open the page for configuring the workspace compiler preferences.


Use project
settings


Once selected, compiler settings can be configured for this project. All compiler
preferences can be customized. At any time, it is possible to revert to workspace defaults,
by using the button Restore Defaults.


Build classpath


Global compiler preferences
Frequently asked questions on JDT
Java Build Path properties
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Editing a JRE definition


You can modify all settings for a JRE definition except its JRE type.


From the menu bar, select Window > Preferences.1. 
In the left pane, expend the Java category, and select Installed JREs.2. 
Select the JRE definition that you want to edit and click Edit.... The Edit JRE page opens.3. 
In the JRE name field, edit the name for the JRE definition. All JREs of the same type must have a
unique name.


4. 


In the JRE home directory field, edit or click Browse... to select the path to the root directory of the
JRE installation (usually the directory containing the bin and lib directories for the JRE). This location
is checked automatically to make sure it is a valid path.


5. 


In the Javadoc URL field, edit or click Browse... to select the URL location. The location is used by
the Javadoc export wizard as a default value and by the 'Open External Javadoc' action.


6. 


If you want to use the default libraries and source files for this JRE, select the Use default system
libraries check box. Otherwise, clear it and customize as desired. Source can be attached for the
referenced jars as well.


7. 


Click OK when you are done.8. 


Java development tools (JDT)


Adding a new JRE definition
Deleting a JRE definition
Overriding the default system libraries for a JRE definition
Working with JREs


Installed JREs preference page
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Deleting a JRE definition


You can delete Java runtime environment definitions that are available for executing Java programs in the
workbench.


Select  Window > Preferences from the main menu bar.1. 
From the left pane, expand the Java category and select Installed JREs.2. 
Select the definition you want to delete and click Remove.3. 
Check the box for the definition that you want to use as the default JRE for the workbench.4. 


Java development tools (JDT)


Working with JREs
Adding a new JRE definition
Editing a JRE definition


Installed JREs preference page
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Overriding the default system libraries for a JRE
definition


You can override the system libraries and the corresponding source attachments when adding a JRE.


Begin adding a new JRE definition.1. 
In the Create JRE dialog, clear the Use default system libraries check box.
If the system was able to determine the set of system libraries, these libraries will already be
displayed.


2. 


Order and/or remove the system libraries that were determined. Add external JARs to the list of
system libraries.


3. 


Associate source with the system libraries using the Attach source button.4. 
When you are finished with this dialog, click OK to create the new JRE definition. The new JRE
definition will use the customized system libraries (and attached source).


5. 


Java development tools (JDT)


Working with JREs
Adding a new JRE definition
Editing a JRE definition


Installed JREs preference page


 Overriding the default system libraries for a JRE definition 158







Adding source code as individual files


From a ZIP or JAR file


In the Navigator or Package Explorer, you can optionally select the source folder into which you wish
to import the source. Note: It is important to choose a source container; otherwise, the imported files
will not be on the build path.


1. 


From the workbench menu bar, select File > Import.2. 
In the Import wizard, select Zip file, then click Next.3. 
In the Zip file field, type or browse to select the file from which you would like to add the resources.
In the import selection panes, use the following methods to select exactly the resources you want to
add:


Expand the hierarchies in the left pane and check or clear the boxes representing the
containers in the selected directory. Then in the right pane, select or clear boxes for individual
files.


♦ 


Click Select Types to select specific file types to add.♦ 
Click Select All to select all files in the directory, then go through and deselect the ones that
you don't want to add.


♦ 


Click Deselect All to deselect all files in the directory, then go through and choose individual
files to add.


♦ 


4. 


In the Select the destination for imported resources field, type or browse to select a workbench
container for the added resources (if it was not already selected when you activated the Import
command).


5. 


In the Options area, you can choose whether or not to overwrite existing resources without warning.6. 
Click Finish when you are done.7. 


From a directory


In the Navigator or Package Explorer, select the source folder into which you wish to import the
source. Note: It is important to choose a source container; otherwise, the imported files will not be on
the build path.


1. 


From the workbench menu bar, select File > Import.2. 
In the import wizard, select File System, then click Next.3. 
In the Directory field, type or browse to select the directories from which you would like to add the
resources.


4. 


In the import selection panes, use the following methods to select exactly the resources you want to
add:


Expand the hierarchies in the left pane and check or clear the boxes representing the
containers in the selected directory. Then in the right pane, select or clear boxes for individual
files.


♦ 


Click Select Types to select specific file types to add.♦ 
Click Select All to select all files in the directory, then go through and deselect the ones that
you don't want to add.


♦ 


Click Deselect All to deselect all files in the directory, then go through and choose individual
files to add.


♦ 


5. 


In the Select the destination for imported resources field, type or browse to select a workbench
container for the added resources (if it was not already selected when you activated the Import
command).


6. 


In the Options area, you can choose whether you want to:7. 
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overwrite existing resources without warning♦ 
create a complete file structure for the imported files♦ 


Click Finish when you are done.8. 


Java development tools (JDT)
Build classpath


Adding a JAR file as a library
Working with build paths


Java Build Path
Package Explorer
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Adding a JAR file as a library
To add a JAR file as a library, you can either drag and drop the JAR file into the workbench from the file
system or you can use the Import wizard to import the file.


From the workbench menu bar, select File > Import. The Import wizard opens1. 
Select File System, then click Next.2. 
In the From directory field, type or browse to select the directory where the JAR file resides.3. 
In the import selection panes, expand the hierarchy and use the buttons to select the JAR file you want
to import.


4. 


In the Into folder field, type or browse to select a workbench container for the JAR file.5. 
Click Finish when you are done.6. 
You now must add the JAR file to the build class path of any projects that need this library.7. 


Java builder
Build classpath


Adding a JAR file to the build path
Attaching source to a JAR file
Working with build paths
Adding source code as individual files


Java Build Path
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Viewing compilation errors and warnings
The workbench supports different ways to examine errors and warnings:


Error ticks in Java views (e.g. Package Explorer)• 
Marker annotations in the editor• 
Tasks in the task list• 


If an expression you select to evaluate has a compilation error, it will be reported in the Scrapbook editor.


For example, if you type and select the (invalid) expression System.println("hi") in the editor and click Run in
the toolbar, the error message:


The method println(java.lang.String) is undefined for the type java.lang.System


is displayed in the editor at the point of the error.


Java builder
Java editor
Scrapbook


Building automatically
Building manually
Running and debugging
Setting execution arguments


Package Explorer
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Setting execution arguments
If you want to specify execution arguments for your program, you must define a launch configuration that
specifies the arguments.


Select Run >Run... (or Run >Debug...) from the workbench Run menu to open the list of launch
configurations.   Launch configurations for Java programs are shown underneath Java Application in
this list. 


1. 


Create a new launch configuration by pushing the New button after selecting Java Application.2. 
On the Arguments tab for the configuration, you can specify the following fields as necessary:


Program Arguments: Application−specific values that your code is expecting (a user name or
a URL for locating help files, for example).


♦ 


VM Arguments: Values meant to change the behavior of the Java virtual machine (VM). For
example, you may need to tell the VM whether to use a just−in−time (JIT) compiler, or you
may need to specify the maximum heap size the VM should use. Refer to your VM's
documentation for more information about the available VM arguments.


♦ 


Working Directory: The working directory used for the launched process. To change from
using the default working directory, uncheck Use default working directory and specify the
workspace or local directory to use for the working directory of the launched process.


♦ 


3. 


Click Apply or  Close when you are done. Every time you launch this configuration, these execution
arguments will be used.


4. 


Creating a Java Application launch configuration
Launching a Java program
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Creating a Java application launch configuration
When you choose Run >Run As >Java Application to launch your class, you are running your class using a
generic Java Application launch configuration that derives most of the launch parameters from your Java
project and your workbench preferences.  In some cases, you will want to override the derived parameters or
specify additional arguments.


You do this by creating your own Java Application launch configuration. 


Select Run >Run... or Run >Debug... from the workbench menu bar.  This opens a dialog that lets
you create, modify, and delete launch configurations of different types.


1. 


Select Java Application in the left hand list of launch configuration types, and press New. This will
create a new launch configuration for a Java application. The tabs on the right hand side allow you
control specific aspects of the launch.


2. 


The Main tab defines the class to be launched. Enter the name of the project
containing the class to launch in the project field, and the fully qualified name of the
main class in the the Main class field. Check the Stop in main checkbox if you want
the program to stop in the main method whenever the program is launched in debug
mode.
Note:  You do not have to specify a project, but doing so allows a default classpath,
source lookup path, and JRE to be chosen.


♦ 


The Arguments tab defines the arguments to be passed to the application and to the
virtual machine (if any). You can also specify the working directory to be used by the
launched application.


♦ 


The JRE tab defines the JRE used to run or debug the application. You can select a
JRE from the already defined JREs, or define a new JRE.


♦ 


The Classpath tab defines the location of class files used when running or debugging
an application. By default, the user and bootstrap class locations are derived from the
associated project's build path. You may override these settings here.


♦ 


The Source tab defines the location of source files used to display source when
debugging a Java application. By default, these settings are derived from the
associated project's build path. You may override these settings here.


♦ 


The Environment tab defines the environment variable values to use when running or
debugging a Java application. By default, the environment is inherited from the
Eclipse runtime. You may override or append to the inherited environment.


♦ 


The Common tab defines general information about the launch configuration.  You
may choose to store the launch configuration in a specific file and specify which
perspectives become active when the launch configuration is launched.


♦ 


Debugger
Local debugging
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Choosing a JRE for launching a project
Launching a Java program
Setting execution arguments
Changing debugger launch options


Debug preferences
Debug view
Run and debug actions
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Changing the active perspective when launching
You can control which perspective becomes active when a program is launched and when it suspends. The
setting is configurable for each launch configuration type, for each of the launch modes it supports.


To activate a particular perspective when a program is launched, do the following:


Open the debugger launch options preferences page (Window > Preferences > Run/Debug >
Launching).


1. 


Select the Always option for the Switch to associated perspective when launching preference. This
will cause the perspective associated with a program to become active whenever it is launched.


2. 


To activate a particular perspective when a program is suspends, do the following:


Open the debugger preferences page (Window > Preferences > Run/Debug).1. 
Select the Always option for the Switch to associated perspective when a breakpoint is hit
preference.  This will cause the perspective associated with a program to become active whenever a
program suspends.


2. 


To associate a particular perspective with a program, do the following:


Open the run dialog (Run > Run...).1. 
Select the type of launch configuration (program) that you would like to associate a perspective with
(for example, Java Application). The Perspectives tab will be displayed.


2. 


For each launch mode, select the desired perspective using the combo box. This will cause the
perspective you choose to become active based on your preference settings (i.e. when a program is
launched and/or when it suspends).


3. 


Press the Apply button to save the settings.4. 


If the specified perspective is not open at the time it needs to be activated, that perspective is created. 


Debugger
Remote debugging
Local debugging
Java perspectives


Running and debugging
Setting execution arguments
Launching a Java program


Console view
Debug preferences
Debug view
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Run and debug actions
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Debug preferences
The following preferences can be set using the Debug Preferences page.


Option Description Default


Build (if required) before launching If the workspace requires building,
an incremental build will be
performed prior to launching an
application.


On


Remove terminated launches when a new
launch is created


When an application is launched,
all terminated applications in the
Debug view are automatically
cleared.


On


Reuse editor when displaying source codeThe debugger displays source code
in an editor when stepping through
an application. When this option is
on, the debugger will reuse the
editor that it opened to display
source from different source files.
This prevents the debugger from
opening an excessive number of
editors. When this option is off, the
debugger will open a new editor for
each source file that needs to be
displayed.


On


Activate the workbench when when a
breakpoint is hit


This option brings attention to the
debugger when a breakpoint is
encountered, by activating the
associated window. The visual
result varies from platform to
platform. For example, on
Windows, the associated window's
title bar will flash.


On


Save dirty editors before launching This option controls whether the
user will be prompted to save any
dirty editors before an application is
launched. The allowable settings
are:


Never − when this option is
selected, the user is never
prompted to save dirty
editors, and editors are not


• 


Prompt
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automatically saved.
Prompt − when this option
is selected, the user is
prompted to save dirty
editors before launching an
application.


• 


Auto−save − when this
option is selected, any dirty
editors are automatically
saved before launching
(and the user is not
prompted).


• 


Debugger
Local Debugging
Remote Debugging


Changing Debugger Launch Options
Preparing to Debug
Running and Debugging


Java search tab
Search menu


 Basic tutorial
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Preparing to debug
You can make your programs easier to debug by following these guidelines:


Where possible, do not put multiple statements on a single line, because some debugger features
operate on a line basis. For example, you cannot step over or set line breakpoints on more than one
statement on the same line.


• 


Attach source code to JAR files if you have the source code.• 


Debugger
Remote debugging
Local debugging


Changing debugger launch options
Running and debugging


Debug preferences
Debug view
Run and debug actions
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Run and debug actions
Run and Debug Actions


Toolbar
Button


Command Description
Run This command re−launches the most recently launched application.


Debug This command re−launches the most recently launched application under
debugger control.


Run
Menu


Debug Last
Launched


This command allows you to quickly repeat the most recent launch in debug
mode (if that mode is supported).


Run
Menu


Run Last
Launched


This command allows you to quickly repeat the most recent launch in run mode
(if that mode is supported).


Run
Menu


Run History Presents a sub menu of the recent history of launch configurations launched in
run mode


Run
Menu


Run As Presents a sub menu of registered run launch shortcuts. Launch shortcuts
provide support for workbench or active editor selection sensitive launching.


Run
Menu


Run... This command realizes the launch configuration dialog to manage run mode
launch configurations.


Run
Menu


Debug History Presents a sub menu of the recent history of launch configurations launched in
debug mode.


Run
Menu


Debug As Presents a sub menu of registered debug launch shortcuts. Launch shortcuts
provide support for workbench or active editor selection sensitive launching.


Run
Menu


Debug... This command realizes the launch configuration dialog to manage debug mode
launch configurations.


Run
Menu


Various step
commands


These commands allow you to step through code being debugged.


Run
Menu


Inspect When a thread suspends, this command uses the Expressions view to show the
result of inspecting the selected expression or variable in the context of a stack
frame or variable in that thread.


Run
Menu


Display When a thread suspends, this command uses the Display view to show the result
of evaluating the selected expression in the context of a stack frame or variable
in that thread. If the current active part is a Java Snippet Editor, the result is
displayed there.


Run
Menu


Run Snippet Within the context of the Java snippet editor, this command allows you to
evaluate an expression but does not display a result.


Run
Menu


Run to Line When a thread is suspended, it is possible to resume execution until a specified
line is executed. This is a convenient way to suspend execution at a line without
setting a breakpoint.


Run
Menu


Toggle Line
Breakpoint


This command allows you to add or remove a Java line breakpoint at the current
selected line in the active Java editor.


Run
Menu


Add Java
Exception
Breakpoint


This command allows you to create an exception breakpoint. It is possible to
suspend the execution of thread or VM when an exception is thrown by
specifying an exception breakpoint. Execution can be suspended at locations
where the exception is uncaught, caught, or both.
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Run
Menu


Toggle Method
Breakpoint


This command allows you to add or remove a method breakpoint for the current
binary method. The binary method can be selected in source of a Java class file
editor, or be selected in any other view (such as the Outline view).


Run
Menu


Toggle
Watchpoint


This command allows you to add or remove a field watchpoint for the current
Java field. The field can be selected in the source of a Java editor, or be selected
in any other view (such as the Outline view).


Debugger
Local Debugging
Remote Debugging


Running and Debugging
Connecting to a remote VM with the Remote Java application launch configuration
Line breakpoints
Setting method breakpoints
Catching exceptions


Debug View
Debug Preferences
Run and Debug actions
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Java search tab
This tab in the Search dialog allows you to search for Java elements.


Search string


In this field, type the expression for which you wish to search, using the wildcard characters mentioned in the
dialog as needed. This field is initialized based on the current selection.


Depending on what is searched for, the search string should describe the element:
Type: the fully qualified name of the type (e.g. org.eclipse.jdt.internal.core.JavaElement)♦ 
Method: the fully qualified name of the defining type, the method selector, and its parameters
(e.g. org.eclipse.jdt.internal.core.JavaElement.getHandleFromMemento(MementoTokenizer,
WorkingCopyOwner))


♦ 


Package: the package name for a package (e.g. org.eclipse.jdt.internal.core)♦ 
Constructor: the fully qualified name of the defining type, and the constructor parameters
(e.g. org.eclipse.jdt.internal.core.JavaElement(JavaElement, String)). Note that the
constructor name should not be entered as it is always the same as the type name.


♦ 


Field: the fully qualified name of the defining type and the field name (e.g.
org.eclipse.jdt.internal.core.JavaElement.name)


♦ 


• 


From the drop−down menu, you can choose to repeat (or modify) a recent search.
Select the Case sensitive field to force a case aware search. Case sensitive is enabled when a custom
search string is entered.


• 


Search For


Select to search for one of the following kinds of elements:


Type• 
Method• 
Package• 
Constructor• 
Field• 


Limit To


Select to limit your search results to one of the following kinds of matches:


Declarations• 
Implementors (available only when searching for types)• 
References• 
All Occurrences• 
Read Access (available only when searching for fields)• 
Write Access (available only when searching for fields)• 
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Scope


Select to limit your search results to one of the following scope


Workspace• 
Selected Resources• 
Working Set• 


Press Choose to select or create a working set.


Java search


Conducting a Java search using the search dialog
Conducting a Java search using pop−up menus
Search
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Java search
The Java searching support allows you to find declarations, references and occurrences of Java elements
(packages, types, methods, fields). Searching is supported by an index that is kept up to date in the
background as the resources corresponding to Java elements are changed. The Java search operates on
workspaces independent of their build state. For example, searches can be conducted when auto−build is
turned off.


The following searches can be initiated from the pop−up menus of Java elements:


Command Description
References Finds all references to the selected Java element
Declarations Finds all declarations of the selected Java element
Implementors Finds all implementors of the selected Java interface
Read Access Finds all read accesses to the selected Java field
Write Access Finds all write accesses to the selected Java field
Occurrences in FileFinds all occurrences of the selected Java element in its file


The scope of the search is defined as:


Workspace − all projects and files in the workspace are included in this search


Enclosing Projects − the projects enclosing the currently selected elements


Hierarchy − only the type hierarchy of the selected element is included in this search


Working Set − only resources that belong to the chosen working set are included in this search


Java development tools (JDT)


Searching Java code


Search actions
Java Search tab
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Searching Java code
A Java search can be conducted using the Search dialog as well as using the pop−up menu of selected
resources and elements.


Java search


Conducting a Java search using pop−up menus
Conducting a Java search using the Search button


Search menu
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Conducting a Java search using pop−up menus
Open the context menu on any Java element visible in a view.


Search, Outline, and Hierarchy views: The selected Java element in these views can be searched for
declarations and references.


• 


Package Explorer: Packages, Java compilation units, types and their members can be searched for
declarations and references. If a compilation unit or CLASS file contains more than one type, a dialog
prompts you to choose one.


• 


The search pop−up menu is also available in the Java editor. If the selection in the Java editor can be resolved
to a Java element, then you can search for declarations and references.


To conduct a search from a pop−up menu, follow these steps:


Select a Java element (for example a Java compilation unit in the Package Explorer or a method in the
Outline view) or some text in a Java editor.


1. 


From the selection's pop−up menu, navigate to the available Java searches. After you select a search
to perform, the search progress is shown in a dialog. Note: in the editor searches are available under
the Search submenu.


2. 


You may stop the search process by clicking Cancel in the progress dialog.3. 


The type of the selected Java element defines which search pop−up menus are available. The Java editor does
not constrain the list of available Java searches based on the selection.


Java search


Searching Java code


Java search tab
Search menu
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Search actions
Search menu commands:


Name Function Keyboard Shortcut


Search... Opens the search dialog Ctrl + H


File... Opens the search dialog on the File search page


Help... Opens the search dialog on the Help search page


Java... Opens the search dialog on the Java search page


References Finds all references to the selected Java element


Declarations Finds all declarations of the selected Java element


Implementors Finds all implementors of the selected interface.


Read Access Finds all read accesses to the selected field


Write Access Finds all write accesses to the selected field


Occurrences in File Finds all occurrences of the selected Java element in its fileCtrl + Shift + U


Search Scopes Submenu:


Scope Availability Description


Workspace all elements Searches in the full workspace


Project all elements Searches in the project enclosing the selected element


Hierarchy types and membersSearches in the type's hierarchy


Workings Set all elements Searches in a working set


Scopes can be saved and names in the working set dialog. Existing instances of working sets are also available
in the Search Scope submenu


A Java search can also be conducted via the context menu of selected resources and elements in the following
views:


Package Explorer• 
Outline view• 
Search result view• 
Hierarchy view• 
Browsing views• 


The search context menu is also available in the Java editor. The search is only performed if the currently
selected text can be resolved to a Java element.


The type of the selected Java element defines which search context menus are available. The Java editor does
not constrain the list of available Java searches based on the selection.


Java search
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Conducting a Java search using the search dialog
Conducting a Java search using pop−up menus


Java Search tab
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Conducting a Java search using the Search dialog
Java search allows you to quickly find references to and declarations of Java elements.


Open the Search dialog by either:
Clicking the Search button in the toolbar or♦ 
Pressing Ctrl+H or♦ 
Selecting Search > Search... from the menu bar.♦ 


• 


Select the Java Search tab.• 
In the Search string field, type the string for which you want to search, using wildcards as needed.• 
You can also choose a previous search expression from the drop−down list. Selecting a previous
search expression restores all values associated with that previous search in the dialog.


• 


Select the Java element type in the Search For area.• 
Narrow your search in the Limit To area, or select All occurrences to search for references and
declarations to a Java element.


• 


Optionally, use the Scope area to narrow the scope of your search.• 
Click Search, and the search is carried out. The results are displayed in the Search view in the
workbench window.


• 


Java search


Conducting a Java search using pop−up menus


Java search tab
Search menu
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Defining the JAR file's manifest
You can either define the important parts of the JAR file manifest directly in the wizard or choose to use a
manifest file that already exists in your workbench.


Creating a new manifest


Follow the procedure for creating a JAR file, but click Next in the last step to go to the JAR
Packaging Options page.


1. 


Set any advanced options that you want to set, and then click Next again to go to the JAR Manifest
Specification page.


2. 


If it is not already selected, click the Generate the manifest file button.3. 
You can now choose to save the manifest in the workbench. This will save the manifest for later use.
Click Save the manifest in the workspace, then click Browse next to the Manifest file field to specify
a path and file name for the manifest.


4. 


If you decided to save the manifest file in the previous step and you chose to save the JAR description
on the previous wizard page, then you can choose to reuse it in the JAR description (by selecting the
Reuse and save the manifest in the workspace checkbox). This means that the saved file will be used
when the JAR file is recreated from the JAR description.This option is useful if you want to modify or
replace the manifest file before recreating the JAR file from the description.


5. 


You can choose to seal the JAR and optionally exclude some packages from being sealed or specify a
list with sealed packages. By default, nothing is sealed.


6. 


Click the Browse button next to the Main class field to specify the entry point for your applications.
Note: If your class is not in the list, then you forgot to select it at the beginning.


7. 


Click Finish. This will create the JAR, and optionally a JAR description and a manifest file.8. 


Using an existing manifest


You can use an existing manifest file that already exists in your workbench.


Follow the procedure for creating a JAR file, but click Next in the last step to go to the JAR
Packaging Options page.


1. 


Set any advanced options that you want to set, and the click Next again to go to the JAR Manifest
Specification page.


2. 


Click the Use existing manifest from workspace radio button.3. 
Click the Browse button to choose a manifest file from the workbench.4. 
Click Finish. This will create the JAR and optionally a JAR description.5. 


Java development tools (JDT)


Creating a new JAR file
Setting advanced options
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JAR file exporter
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Setting advanced options
Follow the procedure for creating a JAR file, but click Next in the last step to go to the JAR
Packaging Options page.


1. 


If you want to save the JAR file description, select the Save the description of this JAR in the
workspace check box.


2. 


The compiler is able to generate CLASS files even when source contains errors. You have the option
to exclude CLASS (but not source) files with compile errors. These files will be reported at the end, if
reporting is enabled.


3. 


You can choose to exclude CLASS (but not source) files that have compile warnings. These files will
be reported at the end.
Note: This option does not automatically exclude class files with compile errors.


4. 


You can choose to include the source folder path by selecting the Create source folder structure
checkbox.


5. 


Select the Build projects if not built automatically checkbox if you want the export to perform a
build before creating the JAR file.


6. 


Click Finish to create the JAR file immediately or Next if you want to change the default manifest.7. 


Java development tools (JDT)


Creating a new JAR file
Defining the JAR file's manifest


JAR file exporter
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Regenerating a JAR file
You can use a JAR file description to regenerate a previously created JAR file.


Select one or more JAR file descriptions in your workbench.1. 
From the selection's pop−up menu, select Create JAR. The JAR file(s) are regenerated.2. 


Java development tools (JDT)


Creating a new JAR file
Defining the JAR file's manifest


JAR file exporter
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New Java Class Wizard
This wizard helps you to create a new Java class in in a Java project.


Java Class Options


Option Description Default


Source folder Enter a source folder for the new class. Either type a
valid source folder path or click Browse to select a
source folder via a dialog.


The source folder of the element that
was selected when the wizard has
been started.


Package Enter a package to contain the new class. You can
select either this option or the Enclosing Type
option, below. Either type a valid package name or
click Browse to select a package via a dialog.


The package of the element that was
selected when the wizard has been
started.


Enclosing type Select this option to choose a type in which to
enclose the new class. You can select either this
option or the Package option, above. Either type a
valid name in the field or click Browse to select a
type via a dialog.


The type or the primary type of the
compilation unit that was selected
when the wizard has been started or
<blank>


Name Type a name for the new class. <blank>


Modifiers Select one or more access modifiers for the new
class.


Either public, default, private, or protected
(private and protected are only available if
you specify an enclosing type)


• 


abstract• 
final• 
static (only available if you specify an
enclosing type)


• 


public


Superclass Type or click Browse to select a superclass for this
class.


The type (not the compilation unit!)
that was selected when the wizard has
been started or <java.lang.Object>


Interfaces Click Add to choose interfaces that the new class
implements.


<blank>


Which method
stubs would you
like to create?


Choose the method stubs to create in this class:


public static void main(String [] args): Adds
a main method stub to the new class.


• 


Constructors from superclass: Copies the
constructors from the new class's superclass
and adds these stubs to the new class.


• 


Inherited abstract methods: Adds to the new
class stubs of any abstract methods from
superclasses or methods of interfaces that
need to be implemented.


• 


Inherited abstract methods enabled
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Creating a new Java class
File actions
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New Java Interface Wizard
This wizard helps you to create a new Java interface in a Java project.


Java Interface Options


Option Description Default


Source folder Enter a source folder for the new interface. Either type a valid
source folder path or click Browse to select a source folder via
a dialog.


The source folder of the
element that was selected
when the wizard has been
started.


Package Enter a package to contain the new interface. You can select
either this option or the Enclosing Type option, below. Either
type a valid package name or click Browse to select a package
via a dialog.


The package of the element
that was selected when the
wizard has been started.


Enclosing type Select this option to choose a type in which to enclose the new
interface. You can select either this option or the Package
option, above. Either type a valid name in the field or click
Browse to select a type via a dialog.


The type or the primary
type of the compilation unit
that was selected when the
wizard has been started or
<blank>


Name Type a name for the new interface. <blank>


Modifiers Select one or more access modifiers for the new interface.


Either public, default, private, or protected (private and
protected are only available if you specify an enclosing
type)


• 


static (only available if you specify an enclosing type)• 


public


Extended
interfaces


Click Add to choose interfaces that the new interface extends.<blank>


Creating a new Java interface
File actions
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Creating a new Java interface
Use the New Java Interface wizard to create a new Java interface. There are a number of ways to open this
wizard:


Select the container where you want the new class to reside.1. 
From the drop−down menu on the New Java Class button in the workbench toolbar, select Interface.2. 


or


Select the container where you want the new class to reside.1. 
From the container's pop−up menu, select New > Interface.2. 


or


Select the container where you want the new class to reside.1. 
From the drop−down menu on the New button in the workbench toolbar, select Interface.2. 


or


Click the New button. In the left pane, select Java, and in the right pane, select Interface.


or


Select the container where you want the new interface to reside. Then, from the menu bar select File > New >
Interface


Java projects


Creating a top−level interface
Creating a nested interface
Creating a new interface in an existing compilation unit
Renaming a class or interface


New Java Interface wizard
Java Toolbar actions
Package Explorer
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Creating a top−level interface
You can create interfaces that are not enclosed in other types.


Open the New Java Interface wizard.1. 
Edit the Source Folder field as needed to indicate in which folder you want the new interface to
reside. You can either type a path or click the Browse button to find the folder. If a folder is found for
the current selection, that folder appears in the Source Folder field as the container for the new
interface.


2. 


In the Package field, type a name or click Browse to select the package where you want the new
interface to reside. If you want the new interface to be created in the default package, leave this field
empty.


3. 


Clear the Enclosing type check box.4. 
In the Name field, type a name for the new interface.5. 
Select the public or default access modifier using the Modifiers radio buttons.6. 
Click the Add button to add interfaces for the new interface to extend.7. 
Click Finish.8. 


Java projects


Creating a new Java interface
Creating a nested interface
Creating a new interface in a compilation unit
Renaming a class or interface


New Java Interface wizard
Java Toolbar actions
Package Explorer
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Creating a nested interface
You can create interfaces that are enclosed in other types (that is, nested interfaces).


Open the New Java Interface wizard.1. 
Edit the Source Folder field to indicate in which folder you want the new interface to reside. You can
either type a path or click the Browse button to find the folder. If a folder is found for the current
selection, that folder appears in the Source Folder field as the container for the new interface.


2. 


Select the Enclosing type check box.3. 
In the Enclosing type field, type the name of the enclosing type or click the Browse button to select
the enclosing type for the new interface.


4. 


In the Name field, type a name for the new interface.5. 
Select the public or default access modifier by using the Modifiers radio buttons.6. 
Select the static check box if you want the new interface to be static.7. 
Click the Add button to add interfaces for the new interface to extend.8. 
Click Finish when you are done.9. 


Note: The new interface is created in the same compilation unit as its enclosing type.


Java projects


Creating a new Java interface
Creating a top−level interface
Creating a new interface in a compilation unit
Renaming a class or interface


New Java Interface wizard
Java Toolbar actions
Package Explorer
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Creating a new interface in an existing
compilation unit
An alternative way to create a new interface is to add it to an existing compilation unit.


In the Package Explorer, double−click a compilation unit.1. 
Type the code for the interface at the desired position in the compilation unit.2. 


Java projects


Creating Java elements
Creating a new Java interface
Creating a nested interface
Creating a top−level interface
Renaming a compilation unit


Package Explorer
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Renaming a compilation unit
To rename a compilation unit:


In the Package Explorer, select the compilation unit you want to rename.1. 
From the view's pop−up menu, select Refactor > Rename.2. 


Renaming a compilation unit also renames (and updates all references to) the top−level type that has the same
name as the compilation unit. For example, renaming a compilation unit A.java in which a class A is declared
also renames class A and updates all references to it.


Refactoring support


Copying and moving Java elements
Viewing compilation errors and warnings
Creating a class in an existing compilation unit
Creating a new interface in a compilation unit
Showing a type's compilation unit in the Packages view


Package Explorer
Refactoring actions
Refactoring dialogs
Refactoring preferences
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Copying and moving Java elements
To move Java elements:


From a Java view, select the Java elements you want to move.1. 
From the menu bar, select Refactor > Move or, from the view's pop−up menu, select Refactor
> Move.


2. 


In the resulting dialog, select the new location for the element and press OK.
Note: Moving static members (such as methods and types), classes or compilation units allows you to
choose to also update references to these elements.


3. 


You can also move Java elements by dragging them and dropping in the desired new location.


Note: Dragging and dropping compilation units and types allows you to update references to these elements.
In the dialog that appears on dropping, press Yes if you want to update references, press Preview if you want
to see the preview of the reference updates, press No if you want to move the elements without updating
references or press Cancel if you want to cancel the move operation.


To copy Java elements you need to copy them to the clipboard and paste them in the desired new location:


From a Java view, select the Java elements you want to copy to the clipboard and do one of the
following:


Press Ctrl+C♦ 
From the menu bar, select Edit > Copy♦ 
From the view's pop−up menu, select Copy♦ 


1. 


Now, to paste the elements, select the desired destination and do one of the following:
Press Ctrl+V♦ 
From the menu bar, select Edit > Paste♦ 
From the view's pop−up menu, select Copy♦ 


2. 


You can also copy Java elements by dragging them and dropping in the desired new location. You will need
to have Ctrl pressed while dragging to copy the elements.


Java projects


Creating Java elements
Moving folders, packages, and files
Copying and moving Java elements


Edit menu
Refactoring actions
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Edit actions
Edit menu commands shown when a Java Editor is visible:


Name Function
Keyboard
Shortcut


Undo Revert the last change in the editor Ctrl + Z


Redo Revert an undone change Ctrl + Y


Cut Copies the currently selected text or element to the clipboard and removes the
element. On elements, the remove is not performed before the clipboard is
pasted.


Ctrl + X


Copy Copies the currently selected text or elements to the clipboard Ctrl + C


Paste Paste the current content as text to the editor, or as a sibling or child element to
the a currently selected element. 


Ctrl + V


Delete Delete the current text or element selection. Delete


Select All Select all the editor content.. Ctrl + A


Find / Replace Open the Find / Replace dialog. Editor only. Ctrl + F


Find Next Finds the next occurrence of the currently selected text. Editor only. Ctrl + K


Find Previous Finds the previous occurrence of the currently selected text. Editor only.
Ctrl + Shift
+ K


Incremental
Find Next


Starts the incremental find mode. After invocation, enter the search text as
instructed in the status bar. Editor only.


Ctrl + J


Incremental
Find Previous


Starts the incremental find mode. After invocation, enter the search text as
instructed in the status bar. Editor only.


Ctrl + Shift
+ J


Add Bookmark Add a bookmark to the current text selection or selected element.


Add Task Add a user defined task to the current text selection or selected element. Alt + Enter


Expand
Selection to Enclosing Element: Selects the enclosing expression, block, method in


the code. This action is aware of the Java syntax. It may not function
properly when the code has syntax errors. (Arrow Up)


• 


Next Element: Selects the current and next element. (Arrow Right)• 
Previous Element: Selects the current and the previous element (Arrow
Left)


• 


Restore Last Selection: After an invocation of Expand Selection to
restore the previous selection. (Arrow Down)


• 


Alt + Shift
+ Arrow
Keys


Show Tooltip
Description


Shows the value of a hover that would appear at the current cursor location. The
dialog shown is scrollable and does not shorten descriptions.


F2


Content Assist


Opens a context assist dialog at the current cursor position to bring up Java code
assist proposals and templates. See the Templates preference page for available
templates (Window > Preferences > Java > Editor > Templates) and go to the
Editor preference page (Window > Preferences > Java > Editor > Code Assist)
for configuring the behaviour of code assist.


Ctrl +
Space


Quick Fix
If the cursor is located at a location with problem indication this opens a context
assist dialog at the current cursor to present possible corrections. 


Ctrl + 1


Parameter HintsIf the cursor is located at the parameter specification for method reference, this
actions shows a hover with parameter types information.The parameter at the


Ctrl + Shift
+ Space
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current cursor location is shown in bold.


Encoding Toggles the encoding of the currently shown text content.


Java editor
Java development tools (JDT)


Using the Java editor


Java editor
Java editor preferences
Outline view for Java
Views and editors
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Using Quick Fix
To use the Quick Fix feature:


You need to have the Window > Preferences > Java > Editor > Annotations > Analyze annotations
while typing checkbox selected.


• 


In the Java editor, if you see an error underlined with a squiggly line, position the caret inside the
underlined range and do one of the following


Press Ctrl+1 or♦ 
From the menu bar, select Edit > Quick Fix♦ 


• 


A list of suggested corrections is presented, with a preview displayed when an entry is selected.• 
Select an entry form the list and press Enter.• 


If you have the Window > Preferences > Java > Editor > Annotations > Indicate annotations solvable with
Quick Fix in vertical ruler checkbox selected, then light bulb icons appear on the left−hand side vertical ruler
to indicate Quick Fix'able problems. You can then click on one of the the light bulb icons to invoke Quick
Fix.


Note: Occasionally, invoking Quick Fix will not suggest any corrections. A message saying 'No suggestions
available' will be displayed in such cases.


Java editor
Available Quick Fix proposals


Using the Java editor


Quick Fix
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Quick Fix
The Java editor offers corrections to problems found while typing and after compiling. To show that
correction proposals are available for a problem or warning, a 'light bulb' is visible on the editor's annotation
bar.
Left click on the light bulb or invoking Ctrl+1 (Edit / Quick Fix) brings up the proposals for the problem at
the cursor position.


The following quick fixes are available:


Package
Declaration Add missing package declaration or correct package declaration• 


Move compilation unit to package that corresponds to the package declaration• 


Imports
Remove unused, unresolvable or non−visible import• 
Invoke 'Organize import' on problems in imports• 


Types
Create new class or interface for references to types that can not be resolved• 
Change visibility for types that are accessed but not visible• 
Rename to a similar type for references to types that can not be resolved• 
Add import statement for types that can not be resolved but exist in the project• 
Add explicit import statement for ambiguous type references (two
import−on−demands for the same type)


• 


If the type name is not matching with the compilation unit name either rename
the type or rename the compilation unit


• 


Remove unused private types• 


Constructors
Create new constructor for references to constructors that can not be resolved
(this, super or new class creation)


• 


Reorder or remove arguments for constructor references that mismatch
parameters


• 


Change method with constructor name to constructor (remove return type)• 
Change visibility for constructors that are accessed but not visible• 
Remove unused private constructor• 
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Create constructor when super call of the implicit default constructor is
undefined, not visible or throws an exception


• 


If type contains unimplemented methods, change type modifier to 'abstract' or
add the method to implement


• 


Methods
Create new method for references to methods that can not be resolved• 
Rename to a similar method for references to methods that can not be resolved• 
Reorder or remove arguments for method references that mismatch parameters• 
Correct access (visibility, static) of referenced methods• 
Remove unused private methods• 
Correct return type for methods that have a missing return type or where the
return type does not match the return statement


• 


Add return statement if missing• 
For non−abstract methods with no body change to 'abstract' or add body• 
For an abstract method in a non−abstract type remove abstract modifier of the
method or make type abstract


• 


For an abstract/native method with body remove the abstract or native modifier
or remove body


• 


Change method access to 'static' if method is invoked inside a constructor
invocation (super, this)


• 


Change method access to default access to avoid emulated method access• 


Fields and
variables Correct access (visibility, static) of referenced fields• 


Create new fields, parameters or local variables for references to variables that
can not be resolved


• 


Rename to a variable with similar name for references that can not be resolved• 
Remove unused private fields• 
Correct non−static access of static fields• 
Add 'final' modifier to local variables accessed in outer types• 
Change field access to default access to avoid emulated method access• 
Change local variable type to fix a type mismatch• 
Initialize a variable that has not been initialized• 


Exception
Handling Remove unneeded catch block• 


Handle uncaught exception by surrounding with try/catch or adding catch
block to a surrounding try block


• 


Handle uncaught exception by adding a throw declaration to the parent method
or by generalize an existing throw declaration


• 


Others
Add cast or change cast to fix type mismatches• 
For non−NLS strings open the NLS wizard or mark as non−NLS• 


Quick Assist are proposals available even if there is no problem or warning: There is no light bulb shown so
the user has to know the available assists.
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Quick Assists Replace catch clause with throws declaration on the parent method• 
Transform an expression statement to an assignment to a new local or new
field


• 


Remove surrounding 'if', 'for', 'while', 'do' statement• 
Remove surrounding try block with a single catch or finally block• 
Remove surrounding anonymous class, block or parenthesis• 
Local rename of a type, method or variable in a linked 'template' mode• 
Surround selected lines with templates (''if', 'while'..)• 


Java editor


JDT actions
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JDT actions
JDT actions are available from


Menu bar• 
Toolbar• 
Context menus in views• 


Java Development Tools (JDT)


Frequently Asked Questions on JDT
JDT Glossary
File actions
Edit actions
Source actions
Refactor actions
Navigate actions
Search actions
Project actions
Run actions
Java Toolbar actions
Java Editor actions
Run and Debug actions
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Source actions
Source menu commands:


Name Function
Keyboard
Shortcut


Comment Comments out all lines containing the current selection. Ctrl + /


Uncomment Uncomments all lines containing the current selection. Ctrl + \


Shift Right Increments the level of indentation of the currently select lines. Only
activated when the selection covers multiple lines or a single whole line.


Tab


Shift Left Decrements the level of indentation of the currently select lines. Only
activated when the selection covers multiple lines or a single whole line.


Shift +
Tab


Format Uses the code formatter to format the current text selection. The
formatting options are configured on the Code Formatter preference page
(Window > Preferences > Java > Code Formatter)


Ctrl +
Shift + F


Sort Members Sorts the members of a type according to the sorting order specified in
(Window > Preferences > Java > Appearance > Members Sort Order)


Organize Imports


Organizes the import declarations in the compilation unit currently open
or selected. Unnecessary import declarations are removed, and required
import declarations are ordered as specified in the Organize Import
preference page (Window > Preferences > Java > Organize Import).
Organize import can be executed on incomplete source and will prompt
you when a referenced type name can not be mapped uniquely to a type
in the current project.
You can also organize multiple compilation units by invoking the action
on a package or selecting a set of compilation units.


Ctrl +
Shift + O


Add Import Creates an import declaration for a type reference currently selected. If
the type reference if qualified, the qualification will be removed if
possible. If the referenced type name can not be mapped uniquely to a
type of the current project you will be prompted to specify the correct
type. Add Import tries to follow the import order as specified in the
Organize Import preference page


Ctrl +
Shift + M


Override/Implement
Methods


Opens the Override Method dialog that allows you to override or
implement a method in the current type. Available on types or on a text
selection inside a type.


Generate Getter and
Setter


Opens the Generate Getter and Setter dialog that allows you to create
Getter and Setters for fields in the current type. Available on fields and
types or on a text selection inside a type.


Generate Delegate
Methods


Opens the Generate Delegate Methods dialog that allows you to create
method delegates for fields in the current type. Available on fields.


Add Constructor from
Superclass


For the currently selected type adds constructors as defined in the super
class. Available on types or on a text selection inside a type.


Surround with
try/catch


For the selected statements all exception that have to be caught are
evaluated. A try catch block is created around these expressions. You can
use Expand Selection to from the Edit menu to get a valid selection range.


Externalize Strings
Opens the Externalize strings wizard. This wizards allows you to replace
all strings in the code by statements accessing a property file.
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Find Strings to
Externalize


Shows a dialog presenting a summary of number of strings not
externalized. Available on projects, source folders and packages.


Convert Line
Delimiters To


Changes all line delimiter in the currently open editor to use line
delimiters as used in the following operating systems :


CRLF (Windows)• 
LF (Unix, MacOS X)• 
CR (Classic MacOS)• 


The Java editor is tolerant for a mixed usage of line delimiters. However,
many other tools require an OS conform usage of line delimiters or at
least line delimiter consistency. 


Java editor
String externalization
Java development tools (JDT)


Using the Java editor
Externalizing Strings


Java editor
Java editor preferences
Outline view for Java
Views and editors
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Code Formatter
The preview pane on this page demonstrates what each of these options will do to Java code in the editor.


Code Formatter Preferences


Option Description Default


Insert a new line
before an opening
brace


The editor inserts a line break before opening a new brace. In other
words, open braces always start at the beginning of a new line.


Off


Insert new lines in
control statements


The editor inserts a line break before a new control statement. In other
words, control statements (e.g., if, else, catch, finally, etc.) always start at
the beginning of a new line.


Off


Clear all blank lines The editor deletes all blank lines in the file. Off


Insert new line
between 'else if'


The editor inserts a new line between the words "else" and "if" in else−if
statements.


Off


Insert a new line
inside an empty block


The editor inserts a line break between empty braces. In other words, the
left and right braces in an empty braces set will always appear on separate
lines. An exception is if the right brace is followed by a keyword, in
which case, the two braces appear on the same line.


On


Maximum line length This is the maximum length of any one line. Lines longer than this
number are split and wrapped. Entering 0 here disables line splitting
completely.


80


Compact assignment The editor removes any spaces between a variable and an assignment
statement so that they are asymmetrical (e.g., a= b;).


Off


Insert a space after a
cast


The editor inserts a space between the cast and the following expression.On


Insert tabs for
indentation, not
spaces


The editor uses tabs instead of spaces to represent indentations. On


Number of spaces
representing an
indentation level


If the editor uses spaces instead of tabs to represent indentations, this is
the number of spaces that comprises a single indentation.


4


Preview pane Shows an example of what your Java code will look like with the settings
currently displayed on this page.


n/a


Formatting Java code


Java editor
Java editor preferences
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Formatting Java code
The Java editor supports the formatting of Java code according to your personal preferences.


Java development tools (JDT)
Java editor


Using the Java editor
Setting code formatting preferences
Formatting files or portions of code
Using content/code assist


Code Formatter preferences
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Setting code formatting preferences
From the workbench menu bar, select Window > Preferences. The Workbench Preferences page
opens.


1. 


In the left pane, expand the Java category and select Code Formatter. The Code Formatter
Preferences page opens.


2. 


In the New Lines, Line Splitting, and Style tabs, select the code formatting conventions that you want
the formatter to follow.


3. 


Note that at the bottom of the page, you can observe an example effect of each individual code
formatting option and see a preview of what your formatted code will look like.


4. 


Click OK when you are done.5. 


Java development tools (JDT)


Formatting Java code
Formatting files or portions of code


Code Formatter preferences
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Formatting files or portions of code
To format Java code:


Use the Code Formatting Preferences page (Window > Preferences > Java > Code Formatter) to
specify your preferences for code formatting.


1. 


Open a Java file and select the code you want to format. If nothing is selected, then all of the editor
content is formatted.


2. 


Format the code by either
Selecting Source > Format from the editor's pop−up menu or♦ 
Pressing Ctrl+Shift+F or♦ 
Selecting Source > Format from the menu bar.♦ 


3. 


Java development tools (JDT)
Java editor


Using the Java editor
Formatting Java code
Setting code formatting preferences


Source menu
Code Formatter preferences
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Java editor
The following Java editor preferences can be set on this page:


Appearance• 
Syntax• 
Code Assist• 
Problem Indication• 


Appearance


Appearance specifies the Java editor's appearance.


Appearance


Option Description Default


Displayed tab width Specifies how wide tabs are displayed in units of spaces. 4


Print margin column Specifies the column after which the print margin is displayed.


To display the print margin, enable the option Show print margin,
the preference Appearance color options specifies the color of the
print margin.


80


Synchronize outline
selection on cursor move


If enabled, the Outline view always selects the Java element
enclosing the cursor in the Java editor.


Off


Show overview ruler If enabled, the overview ruler on the right border of the Java editor
is displayed and shows problems of the whole visible document.


On


Show line numbers If enabled, the vertical ruler on the left border of the Java editor
displays line numbers of the visible document.


The color of line numbers is specified with Appearance color
options.


Off


Highlight matching
brackets


If enabled, whenever the cursor is next to a parenthesis, bracket or
curly braces, its opening or closing counter part is highlighted.


The color of the bracket highlight is specified with Appearance
color options.


On


Highlight current line If enabled, the background of the current line of the cursor is
highlighted.


The color of the current line background is specified with
Appearance color options.


On


Show print margin If enabled, the print margin is displayed. Off
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The preferences Print margin column and Appearance color
options determine the position and color of the print margin.


Appearance color options The colors of various Java editor appearance features are specified
here.


Line number foreground
The color of line numbers.


Matching brackets highlight
The color of brackets highlight.


Current line highlight
The color of current line highlight.


Print margin
The color of the print margin.


Find scope
The color of find scope.


Linked position
The color of linked positions used in code assist.


Link
The color of a link.


default
colors


Syntax


Syntax specifies how Java source code is rendered.


Syntax


Option Description Default


Background color
System default:


The default background color given by the operating
system.


Custom:
A user defined background color.


System default


Foreground The following Java source fragments can be rendered with different
color and style:


Multi−line comment
Comments of the form '/* ... */'


Single−line comment
Comments starting with '//'


Keywords
All Java keywords.


Strings
Java strings and characters, surrounded by single and double
quotes


Others
Default Java source code


default colors
and styles
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Task tags
Task tags in comments


Javadoc keywords
Keywords used in Javadoc, starting with '@'


Javadoc HTML tags
HTML tags used in Javadoc s


Javadoc links
{@link reference} tag


Javadoc others
Default Javadoc text


Preview Displays the preview of a Java source code respecting the current
colors and styles.


n/a


Code assist


Code Assist specifies the behaviour and appearance of code assist.


Code Assist


Option Description Default


Completion
inserts/Completion
overwrites


If Completion inserts is on, the completion text is inserted at
the caret position, so it never overwrites any existing text.
If Completion overwrites is on, the completion text replaces
the characters following the caret position until the end of
the word.


Completion
inserts


Insert single proposals
automatically


If enabled, code assist will choose and insert automatically
single proposals.


On


Show only proposals visible
in the invocation context


If enabled, the Java element proposals are limited by the
rules of visibility. For example, private field proposals of
other classes would not be displayed.


On


Present proposals in
alphabetical order


If enabled, the proposals are sorted in alphabetical order.Off


Automatically add import
instead of qualified name


If enabled, type proposals which are in other packages will
invoke the addition of the corresponding import declaration.
Otherwise, the type will be inserted fully qualified.


On


Fill argument names on
method completion


If enabled, choosing a method proposal will additionally
insert the method's argument names as specified in its
declaration.


Off


Enable auto activation If enabled, code assist can be invoked automatically.


The condition for automatic invocation is specified with the
preferences Auto activation delay, Auto activation triggers
for Java and Auto activation triggers for Javadoc.


On
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Auto activation delay If the time starting when an auto activation trigger character
is encountered until a new character is typed exceeds the
auto activation delay, code assist is invoked.


500


Auto activation triggers for
Java


If one of the trigger characters is typed inside Java source
code (but not inside a Javadoc comment) and no other
character is typed before the auto activation delay times out,
the code assist is invoked.


'.'


Auto activation triggers for
Javadoc


If one of the trigger characters is typed inside a Java doc and
no other character is typed before the auto activation delay
times out, the code assist is invoked.


'@'


Code assist color options The colors used for the following code assist UI elements:


Completion proposal background
The background color of the completion proposal
window


Completion proposal foreground
The foreground color of the completion proposal
window


Method parameter background
The background color of the parameter window


Method parameter foreground
The foreground color of the parameter window


Completion overwrite background
The background color of the completion overwrite
window


Completion overwrite foreground
The foreground color of the completion overwrite
window


default colors


Annotations


Annotations specifies when and how annotations are displayed.


Annotations


Option Description Default


Analyze annotations while typing If enabled, annotations are updated as the user types.
Otherwise, annotations aren't updated until the Java file is
compiled.


On


Indicate annotations solvable with
Quick Fix in vertical ruler


Displays a light bulb on the vertical ruler on the left border
of the Java editor for every annotation solvable with Quick
Fix.


On


Annotation presentation For every type of annotation you can specify
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whether the annotation is shown in text, or in the
overview ruler, or in both


• 


in what color the annotation is rendered• 


Java Editor


Using the Java editor


Java editor Code Formatter preferences Outline view for Java Java Content Assist Quick Fix
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Content/code assist
If activated from a valid line of code in an editor, this command opens a scrollable list of available code
completions. Some tips for using code assist:


If you select and then hover over a selected line in the content assist list, you can view Javadoc
information for that line.


• 


You can use the mouse or the keyboard (Up Arrow, Down Arrow, Page Up, Page Down, Home, End,
Enter) to navigate and select lines in the list.


• 


Clicking or pressing Enter on a selected line in the list inserts the selection into the editor.• 
You can access specialized content assist features inside Javadoc comments.• 


Configure the behaviour of the content assist in the Java > Editor preference page (Code Assist tab).


Java editor
Java Development Tools (JDT)


Using content/code assist


Edit menu
Java editor preferences
Templates preferences
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Templates
The Templates preference page allows to create new and edit existing templates. A template is a convenience
for the programmer to quickly insert often reoccurring source code patterns.


The following buttons allow manipulation and configuration of templates:


Action Description


New... Opens a dialog to create a new template.


Edit... Opens a dialog to edit the currently selected template.


Remove Removes all selected templates.


Import... Imports templates from the file system.


Export... Exports all selected templates to the file system.


Export All... Exports all templates to the file system.


Enable All Enables all templates.


Disable All Disables all templates.


Use Code Formatter If enabled, the template is formatted according to the code formatting rules
specified in the Code Formatter preferences, prior to insertion. Otherwise, the
template is inserted as is, but correctly indented.


See Code Formatter preference page


Template dialog


Creating a new template and editing an existing template uses the same dialog, which is described here.


The following fields and buttons appear in the dialog:


Option Description


Name The name of the template.


Context The context determines where the template can be used and the set of available
pre−defined template variables.


Java
The Java context


Javadoc
The Javadoc context


Description A description of the template, which is displayed to the user when choosing the
template.


Pattern The template pattern.
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Insert Variables... Displays a list of pre−defined context specific variables.


Template variables


Both Java and Javadoc context define the following variables:


Variable Description


${cursor} Specifies the cursor position when the template edit mode is left. This
is useful when the cursor should jump to another place than to the end
of the template on leaving template edit mode.


${date} Evaluates to the current date.


${dollar} Evaluates to the dollar symbol '$'.


Alternatively, two dollars can be used: '$$'.


${enclosing_method} Evaluates to the name of the enclosing name.


${enclosing_method_arguments}Evaluates to a comma separated list of argument names of the
enclosing method. This variable can be useful when generating log
statements for many methods.


${enclosing_package} Evaluates to the name of the enclosing package.


${enclosing_project} Evaluates to the name of the enclosing project.


${enclosing_type} Evaluates to the name of the enclosing type.


${file} Evaluates to the name of the file.


${return_type} Evaluates to the return type of the enclosing method.


${time} Evaluates to the current time.


${user} Evaluates to the user name.


The Java context additionally defines the following variables:


Variable Description


${array} Evaluates to a proposal for a declared array name.


${array_element} Evaluates to a proposal for an element name of a declared array.


${array_type} Evaluates to a proposal for the element type of a declared array.


${collection} Evaluates to a proposal for a declared collection implementing
java.util.Collection.


${index} Evaluates to a proposal for an undeclared array index iterator.


${iterator} Evaluates to a proposal for an undeclared collection iterator.
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Templates


Using templates
Writing your own templates


Java Content Assist
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Templates
Templates are a structured description of coding patterns that reoccur in source code. The Java editor supports
the use of templates to fill in commonly used source patterns. Templates are inserted using content assist
(Ctrl+Space).


For example, a common coding pattern is to iterate over the elements of an array using a for loop that indexes
into the array. By using a template for this pattern, you can avoid typing in the complete code for the loop.
Invoking content assist after typing the word for will present you with a list of possible templates for a for
loop. You can choose the appropriate template by name (iterate over array). Selecting this template
will insert the code into the editor and position your cursor so that you can edit the details.


Many common templates are already defined. These can be browsed in Window > Preferences > Java >
Editor > Templates. You can also create your own templates or edit the existing ones.


Using templates
Writing your own templates


Edit menu
Java Content Assist
Templates preferences
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Using templates
To use templates:


In the Java editor, position the caret in a place where you want to insert a template.1. 
Invoke content assist by pressing Ctrl+Space.2. 
Templates appear in the presented list. Note that the list is filtered as you type, so typing a few first
characters of a template name will reveal it.


3. 


Note that a preview is presented for each selected template.4. 


Notes:


Templates can have variables, which are place−holders for the dynamic part of a template pattern, e.g. subject
to change with every application of the particular template.


When a template is inserted in the Java editor and the template pattern contained a template variable, the
editor enters the template edit mode.


The first variable is underlined and selected. The variable can be modified by typing in the editor. If the same
variable existed multiple times in the template pattern, all instances of the same variable are updated
instantaneously to save typing.


Pressing Tab navigates to the next unique template variable, Shift−Tab navigates to the previous unique
template variable.


The template edit mode is left by either pressing Tab on the last template variable or pressing Esc or Enter.


Example:


Create a method void m(int[] intarray){} and position the caret inside the method.• 
Type for and press Ctrl+Space to open Code Assist• 
Select the first entry from the list (i.e.for − iterate over array). Note the template preview window.• 
Note also that the name of the array (i.e. intarray) is automatically detected.• 
The local variable i is now selected and you are in the template edit mode. Typing another name
instantaneously updates all occurrences of it.


• 


Press Tab. You can now modify the suggested name for the array (pressing Shift−Tab will let you
modify the name of the local variable again).


• 


To leave the template edit mode
press Tab or Enter, which will move the caret so that you can enter the body of the newly
created loop or


♦ 


press Esc, which will not move the caret and preserves the current selection in the editor.♦ 


• 


Java editor
Templates


Using the Java editor
Writing your own templates
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Templates preference page
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Writing your own templates
You can define your own templates.


Go to Window > Preferences > Java > Editor > Templates and press the New button.• 
In the Name field, enter the name for the template. This name need not be unique. It is used for
selecting templates from the Code Assist list.


• 


Specify the context for the template using the Context combo−box:
Select java if the template is to be used in normal Java code♦ 
Select javadoc if the template is to be used in Javadoc comments♦ 


• 


In the Description field, enter a brief description of the template.• 
Use the Pattern text field to enter the the template pattern
The pattern may contain pre−defined and custom template variables.
Template variables are place−holders for the dynamic part of the template pattern, i.e. they are
different in every application of the particular template. Before a template is inserted, the variables in
its pattern are evaluated and the place−holders are replaced with the evaluated values. Variables are of
form ${variable_name}.


To insert a pre−defined template variable, use the Insert Variable button or press
Ctrl+Space and select the variable from the presented list.


♦ 


You can insert your own template variables, which then evaluate to the name of the variable
itself. You must, however, make sure that the name does not conflict with the pre−defined
template variable names in the specific context.


♦ 


If the dollar symbol $ should be displayed, it must be escaped by using two dollar symbols or
using the variable ${dollar}.


♦ 


• 


Templates


Using the Java editor
Using templates


Template preference page
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Organize imports
The following preferences define how the Organize Imports command generates the import statements in a
compilation unit.


Organize Imports Preferences


Option
Description Default


Import order list This list of prefixes shows the sequential order for packages imported
into a Java compilation unit. Each entry defines a block. Different
blocks are separated by a spacer line.


java
javax
org
com


New... Adds a package name prefix to the import order list. In the resulting
dialog, type a package name or package name prefix.


n/a


Edit... Change the name of an existing package name prefix. In the resulting
dialog, type a package name or package name prefix.


n/a


Up Moves the selected package name prefix up in the import order list.n/a


Down Moves the selected package name prefix down in the import order list.n/a


Remove Removes a package name prefix from the import order list. n/a


Load... Load a list of package name prefixes from a file. n/a


Save... Save the list of package name prefixes to a file. n/a


Number of imports needed
before .* is used


The number of fully−qualified import statements that are allowed from
the same package before <package>.* is used.


99


Do not create imports for
types starting with a lower
case letter


If enabled, types starting with a lowercase letter are not imported.On


Managing import statements


Source actions
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Managing import statements
The default Java editor includes several features that help you manage import statements.


Java editor


Using the Java editor
Adding required import statements
Organizing existing import statements
Setting the order of import statements


Source menu
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Adding required import statements
The Java editor can help you adding required import statements for a selected type inside a compilation unit.


Select a reference to a type in your Java code, and do one of the following:
Select Source > Add Import from the pop−up menu in the editor♦ 
Select Source > Add Import from the menu bar.♦ 
Press Ctrl + Shift + M♦ 


1. 


Either the editor can identify the type or you are prompted to choose the desired type from a list of
possible types.


2. 


The import statement is generated and inserted as specified by the import order preference.3. 


Java editor


Using the Java editor
Managing import statements
Organizing existing import statements
Setting the order of import statements


Source menu
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Organizing existing import statements
The Java editor can help you improve the existing import statements inside a compilation unit.


Do one of the following while editing your Java code:
Select Source > Organize Imports from the pop−up menu in the editor♦ 
Select Source > Organize Imports from the menu bar♦ 
Press Ctrl+Shift+O♦ 


1. 


The Java editor generates a complete list of import statements, as specified by the import order
preference, and new import statements replace the old ones.


2. 


Java editor


Adding required import statements
Managing import statements
Setting the order of import statements
Showing a type's compilation unit in the Package Explorer view


Source menu
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Setting the order of import statements
From the menu bar, select Window > Preferences.1. 
In the left pane, expand the Java category and select Organize Imports.2. 
The Organize Imports page defines the sorting order of import statements. In the Imports list, manage
the list of package prefixes as follows:


New to add a new prefix♦ 
Edit to change the name of an existing prefix♦ 
Use Up and Down buttons to rearrange the sequence of the list by moving the selected prefix
up or down


♦ 


Remove to remove the selected prefix from the list♦ 
Use Load... and Save... to load a list of prefixes from a file or to store it to a file♦ 


3. 


In the Number of imports needed before .* field, type the number of import statements that are
allowed to refer to the same package before <package prefix>.* is used. This number is called the
import threshold.


4. 


Click OK when you are done.5. 


Java editor


Adding required import statements
Managing import statements
Organizing existing import statements


Refactoring actions
Organize Import preference page
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Refactor actions
Refactor menu commands:


Name Function
Keyboard
Shortcut


Undo Does an Undo of the last refactoring. The refactoring undo buffer is only valid
as long as no other source changes than refactoring have been performed.


Alt + Shift
+ Z


Redo Does a Redo of the last undone refactoring. The refactoring undo/redo buffer is
only valid as long as no other source changes than refactoring have been
performed.


Alt + Shift
+ Y


Rename Starts the Rename refactoring dialog:  Renames the selected element and (if
enabled) corrects all references to the elements (also in other files). Is available
on methods, fields, local variables, method parameters, types, compilation
units, packages, source folders, projects and on a text selection resolving to one
of these element types. 


Alt + Shift
+ R


Move Starts the Move refactoring dialog: Moves the selected elements and (if
enabled) corrects all references to the elements (also in other files). Can be
applied to one instance method (which can be moved to a component), one or
more static methods, static fields, types, compilation units, packages, source
folders and projects and on a text selection resolving to one of these element
types. 


Alt + Shift
+ V


Change Method
Signature


Starts the Change Method Signature refactoring dialog. Changes parameter
names, parameter types, parameter order and updates all references to the
corresponding method. Additionally, parameters can be removed or added and
method return type as well as its visibility can be changed. This refactoring can
be applied to methods or on text selection resolving to a method. 


Convert
Anonymous
Class to Nested


Start the Convert Anonymous Class to Nested Class refactoring dialog. Helps
you convert an anonymous inner class to a member class. This refactoring can
be applied to anonymous inner classes.


Convert Nested
Type to Top
Level


Starts the Convert Nested Type to Top Level Type refactoring dialog. Creates
a new Java compilation unit for the selected member type, updating all
references as needed. For non−static member types, a field is added to allow
access to the former enclosing instance. This refactoring can be applied to
member types or text resolving to a member type.


Push Down


Starts the Push Down refactoring dialog. Moves a set of methods and fields
from a class to its subclasses. This refactoring can be applied to one or more
methods and fields declared in the same type or on a text selection inside a
field or method. 


Pull Up Starts the Pull Up refactoring wizard. Moves a field or method to a superclass
of its declaring class or (in the case of methods) declares the method as
abstract in the superclass. This refactoring can be applied on one or more
methods, fields and member types declared in the same type or on a text
selection inside a field, method or member type. 


Extract Interface


Starts the Extract Interface refactoring dialog. Creates a new interface with a
set of methods and makes the selected class implement the interface, optionally
changing references to the class to the new interface wherever possible. This
refactoring can be applied to types.
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Use Supertype
Where Possible


Starts the Use Supertype Where Possible dialog. Replaces occurrences of a
type with one of its supertypes after identifying all places where this
replacement is possible.This refactoring is available on types.


Inline Starts the Inline refactoring dialog. Inlines local variables, methods or
constants. This refactoring is available on methods, static final fields and text
selections that resolve to methods, static final fields or local variables.


Alt + Shift
+ I


Extract Method Starts the Extract Method refactoring dialog. Creates a new method containing
the statements or expression currently selected and replaces the selection with
a reference to the new method. You can use Expand Selection to from the Edit
menu to get a valid selection range.
This feature is useful for cleaning up lengthy, cluttered, or overly−complicated
methods. 


Alt + Shift
+ M


Extract Local
Variable


Starts the Extract Variable refactoring dialog. Creates a new variable assigned
to the expression currently selected and replaces the selection with a reference
to the new variable. This refactoring is available on text selections that resolve
to local variables. You can use Expand Selection to from the Edit menu to get a
valid selection range.


Alt + Shift
+ L


Extract Constant


Starts the Extract Constant refactoring dialog. Creates a static final field from
the selected expression and substitutes a field reference, and optionally
rewrites other places where the same expression occurs. This refactoring is
available on static final fields and text selections that resolve to static final
fields.


Convert Local
Variable to Field


Start the Convert Local Variable to Field refactoring dialog. Turn a local
variable into a field. If the variable is initialized on creation, then the operation
moves the initialization to the new field's declaration or to the class's
constructors. This refactoring is available on text selections that resolve to
local variables.


Encapsulate
Field


Starts the Self Encapsulate Field refactoring dialog. Replaces all references to
a field with getting and setting methods. Is applicable to a selected field or a
text selection resolving to a field.


Refactoring commands are also available from the context menus in many views and the Java editor.


Refactoring support


Refactoring
Using Structured Selection


Refactoring preference page
Refactoring dialogs
Extract Method Errors


 Basic tutorial
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Using Structured Selection
Structured Selection lets you quickly select Java code in a syntax−aware way.


To use Structured Selection:


In a Java editor, (optionally) select some text and press Alt+Shift+Arrow Up or select Edit >
Expands Selection To > Enclosing Element from the menu bar.


• 


The current text selection is expanded to the inner−most syntax element (more precisely, Abstract
Syntax Tree node) that encloses the selection.


• 


When a statement or a list of statements is selected, you can press Alt+Shift+Arrow Right or select
Edit > Expands Selection To > Next Element, which will expand the selection with the statement (if any
exists) that is immediately after the selected statements.


When a statement or a list of statements is selected, you can press Alt+Shift+Arrow Left or select Edit
> Expands Selection To > Previous Element, which will expand the selection with the statement (if any
exists) that is immediately before the selected statements.


Pressing Alt+Shift+Arrow Down or selecting Edit > Expands Selection To > Restore Last Selection
from the menu bar lets you restore the previous structured selection.


Java editor


Using the Java editor
Using Surround with Try/Catch
Extracting a method
Extracting a local variable
Inlining a local variable
Replacing a local variable with a query


Edit menu
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Using Surround with Try/Catch
To surround a statement or a set of statements with a try/catch block:


In the Java editor, select the statement or a set of statements that you want to surround with a try/catch
block.


• 


Do one of the following:
From the menu bar, select Source > Surround with try/catch Block or♦ 
From the editors pop−up menu, select Source > Surround with try/catch Block♦ 


• 


'catch' blocks for all uncaught exceptions (if there are any) are created. If there are no uncaught
exceptions, a dialog appears informing you about this fact and asking if you want to create a 'catch'
block for java.lang.RuntimeException.


• 


Java editor


Using the Java editor
Using Structured Selection


Source menu
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Extracting a method
To extract a method:


In an editor, select a set of statements or an expression from a method body.1. 
Do one of the following:


From the pop−up menu in the editor, select Refactor > Extract Method.♦ 
From the menu bar, select Refactor > Extract Method.♦ 


2. 


Java development tools (JDT)


Overriding a method
Renaming a method


Refactoring actions
Refactoring dialogs
Refactoring preferences
Extract method errors
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Overriding a method using the Hierarchy view
You can use the Hierarchy view to override a method:


Open the type hierarchy for the type in which you want to add the overriding method. Note: It does
not matter whether the subtypes, supertypes, or type hierarchy is displayed.


1. 


In the list pane of the Hierarchy view, make sure that the Show All Inherited Members button is
active in order to see all the inherited members. Note: The selection might not show all members if a
filter (such as Hide Fields or Hide Static Members) is active.


2. 


From the pop−up menu of one of the inherited methods, select Override in class name (where class
name is the name of the class in which the method will be created).


3. 


Java development tools (JDT)


Using the Hierarchy view
Extracting a method
Finding overridden methods
Opening a type hierarchy on a Java element
Renaming a method


Override methods
Source menu
Type Hierarchy view
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Finding overridden methods
You can discover which methods override a selected method.


Open the type hierarchy for the selected method's declaring type. Toggle on the Show the Subtype
Hierarchy toolbar button.


1. 


In the list pane of the Hierarchy view, make sure that the Lock View and Show Members in
Hierarchy button is toggled on. This option locks the current class in the method pane and shows only
those classes in the upper view that implement the currently selected method of the locked class.


The methods of interest are shown in the upper pane. You can select any method and open it in an
editor.


2. 


Note: The selection might not show all members if a filter (such as Hide Fields or Hide Static Members) is
active.


Java development tools (JDT)


Using the Hierarchy view
Filtering elements
Opening an editor for a selected element
Opening a type hierarchy on a Java element
Overriding a method


Override methods
Type Hierarchy view
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Override methods
This dialog lets you define methods to override.


Use Override/Implement Methods from the Source menu or the context menu on a selected type or on a text
selection in a type.


The dialog presents all methods that can be overridden from superclasses or implemented from interfaces.
Abstract methods or unimplemented methods are selected by default.


The tree view groups methods by the type declaring the method. If more than one type in the hierarchy declare
the same method, the method is only shown once, grouped to the first type in the list of supertypes that
implements or defines this method.


The flat view shows only methods, sorted alphabetically.


When pressing OK, method stubs for all selected methods are created.


Option Description Default


Select methods to
override or
implement


Select methods to override or
implement


Abstract methods from superclasses and
unimplemented methods from interfaces are
selected


Group methods by
types


Shows methods grouped by a list of
the super types in which they are
declared. 


selected 


Select All Select all methods


Deselect All Deselect all methods


To enable / disable that Javadoc comments are added to the created methods go to the Code Generation
preference page (Window > Preferences > Java > Code Generation) and enable / disable Create Javadoc
comments for methods and types.


For overridden methods you can choose to create non−Javadoc comments (Create non−Javadoc comments
for overridden methods). The reason for creating non−Javadoc comments is a feature of the Javadoc tool:
Methods that override a method automatically get the comment of the overridden method if they don't specify
an own Javadoc comment.


Overriding a method using the Hierarchy view
Source actions
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Code generation
The code generation preferences are separated in two sections:


Names• 
Code and Comments• 


Names


This page defines the naming conventions for fields (static and non−static), parameters and local variables.
For each variable type it is possible to configure a list of prefix or suffix or both.
Naming conventions are used by the Generate Getter and Setter action and by all actions and 'Quick Fix'
proposals that create fields, parameters and local variables.


Action Description


Edit... Opens a dialog to edit the list of prefix and suffixes for the currently
selected variable type


Code and Comments


The code and comment page contains code templates that are used by actions that generate code. Templates
contain variables that are substituted when the template is applied. Some variables are available in all
templates, some are specific to templates.


Action Description


Edit... Opens a dialog to edit the currently selected code template.


Import... Imports code templates from the file system.


Export... Exports all selected code templates to the file system.


Export All... Exports all code templates to the file system.


Automatically add
comments for new
methods and types


This setting specifies if comment code templates are automatically
added to all new methods. If disabled, the comment code templates are
only used when comment is explicitly added (e.g. using the Add
Javadoc Comment action). Note that this setting does not apply to
comments contained in the code templates like New Java files


Comment templates


Comment templates can contain the variable ${tags} that will be substituted by the standard Javadoc tags
(@param, @return..) for the commented element. The 'Overriding method' comment can additionally contain
the template ${see_to_overridden}


Constructor comment: Template that speciyfies the comment for new constructors• 
Type comment: Template that speciyfies the comment for new types. Note that this template can be• 
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referenced in the 'New Java File' template
Method comment: Template that speciyfies the comment for new methods that do not override an
method in a base class


• 


Overriding method comment: Template that speciyfies the comment for new methods that override an
method in a base class. By default the comment is defined as a non−Javadoc comment (Javadoc will
replace this comment with the comment of the overridden method). You can change this to a real
Javadoc comment if you want


• 


New Java files template


The 'New Java files' template is used by the Class and Interface wizards when a new file is created. The
template can specify where comments are added. Note that the template can contain the variable
${typecomment} that will be substituted by the evaluation of the type comment template.


Catch block body template


The 'Catch block body' template is used when a catch block body is created. It can use the variables
${exception_type} and ${exception_var}.


Method body template


The 'Method body' templates are used when new method with body is created. It contains the variable
${body_statement} that resolves to a return statement or/and a super−call.


Constructor body templates


The 'Constructor body' templates are used when new method or constructor with body is created. It contains
the variable ${body_statement} that resolves a super call.


Code Template dialog


The following fields and buttons appear in the dialog:


Option Description


Description A description of the template


Pattern The template pattern.


Insert Variables... Displays a list of pre−defined template specific variables.


Generating getters and setters


Source actions
Java editor
Java editor preferences
Templates preferences
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Renaming a method
You can rename a method by modifying its declaration in the compilation unit in which it is declared.
However, if you also want to update all references to it, you must either:


In a Java view presenting methods (for example the Outline view) select the method to be renamed.1. 
From the view's pop−up menu, select Refactor > Rename or select Refactor > Rename from the
global menu bar.


2. 


or


In a Java editor, select a reference to or the declaration of the method to be renamed.1. 
From the editor's pop−up menu, select Refactor > Rename or select Refactor > Rename from the
global menu bar.


2. 


Note 1: Renaming a method declared in an interface also renames (and updates all references to) all methods
that are implementations of that method.


Note 2: When renaming a non−static method declared as public, package visible, or protected, all methods
overriding it are also renamed and all references to them are updated.


Note 3: Renaming a static method or a private method updates references only to that method.


Java development tools (JDT)


Extracting a method
Overriding a method
Renaming method parameters


Override methods
Refactoring actions
Refactoring dialogs
Refactoring preferences
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Renaming method parameters
You can rename the parameters of a method by renaming the parameter's declaration as well as all references
to the parameters inside the method body.


Use the Change Method Signature command to rename one or more parameters of a method as well as all
references to these parameters.


Select the method in a Java view (the Outline view, for example)• 
From the method's pop−up menu, select Refactor > Change Method Signature or, from the menu
bar, select Refactor > Change Method Signature.
Note: these menu entries will no be active if the method has no parameters.


• 


Select a parameter, press the Edit button, enter a new name for the parameter and press OK• 


To rename a single parameter, it is often easier to:


Select the parameter in the Java editor.• 
From the editor's pop−up menu, select Refactor > Rename to open the Rename refactoring dialog.• 


Java development tools (JDT)


Changing method signature


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Changing method signature
In addition to renaming a method, you can change other parts of the method's signature.


Select the method in a Java view (e.g. Outline, Package Explorer, Members).• 
Do one of the following to open the Change Method Signature refactoring dialog:


From the menu bar, select Refactor > Change Method Signature or♦ 
From the method's pop−up menu, select Refactor > Change Method Signature♦ 


• 


Java development tools (JDT)


Renaming a method


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Refactoring Dialog
A dialog based user interface guides you through the steps necessary to execute a selected refactoring.
Depending on the complexity of the refactoring, either a wizard or a simple dialog is used to gather
information that is required for the refactoring.


Wizard based user interface (used for example, for Pull Up)• 
Dialog based user interface (used for example, for Rename)• 


Refactoring support


Refactoring actions
Icons
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Wizard based refactoring user interface
A wizard based user interface guides you through the steps necessary to execute a refactoring. A refactoring
wizard consists of 1 − n parameter pages, a preview page and a problem page.


Parameter pages


These pages gather information that is required for the refactoring. For example, the Pull Up refactoring uses
two pages to gather the methods and fields to be pulled up and to gather the obsolete methods and fields in
subclasses that can be deleted. The user can navigate the parameter pages using the Next > and < Back button.


After you have provided the required information, you can click Finish to carry out the refactoring without
previewing the results. If you want to preview the changes press Next >.


Preview page


The JDT allows you to preview the results of a refactoring action before you execute it.


The preview page consists of two parts:


A tree at the top containing all Java elements affected by the refactoring. Each top−level node in the
tree represents one compilation unit.


• 


A compare viewer at the bottom. The left side of the compare viewer shows the original, the right side
displays the refactored source.


• 


Problem page


The Refactoring Problem page indicates if there are suspected, potential, or definite problems with the
refactoring action you are attempting.


Four types of problems are possible:


Information
A problem described as Information will not affect the refactoring in any way, nor will it negatively
affect the code in the workbench. You can most likely ignore this type of problem.


Warnings
Warnings attempt to predict compiler warnings. This type of problem most likely will not negatively
affect the code in your workbench.


Errors
A problem described as an Error is very likely to cause compiler errors or change your workbench
code semantically. You can choose to continue with the refactoring in spite of these errors, although it
is not recommended.


Stop problems
This type of problem prevents the refactoring from taking place. For example, if you select a
comment and choose the Extract Method command from it, the workbench will issue a stop problem
on the refactoring attempt because you cannot extract a comment.


If there aren't any stop problems then the refactoring can be carried out by pressing the Finish button. To
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preview the results of the refactoring action, press the Next > button.


In the Refactoring preference page (Window > Preferences > Java > Refactoring), you can select the default
level for problems to be displayed when you are carrying out a refactoring.


Refactoring support


Previewing refactoring changes
Undoing a refactoring operation
Redoing a refactoring operation


Refactoring actions
Refactoring preferences Icons


 Basic tutorial
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Refactoring preferences
The following preferences can be set on the Refactoring Preferences page. (Window > Preferences > Java >
Refactoring.)


Option
Description Default


Confirm the execution of the
refactoring if


In this section, choose which kinds of problems will cause the
wizard to remain open and show the problems after pressing
Finish:


problems that prevent the actual refactoring from being
performed


• 


errors in the workbench• 
warnings in the workbench• 
information to be generated by precondition checking• 


Problems less severe than the selected level allow you to do a
refactoring without previewing the results.


Error


Save all modified resources
automatically prior to
refactoring


If this option is turned on, then whenever you perform a
refactoring action, the workbench will automatically save all
resources that have been modified since the last save.


Not
checked


Refactoring support


Refactoring
Refactoring without preview
Refactoring with preview
Previewing refactoring changes
Undoing a refactoring operation
Redoing a refactoring operation


Refactoring actions
Refactoring wizard
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JDT icons


Objects


Compilation Unit (*.java file)


Java file which is not on a build path


class file


file without icon assigned to its type


unknown object


Java scrapbook page (*.jpage file)


Java scrapbook page (evaluation in
progress)


JAR description file


Java Working Set


Java Model


JRE system library container


JAR file with attached source


JAR file without attached source


source folder


package


empty package


logical package


empty logical package


package only containing non Java
resources


package declaration


import container


import


default type (package visible)


public type


default interface (package visible)


public interface


default inner type (package visible)


private inner type


protected inner type


public inner type


 JDT icons 244







default inner interface (package
visible)


private inner interface


protected inner interface


public inner interface


default field (package visible)


private field


protected field


public field


default method (package visible)


private method


protected method


public method


Object adornments


marks project as Java project


this Java element causes an error


this Java element causes warning


this Java element is deprecated


constructor


abstract member


final member


static member


synchronized member


type with public static void
main(String[] args)


implements method from interface


overrides method from super class


type with focus in Type hierarchy


maximal expansion level in Call
Hierarchy


recursive call in Call Hierarchy
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Build path


class path variable


unresolved class path variable


JAR with attached source


JAR without attached source


system library


reference to unavailable project


reference to unavailable source folder


reference to unavailable JAR


build path ordering


inclusion filter


exclusion filter


output folder


Javadoc location


source attachment


Code assist


HTML tag


Javadoc tag


local variable


template


Compare


field


method


Debugger


debug launch


run launch


terminated run launch


process


terminated process


debug target


suspended debug target


 Basic tutorial
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terminated debug target


thread


suspended thread


stack frame


running stack frame


adornment that marks a stack frame
that may be out of synch with the
target VM as a result of an
unsuccessful hot code replace


adornment that marks a stack frame
that is out of synch with the target VM
as a result of an unsuccessful hot code
replace


inspected object or primitive value


watch expression


local variable


monitor


a monitor in contention


a thread in contention for a monitor


a monitor that is owned by a thread


a thread that owns a monitor


current instruction pointer (top of
stack)


current instruction pointer


enabled line breakpoint


disabled line breakpoint


adornment that marks a line
breakpoints as installed


adornment that marks a breakpoint as
conditional


adornment that marks an entry method
breakpoint


adornment that marks an exit method
breakpoint


field access watchpoint


field modification watchpoint


field access and modification
watchpoint


 Basic tutorial
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adornment that marks a watchpoint as
installed


exception breakpoint


runtime exception breakpoint


disabled exception breakpoint


adornment that marks an exception
breakpoint as caught


adornment that marks an exception
breakpoint as uncaught


adornment that marks an exception
breakpoint as scoped


adornment that marks an exception
breakpoint as installed


Editor


implements


overrides


quick assist available


search match


collapsed


expanded


JUnit


test


currently running test


successful test


failing test


test throwing an exception


test suite


currently running test suite


successfully completed test suite


test suite with failing test


test suite with exception throwing test


 Basic tutorial
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NLS tools


skipped NLS key


translated NLS key


untranslated NLS key


search for unused NLS keys


Quick fix


quick fixable error


quick fixable warning


error that got fixed in source but file
still needs a recompile


warning that got fixed in source but
file still needs a recompile


add


change


change cast


move to another package


remove


remove import


rename


surround with try/catch


Refactoring


general change


composite change


compilation unit change


text change


file change


Stop error


Error


Warning


Information


 Basic tutorial
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Search


Java Search


search for declarations


search for references


search for unused NLS keys


Search − Occurrences in File


a general match


read access to local or field


write access to local or field


Type hierarchy view


type from non selected package


interface from non selected package


 Basic tutorial
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Dialog based refactoring user interface
A dialog based user interface guides you through the steps necessary to execute a selected refactoring. A
dialog based refactoring user interface consists of a short first dialog gathering information that is required to
execute the refactoring, a separate problem dialog that pops up if any errors are detected and a preview dialog
to preview the results of a refactoring.


Input dialog


This dialog gathers information that is required for the refactoring. For example, for a rename refactoring you
will enter the new name for the Java element. You can either press OK to execute the refactoring or Preview >
to preview the result of the refactoring.


Preview dialog


The JDT allows you to preview the results of a refactoring action before you execute it.


The preview dialog consists of two parts:


A tree at the top containing all Java elements affected by the refactoring. Each top−level node in the
tree represents one compilation unit.


• 


A compare viewer at the bottom. The left side of the compare viewer shows the original, the right side
displays the refactored source.


• 


Problem dialog


The problem dialog indicates if there are suspected, potential, or definite problems with the refactoring action
you are attempting.


Four types of problems are possible:


Information
A problem described as Information will not affect the refactoring in any way, nor will it negatively
affect the code in the workbench. You can most likely ignore this type of problem.


Warnings
Warnings attempt to predict compiler warnings. This type of problem most likely will not negatively
affect the code in your workbench.


Errors
A problem described as an Error is very likely to cause compiler errors or change your workbench
code semantically. You can choose to continue with the refactoring in spite of these errors, although it
is not recommended.


Stop problems
This type of problem prevents the refactoring from taking place. For example, if you select a
comment and choose the Extract Method command from it, the workbench will issue a stop problem
on the refactoring attempt because you cannot extract a comment.


If there aren't any stop problems then the refactoring can be carried out by pressing the OK button. To preview
the results of the refactoring action, press the Continue button.
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In the Refactoring preference page (Window > Preferences > Java > Refactoring), you can select the default
level for problems to be displayed when you are carrying out a refactoring.


Refactoring support


Refactoring without preview
Refactoring with preview
Previewing refactoring changes
Undoing a refactoring operation
Redoing a refactoring operation


Refactoring actions
Refactoring preferences


Icons


 Basic tutorial
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Extract method errors
When you attempt to extract a method, you may get one or more of the following common errors:


Selected block references a local type declared outside the
selection A local type declaration is not part of the selection but is referenced by one of the
statements selected for extraction. Either extend the selection that it includes the local type declaration
or reduce the selection that no reference to the local type declaration is selected.


• 


A local type declared in the selected block is referenced outside
the selection The selection covers a local type declaration but the type is also referenced
outside the selected statements. Either extend the selection that is includes all references to the local
type or reduce the selection that the local type declaration isn't selected.


• 


Ambiguous return value: selected block contains more than one
assignment to local variable More than one assignment to a local variable was found
inside the selected block. Either reduce the selection that only one assignment is selected or extend
the selection that at least all reference except of one to the local variables are covered by the selection
too.


• 


Ambiguous return value: expression access to local and return
statement selected The selected statement generates more than one return value. This is for
example the case if an expression is selected and an expression's argument is modified as well. To
remedy this problem extend the selection to cover the read access of the modified argument as well.


• 


Selection contains a break statement but the corresponding break
target isn't selected To remedy the problem either extend the selection to include the
break / continue target or reduce the selection that the break / continue statement isn't covered by the
selection.


• 


Selection contains a continue statement but the corresponding
continue target isn't selected To remedy the problem either extend the selection to
include the break / continue target or reduce the selection that the break / continue statement isn't
covered by the selection.


• 


Selection starts inside a comment Parts of a comment cannot be extracted. Either
extend the selection that it covers the whole comment or reduce the selection that the comment isn't
covered at all.


• 


Selection ends inside a comment Parts of a comment can't be extracted. Either extend
the selection that it covers the whole comment or reduce the selection that the comment isn't covered
at all.


• 


Cannot extract selection that ends in the middle of a statement Adjust
selection so that it fully covers a set of statements or expressions. The users can extend the selection
to a valid range using the Expand Selection to in the Edit menu.


• 


Java development tools (JDT)


Refactoring support
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Extracting a method


Using Structured Selection


Source menu


Refactor Menu


 Basic tutorial
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Extracting a local variable
To extract a local variable from an expression:


In a Java editor, select the expression that you want to extract to a local variable• 
Do one of the following:


From the editor's pop−up menu, select Refactor > Extract Local Variable or♦ 
From the menu bar, select Refactor > Extract Local Variable♦ 


• 


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Inlining a local variable
To inline a local variable:


In a Java editor, select the variable that you want to inline (you can select a reference to the variable)• 
Do one of the following:


From the menu bar, select Refactor > Inline or♦ 
From the editor's pop−up menu, select Refactor > Inline♦ 


• 


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Replacing a local variable with a query
To replace a local variable with a query:


In the Java editor, select the expression with which the local variable is initialized• 
Invoke the Extract Method refactoring by either:


Selecting Refactor > Extract Method from the editor's pop−up menu or♦ 
Selecting Refactor > Extract Method from the menu bar♦ 


• 


Perform the Extract Method refactoring• 
Select the local variable (or a reference to it)• 
Invoke the Inline Local Variable by either:


Selecting Refactor > Inline from the editor's pop−up menu or♦ 
Selecting Refactor > Inline from the menu bar♦ 


• 


Perform the Inline Local Variable refactoring• 


Java development tools (JDT)


Extracting a method
Inlining a local variable


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Showing an element in the Package Explorer view
You can reveal an element's location in the Package Explorer view


In the Hierarchy or Outline view, select a type or one of its members.1. 
From the menu bar, select Navigate > Show In > Package Explorer. If the Package Explorer is not
already open, then it opens in the current perspective. The workbench navigates to the selected
element.


2. 


From the Java editor's pop−up menu, select Show in Package Explorer (the currently edited
compilation unit will be revealed)


3. 


Note: The element might not be revealed if Package Explorer filters are active or the Window > Preferences
> Java > Appearance > Show Members in Package Explorer preference is cleared.


Java views


Setting execution arguments
Renaming a compilation unit
Opening a type in the Package Explorer
Organizing existing import statements


Java Base preference page
Package Explorer
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Opening a type in the Package Explorer view
You can open the Package Explorer on any type that is included on a project's class path.


From the menu bar, select Navigate > Go To > Type. The Go to Type dialog opens.1. 
In the Choose a type field, begin typing an expression to narrow the list of available types, using
wildcards as needed. As you type, the list is filtered to display only types that match the current
expression.


2. 


In the Matching types list, select a type. When there is more than one definition of a type, then select
a package in the Qualifier list.


3. 


Click OK when you are done. The selected type is displayed in the Package Explorer.4. 


Note: Revealing may not be possible if Package Explorer filters are applied.


Java development tools (JDT)


Showing a type's compilation unit in the Package Explorer


Navigate actions
Package Explorer
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Create getter and setter
This dialog lets select the Getter and Setter methods to create.


Use Generate Getter and Setter from the Source menu or the context menu on a selected field or type, or a
text selection in a type to open the dialog. The Generate Getter and Setter dialog shows Getter and Setters for
all fields of the selected type. The methods are grouped by the type's fields.


The names of the getting and setting methods are derived from the field name. If you use a prefix or suffix for
fields (e.g. fValue, _value, val_m), you can specify the suffixes and prefixes in the Code Generation
preference page (Windows > Preferences > Java > Code Generation).


When pressing OK, all selected Getter and Setters are created


Option Description


Select methods to create Tree containing Getter and Setter methods that can be created. Getter and
Setters are grouped by field. 


Select All Select all Getters and Setter methods


Deselect All Deselect all Getters and Setter methods


You can control whether Javadoc comments are added to the created methods with the Automatically add
comments for new methods and types option on the Code and Comments tab of the Code Generation
preference page. (Window > Preferences > Java > Code Generation)


Generating getters and setters
Source actions
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String externalization
The Java tools help you to develop applications that can be run on international platforms. An important facet
of designing a program for use in different countries is the localization, or externalization, of text that is
displayed by the program. By externalizing strings, the text can be translated for different countries and
languages without rebuilding the Java program.


The JDT provides the following support for internationalization and string externalization:


A compiler option lets you mark non−externalized strings as compile−time warnings or errors.
See the Window > Preferences > Java > Compiler > Problems > Usage of non−externalized
strings preference


♦ 
• 


Tools that allow you to find strings that have not been externalized.• 
A wizard that will guide you through externalizing the strings.• 
Tools that help you to find unused and incorrectly used keys for strings located in property files.• 


Comments can be used to denote strings that should not be externalized and should not result in compile−time
warnings or errors. These comments are of form //$NON−NLS−n$ where n is the 1−based index of the
string in a line of code.


Additional information about internationalized applications can be found in the following documents:


http://eclipse.org/articles/Article−Internationalization/how2I18n.html• 
http://java.sun.com/docs/books/tutorial/i18n/intro/index.html• 


Finding strings to externalize
Finding unused and incorrectly used keys in property files
Using the Externalize Strings wizard


Source menu
Externalize Strings wizard
Compiler preferences
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Finding strings to externalize
To find strings to externalize:


In a Java view (e.g. Package Explorer), select a set of packages, source folders or projects.• 
From the menu bar, select Source > Find Strings to Externalize• 
A dialog comes up with a list of all compilation units that have some non−externalized strings• 
In the dialog, you can double click on a listed compilation unit or press the Externalize button to
open the Externalize Strings wizard


• 


String Externalization


Externalizing Strings
Finding unused and incorrectly used keys in property files
Using the Externalize Strings wizard


Externalize Strings wizard
Source menu
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Externalizing Strings


Java editor
String Externalization


Finding strings to externalize
Finding unused and incorrectly used keys in property files
Using the Externalize Strings wizard


Externalize Strings wizard
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Finding unused and incorrectly used keys in
property files
Finding unused and incorrectly used keys in a property file:


Open the Search dialog by:
pressing Ctrl+H or♦ 
selecting Search > Search from the menu bar♦ 


• 


See if a tab called NLS Keys is visible. If it is, then select it.• 
If it is not visible, press the Customize button and select the NLS Keys checkbox, press OK to close
the dialog and switch to the NLS Key tab.


• 


In the Resource bundle accessor class field, enter the name of the class that you use to retrieve strings
from the property file. You can use the Browse button to select the class from a list.


• 


In the Property file name field, enter the name of the property file. You can use the Browse button to
select the file.


• 


Select the scope of the search by using the controls in the Scope group.• 
Press Search• 


After the search is finished, the Search Result view displays a list of unused keys in the property file and all
incorrect references to non−existing keys.


Note: This feature assumes that the resource bundle accessor class used a method called getString with a
single String parameter to retrieve strings from the property file.


String Externalization


Externalizing Strings
Finding strings to externalize
Using the Externalize Strings wizard


Externalize Strings wizard
Source menu
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Using the Externalize Strings Wizard
To open the Externalize Strings wizard, do one of the following:


Find strings to externalize (using the Find Strings To Externalize function), select an entry in the
resulting dialog and press the Externalize button or


• 


Select the compilation unit in which you want to externalize strings and selecting Source >
Externalize Strings from the menu bar.


• 


Note: Externalizing strings is undoable (with the same restrictions as for refactorings). Use Refactor > Undo
from the menu bar to undo externalizing strings.


String Externalization


Externalizing Strings
Undoing a refactoring operation
Redoing a refactoring operation
Key/value page
Property file page


Externalize Strings wizard
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Key/value page
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Externalize Strings Key/value page


In the Enter common prefix for generated keys text field, you can specify an optional prefix that will
be used for all keys.


• 


Select one or more entries in the table and:
Press the Translate button to mark them as entries to externalize or♦ 
Press the Never Translate button to mark them as entries to be not externalized♦ 
Press the Skip button to mark them as entries excluded from externalization♦ 


• 


Icons on the left side of the entries are updated and so are the counter below the table• 
To edit a key, single−click on a row in the Key column. You can edit the key in−place. You can also
press the Edit Key button and edit the key in the dialog that appears then.


• 


Press Next to proceed to the Property File page or press Finish to externalize strings without checking
the settings from the Property File page (if you are not familiar with the externalize strings
functionality, it is recommended that you press Next to proceed to the Property File page).


• 


Note: You can double−click on the icons that are displayed on the left side of the table entries to alternate the
state between Translate, Never Translate and Skip
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Note (explanation of the table entry states):


Strings from entries marked as 'Translate' will be externalized and marked as such in the Java file by
adding non−nls tags.


• 


Strings from entries marked as 'Never Translate' will not be externalized but an non−nls tag will be
added to them to inform the wizard that they need not be translated.


• 


Strings from entries marked as 'Skip' will not be externalized and no tags will be added to them.• 


Externalizing Strings
Using the Externalize Strings wizard
Property file page
Undoing a refactoring operation
Redoing a refactoring operation
Refactoring with preview
Refactoring without preview


Externalize Strings wizard
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Property File page


Externalize Strings Property File page


In the Package field, enter the name fo the package in which you want the wizard to locate the
property file (you can use the Browse button to display the list of all packages)


1. 


In the Property file name field, enter the name of the property file (new or existing) in which the
externalized strings will be put (you can use the Browse button to display the list of all .properties
files located in the package selected in the Package field.)


2. 


Select the Create resource bundle accessor class checkbox if you want to create a class that will be
used to access the externalized strings (Note: the class will be reused if it exists already).


3. 


In the Class name field, if you have the above−mentioned checkbox selected, you can specify the
name of the accessor class


4. 


Press Next to see a preview of the modifications or press Finish to externalize strings without
previewing changes.


5. 


Note: The default behavior of the wizard (i.e. creating a class with a name specified in the Class name field
and using getString as the name of the method used to retrieve strings from the property file) can be
overridden. You may want to do so if you already have an accessor class in another package or your accessor
class uses another method with another name to get strings from the property file.


Clear the Use default substitution pattern checkbox1. 
In the Substitution pattern field enter the new pattern that will be used to retrieve strings from the
property file. For each externalized string, the first occurrence of ${key} will be substituted with the
key.


2. 
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Use the Add import declaration field if you want the wizard to add an additional import to the
compilation unit (you can use the Browse button to help you find a class that you want to import.)


3. 


Externalizing Strings
Using the Externalize Strings wizard
Key/value page
Undoing a refactoring operation
Redoing a refactoring operation
Refactoring with preview
Refactoring without preview


Externalize Strings wizard
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Externalize Strings wizard
The Externalize Strings wizard allows you to refactor a compilation unit such that strings used in the
compilation unit can be translated to different languages. The wizard consists of the following pages:


String selection page• 
Translation settings page• 
Error page• 
Preview page• 


String selection page


This page specifies which strings are translated and which not.


Field Description


Enter common prefix for
generated keys


Specifies an optional prefix for every generated key. For example, the fully
qualified name of the compilation unit could be used.


Strings to externalize Displays the list of non−externalized strings with proposed keys and values.


Translate Marks the selected strings to be translated.


Never Translate Marks the selected strings as not to be translated.


Skip Marks the selected strings as to be skipped.


Edit Key... Opens a dialog for entering a new key.


Context Displays the occurrence of the string in the context of the compilation unit.


Translation settings page


This page specifies translation specific settings.


Option Description


Package Specifies the destination package for the property file.


Property file name Specifies the property file name.


Create resource bundle accessor class in
"package"


If enabled, the wizard creates a class to access the language
specific resource bundle.


Class name The name of the class to access the resource bundle.


Use default substitution pattern If enabled, the wizard will use default substitution patterns.


Substitution pattern Specifies the source pattern to replace the string to externalize.


Add import declaration Specifies additional import declarations. This might be required
depending on referenced types by the substitution pattern.
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Error page


Displays a list of errors and warnings if any.


Preview page


Displays a preview of the actions which will be performed on 'Finish'.


String externalization


Externalizing Strings
Using the Externalize Strings wizard


Source actions
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Outline view for Java
This view displays an outline of the structure of the currently−active Java file in the editor area.


Toolbar buttons


Button Command Description


Go into Top Level
Type


Makes the top level type of the compilation unit the new input for
this view. Package declaration and import statements are no longer
shown.


Sort This option can be toggled to either sort the outline elements in
alphabetical order or sequential order, as defined inside the
compilation unit.


Note: Static members are always listed first.


Hide Fields Shows or hides the fields.


Hide Static Members Shows or hides the static fields and methods.


Hide Non−Public
Members


Shows or hides the static fields and methods.


Java editor
Java views


Generating getters and setters
Restoring a deleted workbench element
Setting method breakpoints
Showing and hiding members in Java views
Showing and hiding override indicators
Showing and hiding method return types in Java views
Sorting elements in Java views


Override methods
Views and editors
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Restoring a deleted workbench element
Ensure that a Java view that show Java elements inside files (such as the Outline view) is visible.1. 
Open the compilation unit to which you want to add a previously removed Java element from the
local history.


2. 


Activate the editor by clicking its tab in the editor area, and the Java view shows the content of the
Java file.


3. 


In the Java view, select the element to whose container type you want to restore the deleted element.4. 
From the type's pop−up menu in the Java view, select Restore from Local History.5. 
In the upper left pane of the resulting dialog, all available editions of the selected element in the local
history are displayed.


6. 


In the left pane check all elements that you want to replace.7. 
For every checked element select an edition in the right hand pane and view its content in the bottom
pane.


8. 


When you have identified the edition that you want to restore, press Restore. The local history
editions are loaded into the editor.


9. 


Java editor


Using the local history


Outline view for Java
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Using the local history
The JDT extends the workbench concept of a local history in three ways:


A file can be replaced with an edition from the local history not just in the Navigator but also in the
Package Explorer view.


• 


The JDT allows you to compare and/or replace individual Java elements (types and their members)
with editions from the local history.


• 


The JDT allows you to restore Java elements (and files) deleted from the workbench that have been
kept in the local history.


• 


Note: Files and Java elements such as types and their members change in time. A 'snapshot' of what they look
like a point in time (as saved in the local history) is called an edition.


Java development tools (JDT)
Java views


Using the Java editor
Replacing a Java element with a local history edition
Comparing a Java element with a local history edition
Restoring a deleted workbench element


Package Explorer
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Replacing a Java element with a local history
edition


Make sure that a Java view is visible.1. 
Open a Java editor for the Java file in which you want to replace a Java element with an edition from
the local history.


2. 


Activate the editor by clicking its tab in the editor area. The Java view also displays the Java file.
Note: The Package Explorer can be configured to show or not show Java elements in files. Use
Window > Preferences > Java > Appearance > Show Members in Package Explorer to set your
preference.


3. 


Select the element that you want to replace.4. 
From the element's pop−up menu, select Replace With > Element from Local History.5. 
In the upper pane of the resulting dialog, all available editions of the selected element in the local
history are displayed.


6. 


Select an edition in the upper pane to view the differences between the selected edition and the edition
in the workbench.


7. 


When you have identified the edition with which you want to replace the existing Java element, click
Replace.


8. 


The local history edition replaces the current one in the editor. Note: The changed compilation unit
has not yet been saved at this point.


9. 


Java views
Java editor


Using the local history


Outline view for Java
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Comparing a Java element with a local history
edition


Make sure that a Java view is visible.1. 
Open a Java editor for the Java file in which you want to compare a Java element with an edition from
the local history.


2. 


Activate the editor by clicking its tab in the editor area. The Java view also displays the Java file.
Note: The Package Explorer can be configured to show or not show Java elements in files. Use
Window > Preferences > Java > Appearance > Show Members in Package Explorer to set your
preference.


3. 


Select the element that you want to compare.4. 
From the element's pop−up menu, select Compare With > Element from Local History.5. 
In the upper pane of the resulting dialog, all available editions of the selected element in the local
history are displayed.


6. 


Select an edition in the upper pane to view the differences between the selected edition and the edition
in the workbench.


7. 


If you are done with the comparison, click OK to close the dialog.8. 


Java views
Java editor


Using the local history


Outline view for Java
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Showing and hiding members
Several Java views (e.g. Outline, Package Explorer, Members) offer filtering of members (fields, types and
methods). The filters are available as toolbar buttons or as view menu items, depending on the view. There are
3 member filters:


Hide Fields: when activated, this filter causes all fields to be removed from the view.• 
Hide Static Members: when activated, this filter causes all static members to be removed from the
view.


• 


Hide Non−Public Members: when activated, this filter causes all non−public members to be removed
from the view.


• 


Additionally, the Package Explorer can display or hide all elements inside compilation units.


To show members in the Package Explorer:


Select the Show members in Package Explorer checkbox in the Window > Preferences > Java >
Appearance page.


• 


To hide members in the Package Explorer:


Clear the Show members in Package Explorer checkbox in the Window > Preferences > Java >
Appearance page


• 


Showing and hiding elements
Filtering elements


Appearance preference page
Package Explorer
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Appearance
On this preference page, the appearance of Java elements in views can be configured. The options are:


Option Description Default


Show method return types If enabled, methods displayed in views display the return type.Off


Show override indicators in
outline and hierarchy


If enabled, an indicator is displayed for overridden and
implemented methods in the Outline and Type Hierarchy
views.


On


Show members in Package
Explorer


If enabled, Java elements below the level of Java files and
Class files are displayed as well.


On


Compress package name
segments


If enabled, package names are compressed according to the
compression pattern.


Off


Stack views vertically in the
Java Browsing perspective


If enabled, views in Java Browsing perspective will be stacked
vertically, rather than horizontally.


Off


Java views


Showing and hiding elements
Showing full or compressed package names


Package Explorer view
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Showing full or compressed package names
Package Explorer and Packages views can show full or compressed package names.


To show full package names:


Clear the Compress all package name segments, except the final segment checkbox on the Window >
Preference > Java > Appearance page


• 


To show compressed package names:


Check the Compress all package name segments, except the final segment checkbox on the Window
> Preference > Java > Appearance page


Compression patterns control how many characters of each package name segment are displayed. The
last segment of a package name is always displayed.


A compression pattern of "." indicates that only the separating periods are shown to represent a
segment. A digit (n) in a compression pattern represents the first n characters of a package name
segment. Examples are the best way to understand compression patterns. The package org.eclipse.jdt
would be displayed as follows using the example compression patterns:


.        ..jdt


0       jdt


2~     or~.ec~.jdt


3~     org.ecl~.jdt


• 


Java Appearance preference page


Appearance preference page
Package Explorer
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Showing and hiding override indicators
Outline and Hierarchy views can show special icons (override indicators) to indicate members that override or
implement other members from supertypes.


To show the override indicators:


Select the Show override indicators in outline and hierarchy checkbox in the Window > Preferences >
Java > Appearance page 


• 


To hide the override indicators:


Clear the Show override indicators in outline and hierarchy checkbox in the Window > Preferences >
Java > Appearance page 


• 


Showing and hiding elements
Filtering elements


Appearance preference page
Package Explorer
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Showing and hiding method return types
Several Java views (e.g. Outline, Members) present methods and can also show their return types.


To show method return types in Java views:


Open the Window > Preferences > Java > Appearance page and select the Show method return types
checkbox


• 


To hide method return types in Java views:


Clear the Show method return types checkbox in the Window > Preferences > Java > Appearance
page


• 


Showing and hiding elements
Filtering elements


Appearance preference page
Package Explorer
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Sorting elements in Java views
Members and Outline views can present members sorted or in the order of declaration in the compilation unit.


To sort members:


Toggle on the Sort toolbar button in the Java view• 


Note: the sorting order is defined as follows:


Nested types are presented before other members• 
Fields are presented before methods• 
Static members are presented before non−static members• 
After the above sorting is performed, members in each group are sorted alphabetically• 


To present members in the order of declaration in the compilation unit.


Toggle off the Sort toolbar button in the Java view• 


Java Toolbar actions
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Java toolbar actions


Java Actions


Toolbar Button Command Description


Create a Java ProjectThis command helps you create a new Java project.


See New Java Project Wizard


Create a Java PackageThis command helps you create a new Java package.


See New Java Package Wizard


Create a Java Class This command helps you create a new Java class.


See New Java Class Wizard


Create a Java
Interface


This command helps you create a new Java interface.


See New Java Interface Wizard


Create a Scrapbook
Page


This command helps you create a new Java scrapbook page for
experimenting with Java expressions.


See New Java Scrapbook Page Wizard


Open a Type in the
Editor


This command allows you to browse the workspace for a type to
open in the defined default Java editor. You can optionally choose to
display the type simultaneously in the Hierarchy view.


Choose a type:
In this field, type the first few characters of the type you
want to open in an editor. You can use wildcards as needed
("*" for a string, "?" for a character, "<" for end of line). 


Matching Types:
This list displays matches for the expression you type in the
Choose a type field. 


In Packages:
This list displays the packages where a type with the
selected name are defined. 


Java development tools (JDT)
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Creating Java elements
Opening an editor on a type


New Java Project wizard
New Java Package wizard
New Java Class wizard
New Java Interface wizard
New Java Scrapbook Page wizard
Views and editors


 Basic tutorial
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Opening an editor on a type
You can open an editor on any type in the workbench.


Note: If you open a type from a CLASS or JAR file, you will see a special editor showing only method
signatures unless you have attached source to it.


Press Ctrl+Shift+T or, select Navigate > Open Type from the menu bar. The Open Type dialog
opens.


1. 


In the Choose a type field, begin typing an expression to narrow the list of available types, using
wildcards as needed. As you type, the list is filtered to display only types that match the current
expression.


2. 


In the Matching types list, select a type. When there is more than one definition of a type, then select
a package in the Qualifier list.


3. 


Click OK when you are done. An editor opens on the selected type.4. 


Java editor


Attaching source to a JAR file
Opening an editor for a selected element
Using the Java editor


Navigate actions
Views and editors
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Run menu
This menu allows you to manage the running of an application in the workbench. Some menu items are only
active if the Debug view is the active view.


Java development tools (JDT)


Launching a Java program
Running and debugging


Run and debug actions
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Quick fix
For certain problems underlined with a problem highlight line, the Java editor can offer corrections. This is
shown by the light bulb shown in the editor marker bar.


To see the correction proposals use the Quick Fix action


Set the cursor inside the highlight range, and select Quick Fix from the Edit menu or the context
menu.


• 


Set the cursor inside the highlight range, and press Ctrl + 1• 
Click on the light bulb• 


Note that the light bulb is only a hint. It is possible that even with the light bulb shown, it turns out that no
corrections can be offered.


Provided corrections:


Problem Correction Proposals


Unresolved method reference
Change to a method with a similar
name


• 


Create method• 


Unresolved variable name 
Change to a variable with a similar
name


• 


Create field• 
Create local variable• 
Create parameter• 


Unresolved type name 
Change to a type with a similar name• 
Create class• 
Create interface• 
Add import statement• 
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Undefined constructor
Create constructor• 


Parameter mismatch
Change method name to matching
method


• 


Unhandled exception
Add try / catch statement• 
Add throws declaration to enclosing
method


• 


Type name does not match compilation unit name Change type name• 
Change file name• 


Package declaration does not match file location
Change package declaration• 
Move file• 


Unused import
Remove import• 


Type mismatch
Add cast statement• 
Change declared type• 


Unterminated string
Terminate string• 


Non−Externalized string
Open Externalize String wizard• 


To enable / disable problem indication & the light bulb go to the Java Editor preference page > Annotations


Java editor
Java Development Tools (JDT)


Using quick fix


Java editor preferences
Edit menu
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Renaming a class or an interface
You can rename a class or an interface by modifying its declaration in the compilation unit in which it is
declared. However, if you also want to update all references to it, do one of the following:


In a Java view presenting classes and/or interfaces (e.g. the Outline view, the Type Hierarchy views,
etc.) select a class or interface.


1. 


From the class' or interface's pop−up menu, select Refactor > Rename or use the Refactor > Rename
action from the global menu bar.


2. 


or


In a Java editor, select a reference to the class or interface.1. 
From the editor's pop−up menu, select Refactor > Rename or use the Refactor > Rename action from
the global menu bar.


2. 


Java projects
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Creating a top−level class
Creating a nested class
Creating a class in an existing compilation unit
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Creating a top−level class
You can create classes that are not enclosed in other types.


Open the New Class wizard.1. 
Edit the Source Folder field as needed to indicate in which folder you want the new class to reside.
You can either type a path or click the Browse button to find the folder. If a folder is found for the
current selection, that folder appears in the Source Folder field as the container for the new class.


2. 


In the Package field, type or click Browse to select the package where you want the new class to
reside. Leave this field empty to indicate that you want the new class to be created in the default
package.


3. 


Leave the Enclosing type box deselected.4. 
In the Name field, type a name for the new class.5. 
Select the public or default access modifier using the Modifiers radio buttons.
Note: The private and protected options are available only when creating a class enclosed in a type.


6. 


Optionally, select the abstract or final modifier for the new class using the appropriate check boxes:
Note: The static option is available only when creating a class enclosed in a type.


7. 


In the Superclass field, type or click Browse to select a superclass for the new class.8. 
Click the Add button to add interfaces for the new class to implement.9. 
If you want to create some method stubs in the new class:


Select the public static void main(String[] args) box if you want the wizard to add the main
method to the new class, thus making it a starting point of an application.


♦ 


Select the Constructors from superclass check box if you want the wizard to create, in the
new class, a set of constructors, one for each of the constructors declared in the superclass.
Each of them will have the same number of parameters (of the same types) as the respective
constructor from the superclass.


♦ 


Select the Inherited abstract methods check box if you want the wizard to generate method
stubs for each of the abstract methods that the new class will inherit from its superclass and
implemented interfaces.


♦ 


10. 


Click Finish when you are done.11. 
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Creating a nested class
You can create classes that are enclosed in other types (that is, nested classes).


Open the New Java Class wizard.1. 
Edit the Source Folder field to indicate in which folder you want the new class to reside. You can
either type a path or click Browse to find the folder. If a folder is found for the current selection, that
folder appears in the Source Folder field as the container for the new class.


2. 


Select the Enclosing Type check box and type the name of the enclosing type in the Enclosing Type
field. You can also click Browse to select the enclosing type for the new class.


3. 


In the Name field, type a name for the new class.4. 
Select the desired modifiers by using the Modifiers radio buttons and check boxes.5. 
In the Superclass field, type or click Browse to select a superclass for the new class.6. 
Click the Add button to add interfaces for the new class to implement.7. 
If you want to create some method stubs in the new class:8. 


Select the public static void main(String[] args) check box if you want the wizard to add the
main method to the new class, thus making it a starting point of an application.


♦ 


Select the Constructors from superclass check box if you want the wizard to create, in the
new class, a set of constructors, one for each of the constructors declared in the superclass.
Each of them will have the same number of parameters (of the same types) as the respective
constructor from the superclass.


♦ 


Select the Inherited abstract methods check box if you want the wizard to generate method
stubs for each of the abstract methods that the new class will inherit from its superclass and
implemented interfaces.


♦ 


9. 


Click Finish when you are done.10. 


Note: The new class is created in the same compilation unit as its enclosing type.
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New Source Folder Wizard
This wizard helps you to create a new source folder to a Java project.


Note that a new source folder can not be nested in existing source folders or in an output folder. You can
choose to add exclusion filters to the other nesting source folders or the wizard will suggest to replace the
nesting classpath entry with the new created entry. The wizard will also suggest to change the output location.


New Source Folder Options


Option Description Default


Project name Enter a project to contain the new source folder. Either type a
valid project name or click Browse to select a project via a
dialog.


The project of the
element that was
selected when the
wizard has been
started.


Folder name Type a path for the new source folder. The path is relative to the
selected project.


<blank>


Update exclusion filter
in other source folders
to solve nesting


Select to modify existing source folder's exclusion filters to solve
nesting problems. For example if there is an existing source
folder src and a folder src/inner is created, the source folder src
will be updated to have a exclusion filter src/inner.


Off


Java projects
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Creating a new source folder
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Opening a package
To reveal a package in the tree of the Package Explorer:


Select Navigate > Go To > Package from the menu bar. The Go to Package dialog opens.1. 
Type a package name in the Choose a package field to narrow the list of available packages, using
wildcards as needed. As you type, the list is filtered to display only packages that match the current
expression.


2. 


Select a package from the list, then click OK. The selected package is displayed in the Package
Explorer.


3. 


Java views
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Renaming a package
To rename a package:


In the Package Explorer or the Packages view select the package that you want to rename.1. 
From the view's pop−up menu, select Refactor > Rename.2. 


This updates all import statements of any affected compilation units and all fully qualified references to types
declared in the renamed package.


Java projects
Refactoring support


Opening a package
Moving folders, packages, and files
Creating a new Java package
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Display view
This view displays the result of evaluating an expression in the context of the current stack frame. You can
evaluate and display a selection either from the editor or directly from the Display view.


Java views
Java perspectives


Evaluating expressions
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Variables view
This view displays information about the variables in the currently−selected stack frame.


Java views
Java perspectives
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Views and editors
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Show detail pane
This command toggles showing the detail pane for the Expressions view. The details pane shows the toString
for selected objects. For primitive variables, it shows the value.
Code completion in the context of selected variable or the current stack frame is available as well. Evaluation
can occur on expressions using Inspect and Display


Evaluating expressions
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Show detail pane
This command toggles showing the detail pane for the Variables view. The details pane shows the toString for
selected objects. For primitive variables, it shows the value.
Code completion in the context of selected variable or the current stack frame is available as well. Evaluation
can occur on expressions using Inspect and Display


Evaluating expressions
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Re−launching a program
The workbench keeps a history of each launched and debugged program. To relaunch a program, do one of
the following:


Select a previous launch from Run or Debug button pull−down menus.• 
From the menu bar, select Run > Run History or Run > Debug History and select a previous launch
from these sub−menus.


• 


In the Debug view, select a process that you want to relaunch, and select Relaunch from the process's
pop−up menu.


• 


To relaunch the most recent launch, do one of the following:


Click the Run or Debug buttons (without using the button pull−down menu).• 
Select Run > Run Last Launched (Ctrl+F11), or Run > Debug Last Launched (F11) from the
workbench menu bar.


• 


Launching a Java program
Running and debugging


Debug view


 Re−launching a program 301







Console preferences
The following preferences can be set using the Console Preferences page. The console displays output from
running applications, and allows keyboard input to be read by running applications.


Option
Description Default


Fixed width
console


This preference controls whether the console has a fixed character width. When
on, a maximum character width must also be specified. Some applications write
long lines to the console which require horizontal scrolling to read. This can be
avoided by setting the console to use a fixed width, automatically wrapping
console output.


Off


Limit console
output


This preference limits the number of characters buffered in the console. When on,
a maximum buffer size must also be specified. When console output surpasses the
specified maximum, output is truncated from the beginning of the buffer.


On


Standard Out
Text Color


This preference controls the color of text written to the standard output stream by
an application.


Blue


Standard Error
Text Color


This preference controls the color of text written to the standard error stream by an
application.


Red


Standard In Text
Color


This preference controls the color of text typed into the console to be read by an
application.


Green


Show when
program writes
to standard out


Often, the Console view is hidden or inactive when you begin running or
debugging a program that creates output. If this option is turned on, then when you
run a program that produces output, the Console view is automatically opened (if
necessary) and is made the active view.


On


Show when
program writes
to standard error


Often, the Console view is hidden or inactive when you begin running or
debugging a program that creates error output. If this option is turned on, then
when you run a program that produces error output, the Console view is
automatically opened (if necessary) and is made the active view.


On


You can also click the Change button to set the font for the Console.
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Viewing marker help
You can use hover help to view various kinds of information in the marker bar in the editor area. For example:


Information about problems• 
Information about breakpoints• 


Hover your mouse pointer over the marker in the marker bar to view any available hover help.


Java development tools (JDT)


Using the Java editor
Viewing documentation and information
Viewing Javadoc information
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Showing and hiding empty packages
To show empty packages:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list clear the checkbox for Empty packages.2. 


To hide empty packages:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list select the checkbox for Empty packages.2. 


Showing and hiding elements
Filtering elements


Java Element Filters
Package Explorer
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Showing and hiding empty parent packages
To show empty parent packages:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list clear the checkbox for Empty parent packages.2. 


To hide empty parent packages:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list select the checkbox for Empty parent packages.2. 


Note: As an example, the parent packages created for package org.eclipse.ui, would be:


(default package)
org
org.eclipse


Showing and hiding elements
Filtering elements


Java Element Filters
Package Explorer


Showing and hiding empty parent packages 305







Showing and hiding Java files
To show Java files:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list clear the checkbox for Java files.2. 


To hide Java files:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list select the checkbox for Java files.2. 


Showing and hiding elements
Filtering elements
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Showing and hiding non−Java elements
To show non−Java elements:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list clear the checkbox for Non−Java elements.2. 


To hide non−Java elements:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list select the checkbox for Non−Java elements.2. 


Showing and hiding elements
Filtering elements


Java Element Filters
Package Explorer
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Showing and hiding non−Java projects
To show non−Java projects:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list clear the checkbox for Non−Java projects.2. 


To hide non−Java elements:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list select the checkbox for Non−Java projects.2. 


Showing and hiding elements
Filtering elements
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Showing and hiding import declarations
To show import declarations:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list clear the checkbox for Import declarations.2. 


To hide non−Java elements:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list select the checkbox for Import declarations.2. 


Showing and hiding elements
Filtering elements
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Showing and hiding package declarations
To show non−Java elements:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list clear the checkbox for Package declarations.2. 


To hide non−Java elements:


Select the Filters command from the Package Explorer's drop−down menu.1. 
In the exclude list select the checkbox for Package declarations.2. 


Showing and hiding elements
Filtering elements


Java Element Filters
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Extracting a constant
To extract a constant from an expression:


In a Java editor, select the expression that you want to extract to a constant• 
Do one of the following:


From the editor's pop−up menu, select Refactor > Extract Constant or♦ 
From the menu bar, select Refactor > Extract Constant♦ 


• 


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Renaming a field
You can rename a field by modifying its declaration in the compilation unit in which it is declared. However,
if you also want to update all references to it, do one of the following:


In a Java view presenting fields (for example in the Outline view) select a field.1. 
From the view's pop−up menu, select Refactor > Rename or select Refactor > Rename from the
global menu bar.


2. 


or


In a Java editor, select a reference to the field (or the field's declaration).1. 
From the editor's pop−up menu, select Refactor > Rename or select Refactor > Rename from the
global menu bar.


2. 


Refactoring actions
Refactoring dialogs
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Renaming a local variable
To rename a local variable (or a method parameter):


Select the variable (or a reference to it) in the Java editor• 
Do one of the following:


From the menu bar, select Refactor > Rename or♦ 
From the editor's pop−up menu, select Refactor > Rename♦ 


• 


Java development tools (JDT)


Parameters page
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Renaming method parameters
Changing method signature
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Parameters page


Parameters Page for the Rename Local Variable Refactoring Command


In the Enter new name field, type a new name for the local variable.• 
If you do not want to update references to the renamed local variable, deselect the Update references
to the renamed element checkbox.


• 


Click OK to perform a quick refactoring, or click Preview to perform a controlled refactoring.• 


Renaming a local variable
See Refactoring without Preview
See Refactoring with Preview
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Inlining a method
To inline a method:


In a Java editor or in one of the java views, select the method that you want to inline (you can also
select an invocation site of the method)


• 


Do one of the following:
From the menu bar, select Refactor > Inline or♦ 
From the editor's pop−up menu, select Refactor > Inline♦ 


• 


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Inlining a constant
To inline a constant:


In a Java editor or in one of the java views, select the constant that you want to inline (you can select
a reference to the constant)


• 


Do one of the following:
From the menu bar, select Refactor > Inline or♦ 
From the editor's pop−up menu, select Refactor > Inline♦ 


• 


Refactoring actions
Refactoring dialogs
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Self encapsulating a field
To self−encapsulate a field:


Select the field in one of the Java views (e.g. Outline, Package Explorer or Members view)• 
Do one of the following


From the menu bar, select Refactor > Self Encapsulate or♦ 
From the field's pop−up menu, select Refactor > Self Encapsulate♦ 


• 


You can also invoke this refactoring from the Java editor:


In the Java editor, select the field (or a reference to it)• 
Do one of the following


From the menu bar, select Refactor > Self Encapsulate or♦ 
From the editor's pop−up menu, select Refactor > Self Encapsulate♦ 


• 


Refactoring actions
Refactoring dialogs
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Pulling members up to superclass
To pull up class members (fields and methods) to the class's superclass:


In a Java view (e.g. Outline, Package Explorer, Members), select the members that you want to pull
up.


• 


Do on of the following:
From the menu bar, select Refactor > Pull Up or♦ 
From the pop−up menu, select Refactor > Pull Up♦ 


• 


Note: the selected members must all have the same declaring type for this refactoring to be enabled.


Refactoring actions
Refactoring dialogs
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Pushing members down to subclasses
To push down class members (fields and methods) to the class's subclasses:


In a Java view (e.g. Outline, Package Explorer, Members), select the members that you want to push
down.


• 


Do on of the following:
From the menu bar, select Refactor > Push Down or♦ 
From the pop−up menu, select Refactor > Push Down♦ 


• 


Note: the selected members must all have the same declaring type for this refactoring to be enabled.


Refactoring actions
Refactoring dialogs
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Moving static members between types
To move static members (fields and methods) between types:


In a Java view, select the static members that you want to move• 
Do one of the following:


From the menu bar, select Refactor > Move or♦ 
From the pop−up menu select, Refactor > Move♦ 


• 


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Moving an instance method to a component
To move an instance method to a component:


In a Java view or in the Java editor, select the method that you want to move• 
Do one of the following:


From the menu bar, select Refactor > Move or♦ 
From the pop−up menu select, Refactor > Move♦ 


• 


Refactoring actions
Refactoring dialogs
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Converting a local variable to a field
To convert a local variable to a field:


In a Java editor or in one of the java views, select the local variable• 
Do one of the following:


From the menu bar, select Refactor > Convert Local Variable to Field or♦ 
From the editor's pop−up menu, select Refactor > Convert Local Variable to Field♦ 


• 


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Converting an anonymous inner class to a nested
class
To convert an anonymous inner class to a nested class:


In a Java editor, position the care inside the anonymous class• 
Do one of the following:


From the menu bar, select Refactor > Convert Anonymous Class to Nested or♦ 
From the editor's pop−up menu, select Refactor > Convert Anonymous Class to Nested♦ 


• 


Refactoring actions
Refactoring dialogs
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Converting a nested type to a top level type
To convert a nested type to a top level type:


In a Java editor or a Java view, select the member type• 
Do one of the following:


From the menu bar, select Refactor > Convert Nested Type to Top Level or♦ 
From the editor's pop−up menu, select Refactor > Convert Nested Type to Top Level♦ 


• 


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Extracting an interface from a type
To extract an interface from a type:


In a Java editor or a Java view, select the type from which you want to extract an interface• 
Do one of the following:


From the menu bar, select Refactor > Extract Interface or♦ 
From the editor's pop−up menu, select Refactor > Extract Interface♦ 


• 


Refactoring actions
Refactoring dialogs
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Replacing references to a type with references to
one of its subtypes
To replace references to a type with references to one of its subtypes:


In a Java editor or a Java view, select the type• 
Do one of the following:


From the menu bar, select Refactor > Use Supertype Where Possible or♦ 
From the editor's pop−up menu, select Refactor > Use Supertype Where Possible♦ 


• 


Refactoring actions
Refactoring dialogs
Refactoring preferences
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Converting line delimiters
The Java editor can handle Java files with heterogenous line delimiters. However other external editors or
tools may not be able to handle them correctly.


If you want to change line delimiters used by your Java files:


Open a Java file in the Java editor1. 
Select Source > Convert Line Delimiters To from the menu bar2. 
Select the delimiters to which you want to convert the file to (one of CRLF, LF, CR)3. 


Java editor


Using the Java editor


Source menu
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Finding and replacing


Using the Java editor
Using the Find/Replace dialog
Using Incremental Find
Finding Next or Previous Match
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Using the Find/Replace dialog
To open the Find / Replace dialog:


Optionally, select some text in a text (or Java) editor1. 
Press Ctrl+F or2. 
From the menu bar, select Edit > Find / Replace3. 


To use the Find / Replace dialog:


In the Find field, enter the text you want to replace1. 
Optionally, in the Replace With field, enter the next text2. 
Use the radio buttons in the Direction group to select the direction of finding occurrences (relative to
the current caret position)


3. 


In the Scope radio button group:
Select the Selected Lines button if you want to limit find / replace to the lines you selected
when opening the dialog


♦ 


Select the All button otherwise♦ 


4. 


In the Options group:
Select the Case Sensitive checkbox if you want finding to be case sensitive.♦ 
Select the Whole Word checkbox if you want to find / replace only those occurrences in
which the text you entered in the Find field is a whole word


♦ 


Select the Wrap Search checkbox if you want the dialog to continue from the top of the file
once the bottom is reached (if you find / replace in Selected Lines only, then this option
applies to those lines only)


♦ 


Select the Incremental checkbox if you want to perform incremental find (e.g. the dialog will
find matching occurrences while you are typing in the Find field)


♦ 


5. 


Press:
Find if you want to find the next matching occurrence♦ 
Replace, if you want to replace the currently selected occurrence with the new text♦ 
Replace / Find, if you want to replace the currently selected occurrence with the new text and
find the next matching occurrence


♦ 


Replace All, if you want to replace all matching occurrences with the new text♦ 


6. 


Press Close.7. 


Java editor
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Using Incremental Find
To use Incremental Find:


In the text (or Java) editor, press Ctrl+J or select Edit > Incremental Find Next from the menu bar.1. 
The workbench status line displays "Incremental Find:". The editor is now in the Incremental Find
mode.


2. 


As you type, the editor finds the next occurrence of the text and updates the selection after each
character typed.


3. 


Navigate to the next or previous match by pressing Arrow Down or Arrow Up.4. 
Undo the last action within the Incremental Find mode by pressing Backspace.5. 
You can leave the Incremental Find mode by pressing Esc.6. 


Java editor
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Finding next or previous match
To find the next match:


In the text (or Java) editor, press Ctrl+K or select Edit > Find Next from the menu bar.1. 
The next occurrence of the text selected in the editor will be found.2. 


To find the previous match:


In the text (or Java) editor, press Ctrl+Shift+K or select Edit > Find Previous from the menu bar.1. 
The next occurrence of the text selected in the editor will be found.2. 


Java editor
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Changing the encoding used to show the source
To change the encoding used by the Java editor to display source files:


With the Java editor open, select Edit > Encoding from the menu bar• 
Select an encoding from the menu or select Others and, in the dialog that appears, type in the
encoding's name.


• 


Note: this setting affects only the way the source is presented.


To change the encoding that the Java editor uses when saving files, specify a text file encoding preference on
Window > Preferences > Workbench > Editors.


Java editor
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Commenting and uncommenting lines of code
To comment lines of code in the Java editor:


Select the lines you wish to comment• 
Do one of the following:


Press Ctrl+/ or♦ 
Select Source > Comment from the menu bar♦ 


• 


To uncomment lines of code in the Java editor:


Select the lines you wish to uncomment• 
Do one of the following


Press Ctrl+\ or♦ 
Select Source > Uncomment from the menu bar♦ 


• 


Java editor
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Shifting lines of code left and right
To shift lines of code to the right (i.e. indent):


Select the lines you wish to shift right• 
Do one of the following:


Press Tab or♦ 
Select Source > Shift Right from the menu bar♦ 


• 


To shift lines of code to the left (i.e. outdent):


Select the lines you wish to shift left• 
Do one of the following:


Press Shift+Tab or♦ 
Select Source > Shift Left from the menu bar♦ 


• 


Java editor
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Creating a new source folder with exclusion filter
In a project that uses source folders, you can create a new folder to contain Java source code with exclusion
patterns. Exclusion patterns are useful if you have nested source folders. There are two ways to do it:


You don't already have an existing Java project in which you want to create a source folder with
exclusion pattern.


1. 


You already have an existing Java project.2. 


Starting from scratch


First follow the steps of the task "Creating a new source folder".1. 
Once a first source folder is created, if you want to create another source folder that is nested inside
the first one, you need to use the exclusion pattern.


2. 


Click Create New Folder to create new source folder. Create a folder that is nested inside the first
one.


3. 


You will get a dialog saying that exclusion filter has been added to the first source folder.


NOTE: The trailing '/' at the end of the exclusion pattern is required to exclude the
children of this folder. The exclusion pattern follows the ant exclusion pattern syntax.


4. 


Click OK and Finish when you are done.5. 


From an existing Java Project


Before you start, make sure that your project properties are enabled to handle exclusion filters in
source folders.


1. 


In the Package Explorer, select the project where you want the new source folder to reside.2. 
From the project's pop−up menu, select New > Source Folder. The New Source Folder wizard opens.3. 
In the Project Name field, the name of the selected project appears. If you need to edit this field, you
can either type a path or click Browse to choose a project that uses source folders.


4. 


In the Folder Name field, type a name for the new source folder. If you choose a path that is nested
inside an existing source folder, you will see an error saying that you have nested source folders.


5. 


Check Update exclusion filters in other source folders to solve nesting.6. 
Click Finish when you are done.7. 
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Creating a new source folder with specific output
folder
Any source folder can use either the default project output folder or its specific output folder.


First follow the steps of the task "Creating a new source folder".1. 
Once a first source folder is created, you might want to change its default output folder.2. 
Click on Allow output folders for source folders. This adds a new entry to the source folder tree.3. 
Expand the source folder tree.4. 
Double−click on the Output folder entry.5. 
A dialog asks you if you want to use the project's default output folder or a specific output folder.
Choose the second option and click Browse....


6. 


Select the folder you want and click OK and then Finish.7. 


Java projects


Creating Java elements
Creating a new Java project
Creating a new Java package
Creating a Java project as its own source container
Creating a Java project with source folders
Creating a new source folder


New Source Folder wizard
Java Toolbar actions
Package Explorer


 Creating a new source folder with specific output folder 337







Creating your first Java project
In this section, you will create a new Java project. You will be using JUnit as your example project. JUnit is
an open source unit testing framework for Java.


Getting the Sample Code (JUnit)


First you need to download the JUnit source code.


Go to the http://www.eclipse.org/downloads/ page and locate the release that you are working with.1. 
Scroll down to the Example Plug−ins section and download the examples archive.2. 
Extract the contents of the Zip file to a directory from now on referenced as
<ExamplesDownloadPath> (e.g. c:\myDownloads).


3. 


Creating the project


Inside Eclipse select the menu item File > New > Project.... to open the New Project wizard.1. 
Select Java Project then click Next. On the next page, type "JUnit" in the Project name field and
click Finish. A Java perspective opens inside the workbench with the new Java project in the Package
Explorer. When the Java perspective is active, new menu options and Java specific buttons are loaded
in the workbench toolbar. Depending on which view or editor is active, other buttons and menu
options will be available.


2. 


In the Package Explorer, make sure that the JUnit project is selected. Select the menu item File >
Import....


3. 


Select Zip file, then click Next.4. 
Click the Browse button next to the Zip file field and browse to select
<ExamplesDownloadPath>eclipse/plugins/org.eclipse.jdt.ui.examples.projects_3.0.0/archive/junit/junit381src.jar.
Note: This step assumes that you followed steps 1−3 in the Getting the Sample Code section above.


5. 


In the Import wizard, below the hierarchy list click Select All. You can expand and select elements
within the junit directory on the left pane to view the individual resources that you are importing on
the right pane. Note: Do not deselect any of the resources in the junit directory at this time. You will
need all of these resources in the tutorial.


6. 
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Make sure that the JUnit project appears in the destination Folder field. Then click Finish. In the
import progress indicator, notice that the imported resources are compiled as they are imported into
the workbench. This is because the Build automatically option is checked on the Workbench
preferences page. You will be prompted to overwrite the .classpath and .project files in the JUnit
project. This is because the .classpath resource was created for you when you created the JUnit
project. It is safe to overwrite these files.


7. 


In the Package Explorer view, expand the JUnit project to view the JUnit packages.8. 
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Browsing Java elements using the package
explorer
In this section, you will browse Java elements within the JUnit project.


In the Package Explorer view, expand the JUnit project to see its packages.1. 
Expand the package junit.framework to see the Java files contained in the package.2. 
Expand the Java file TestCase.java. Note that the Package Explorer shows Java−specific
sub−elements of the source code file.  The import declaration, the public type, and its members (fields
and methods) appear in the tree.


3. 


Java views
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Opening a Java editor
In this section, you will learn how to open an editor for Java files. You will also learn about some of the basic
Java editor features.


Expand the package junit.samples and select the file VectorTest.java.  You can open VectorTest.java
in the Java editor by double clicking on it. In general you can open a Java editor for Java files, types,
methods and fields by simply double clicking on them. For example, to open the editor directly on the
method testClone defined in VectorTest.java double click on the method in the Package Explorer.


1. 


Notice the syntax highlighting.  Different kinds of elements in the java source are rendered in unique
colors.  Examples of java source elements that are rendered differently are:


Regular comments♦ 
Javadoc comments♦ 
Keywords♦ 
Strings.♦ 


2. 


Look at the Outline view. It displays an outline of the Java file including the package declaration,
import declarations, fields, types and methods. The Outline view uses icons to annotate Java
elements.  For example, icons indicate whether a Java element is static, abstract, or final.  Different
icons show you whether a method is overridden from a base class ( ) or when it implements a
method from an interface ( ).


3. 
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Toggle the Hide Fields, Hide Static Members, and Hide Non−Public Members buttons in the
Outline view toolbar to filter the view's display. Before going to the next step make sure that Hide
Non−Public Members button is not pressed.


4. 


You can edit source code by viewing the whole Java file, or you can narrow the view to a single Java
element. The toolbar includes a button, Show Source of Selected Element Only, that will cause only
the source code of the selected outline element to be displayed in the Java editor.  In the example
below, only the setUp() method is displayed.


5. 
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Press the Show Source of Selected Element Only button again to see the whole Java file again. In the
Outline view, select different elements and note that they are again displayed in a whole file view in
the editor. The Outline view selection now contains a range indicator on the vertical ruler on the left
border of the Java editor that indicates the range of the selected element.


6. 
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Adding new methods
Start adding a method by typing the following at the end of the VectorTest.java file (but before the
closing brackets of the type) in the Java editor:
public void testSizeIsThree()
As soon as you type the method name in the editor area, the new method appears at the bottom of the
Outline view.


In addition, an error annotation (red square) appears in the overview ruler positioned on the right hand
side of the editor. This error annotation indicates that the compilation unit is currently not correct. If
you hover over the red square a tool tip appears, Unmatched bracket; Syntax error on token ")", "{"
expected, which is correct since the method doesn't have a body yet. Note that error annotations in the
editor's rulers are updated as you type. This behavior can be controlled via Analyze annotations while
typing option located on the preference page Java > Editor under the Typing tab .


1. 
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Click the Save button. The compilation unit is compiled automatically and errors appear in the
Package Explorer view, in the Problems view and on the vertical ruler (left hand side of the editor). In
the Package Explorer view, the errors are propagated up to the project of the compilation unit
containing the error.


2. 


Complete the new method by typing the following:


{
  assertTrue(fFull.size() == 3);


Note, that the closing curly bracket has been auto inserted.


3. 


Save the file. Notice that the error indicators disappear since the missing bracket has been added.4. 


Java editor
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Using content assist
In this section you will use content assist to finish writing a new method. Open junit.samples.VectorTest.java
file in the Java editor if you do not already have it open and select the testSizeIsThree() method in the
Outline view. If the file doesn't contain such a method see Adding new methods for instructions on how to
add this method.


Add the following lines to the end of the method:


Vector v = new Vector();
for (int i=0; i<3; i++)
  v.addElement(new Object());
assert


1. 


With your cursor at the end of the word assert, press Ctrl+Space to activate content assist. The
content assist window with a list of proposals will appear. Scroll the list to see the available choices.


2. 


With the content assist window still active, type the letter 't' in the source code after assert (with no
space in between). The list is narrowed and only shows entries starting with 'assertt'. Select and then
hover over various items in the list to view any available Javadoc help for each item.


3. 


Select assertTrue(boolean) from the list and press Enter. The code for the
assertTrue(boolean) method is inserted.


4. 


Complete the line so that it reads as follows:


assertTrue(v.size() == fFull.size());


5. 
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Save the file.6. 
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Identifying problems in your code
In this section, you will review the different indicators for identifying problems in your code.


Build problems are displayed in the Problems view and annotated in the vertical ruler of your source code.


Open junit.framework.TestCase.java in the editor from the Package Explorer view.1. 
Add a syntax error by deleting the semicolon at the end of the package declaration in the source code.2. 


Click the Save button. The project is rebuilt and the problem is indicated in several ways:
In the Problems view, the problems are listed,♦ 
In the Package Explorer view, the Type Hierarchy or the Outline view, problem ticks appear
on the affected Java elements and their parent elements,


♦ 


In the editor's vertical ruler, a problem marker is displayed near the affected line,♦ 
Squiggly lines appear under the word which might cause the error, and♦ 
The editor tabs are annotated with a problem marker.♦ 


3. 


You can hover over the problem marker in the vertical ruler to view a description of the problem.4. 


Click the Close button on the editor's tab to close the editor.5. 
In the Problems view, select a problem in the list. Open its context menu and select Go To. The file is
opened in the editor at the location of the problem.


6. 
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Correct the problem in the editor by adding the semicolon. Click the Save button. The project is
rebuilt and the problem indicators disappear.


7. 


In the Outline view, select the method getName(). The editor will scroll to this method.8. 
On the first line of the method change the returned variable fName to fTestName. While you type,
a problem highlight underline appears on fTestName, to indicate a problem. Hovering over the
highlighted problem will display a description of the problem.


9. 


On the marker bar a light bulb marker appears. The light bulb signals that correction proposals are
available for this problem.


10. 


Set the cursor inside the marked range and choose Quick Fix from the Edit menu bar. You can also
press Ctrl+1 or left click the light bulb. A selection dialog appears with possible corrections.


11. 


Select 'Change to fName' to fix the problem. The problem highlight line will disappear as the
correction is applied.


12. 


Close the file without saving.13. 
You can configure how problems are indicated on the Window > Preferences > Workbench >
Editors > Annotations page.


14. 
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Using source code templates
In this section you will use content assist to fill in a template for a common loop structure. Open
junit.samples.VectorTest.java file in the Java editor if you do not already have it open.


Start adding a new method by typing the following:


public void testValues() {
    Integer[] expected= new Integer[3];
    for


1. 


With the cursor at the end of for, press Ctrl+Space to enable content assist.  You will see a list of
common templates for "for" loops.  When you hover over a template, you'll see the code for the
template in its help message.  Note that the local array name is guessed automatically.


2. 


Choose the for − iterate over array entry and press Enter to confirm the template.  The
template will be inserted in your source code.


3. 


Next we change the name of the index variable from i to e. To do so simply press e, as the index
variable is automatically selected. Observe that the name of the index variable changes at all places.
When inserting a template all template variable with the same name are connected to each other. So
changing one changes all the other values as well.


4. 


Pressing the tab key moves the cursor to the next variable of the code template. This is the array
expected.


5. 
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Since we don't want to change the name (it was guessed right by the template) we press tab again,
which leaves the template since there aren't any variables left to edit.
Complete the for loop as follows:


for (int e= 0; e < expected.length; e++) {
    expected[e]= new Integer(e + 1);
}
Integer[] actual= to


6. 


With the cursor at the end of to, press Ctrl+Space to enable content assist. Pick toarray −
convert collection to array and press Enter to confirm the selection (or double−click
the selection).


The template is inserted in the editor and type is highlighted and selected.


7. 


Overwrite the selection by typing Integer. The type of array constructor changes when you change
the selection.


8. 


Press Tab to move the selection to collection and overwrite it by typing fFull.9. 
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Add the following lines of code to complete the method:


assertEquals(expected.length, actual.length);
for (int i= 0; i < actual.length; i++)
    assertEquals(expected[i], actual[i]);
}


10. 


Save the file.11. 
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Organizing import statements
In this section you will organize the import declarations in your source code.  Open
junit.samples.VectorTest.java file in the Java editor if you do not already have it open.


Delete the import declarations by selecting them in the Outline view and selecting Delete from the
context menu. Confirm the resulting dialog with Yes. You will see numerous compiler warnings in the
vertical ruler since the types used in the method are no longer imported.


1. 


From the context menu in the editor, select Source > Organize Imports. The required import
statements are added to the beginning of your code below the package declaration.


You can also choose Organize Imports from the context menu of the import declarations in the
Outline view.
Note: You can specify the order of the import declarations in preferences Window > Preferences >
Java > Code Style > Organize Imports.


2. 
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Save the file.3. 
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Using the local history
In this section, you will use the local history feature to switch to a previously saved version of an individual
Java element.


Open junit.samples.VectorTest.java file in the Java editor and select the method testCapacity() in the
Outline view.


1. 


Change the content of the method so that the 'for' statements reads as:


for (int i= 0; i < 99; i++)


Save the file by pressing Ctrl+S.


2. 


In the Outline view, select the method testCapacity(), and from its context menu, select
Replace With > Element from Local History.


3. 


In the Replace Java Element from Local History dialog, the Local History list shows the various
saved states of the method. The Java Source Compare pane shows details of the differences between
the selected history resource and the existing workbench resource.


4. 
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In the Local History pane, select the method that you changed, then click the Replace button. In the
Java editor, the method is replaced with the selected history version.


5. 


Save the file.6. 
Beside replacing a method's version with a previous one you can also restore Java elements that were
deleted. Again, select the method testCapacity() in the Outline view, and from its context menu, select
Delete. Confirm the resulting dialog with Yes and save the file.


7. 


Now select the type VectorTest in the Outline view, and from its context menu, select Restore from
Local History.... Select and check the method testCapacity() in the Available Java Elements pane. As
before, the Local History pane shows the versions saved in the local history. The Java Source
Compare pane shows the details of the differences between the selected history version and the
existing workbench resource.


8. 
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In the Local History pane, select the earlier version and then click Restore.9. 
Press Ctrl+S to save the file.10. 
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Extract a new method
In this section, you will improve the code of the constructor of junit.framework.TestSuite. To make the intent
of the code clearer, you will extract the code that collects test cases from base classes into a new method
called collectTestMethods.


In the junit.framework.TestSuite.java file, select the following range of code inside the
TestSuite(Class) constructor:


Class superClass= theClass;
Vector names= new Vector();
while(Test.class.isAssignableFrom(superClass)) {
    Method[] methods= superClass.getDeclaredMethods();
    for (int i= 0; i < methods.length; i++) {
        addTestMethod(methods[i],names, constructor);
    }
    superClass= superClass.getSuperclass();
}


1. 


From the selection's context menu in the editor, select Refactor > Extract Method....2. 


In the Method Name field, type collectInheritedTests.3. 
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To preview the changes, press Preview>.The preview page displays the changes that will be made.
Press OK to extract the method.


4. 
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Go to the extracted method by selecting it in the Outline view.5. 
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Creating a Java class
In this section, you will create a new Java class and add methods using code generation actions.


In the Package Explorer view, select the JUnit project. From the project's context menu, select New >
Package or click the New Java Package button in the toolbar.


1. 


In the Name field, type test as the name for the new package. Then click Finish.2. 
In the Package Explorer view, select the new test package and click the New Java Class button in the
toolbar.


3. 


Make sure that JUnit appears in the Source Folder field and that test appears in the Package field. In
the Name field, type MyTestCase.


4. 


Click the Browse button next to the Superclass field.5. 
In the Choose a type field in the Superclass Selection dialog, type Test to narrow the list of available
superclasses.


6. 
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Select the TestCase class and click OK.7. 
Select the checkbox for Constructors from superclass.8. 
Click Finish to create the new class.9. 
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The new file is opened in the editor. It contains the new class, the constructor and comments.  You
can select options for the creation and configuration of generated comments in the Java preferences
(Window > Preferences > Java > Code Style > Code Templates).


10. 


In the Outline view select the new class MyTestCase. Open the context menu and select Source >
Override/Implement Methods....


11. 
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In the Override Methods dialog, check setUp() and tearDown() and click OK. Two methods are added
to the class.


12. 
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Change the body of setUp() to container= new Vector();13. 
container and Vector are underlined with a problem highlight line as they cannot be resolved. A light
bulb appears on the marker bar. Set the cursor inside Vector and press Ctrl+1 (or use Edit > Quick
Fix from the menu bar). Choose Import 'Vector' (java.util).This adds the missing import declaration.


Set the cursor inside container and press Ctrl+1. Choose Create field 'container' to add the new
field.


14. 


 Basic tutorial


 Creating a Java class 370







In the Outline view, select the class MyTestCase. Open the context menu and select Source >
Generate Getter and Setter....


15. 


The Generate Getter and Setter dialog suggests that you create the methods getContainer and
setContainer. Select both and click OK. A getter and setter method for the field container are added.


16. 
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Save the file.17. 
The formatting of generated code can be configured in Window > Preferences > Java > Code Style >
Code Formatter. If you use a prefix or suffix for field names (e.g. fContainer), you can specify this
in Window > Preferences > Java > Code Style > Fields so that generated getters and setters will
suggest method names without the prefix or suffix.


18. 


Java views
Java editor


Using quick fix
Creating Java elements
Overriding a method using the Hierarchy view
Generating getters and setters


 Basic tutorial


 Creating a Java class 372







New Java Class wizard
Source actions
Quick Fix
Override Methods dialog
Generate Getter and Setter dialog
Code formatter preference page
Code generation preference page


 Basic tutorial


 Creating a Java class 373







Renaming Java elements
In this section, you will rename a Java element using refactoring.  Refactoring actions change the structure of
your code without changing its semantic behavior.


In the Package Explorer view, select junit.framework.TestCase.java.1. 
From its context menu, select Refactor > Rename.2. 
In the Enter New Name field on the Rename Compilation Unit page, type "TestCase2".3. 


To preview the changes that will be made as a result of renaming the class, press Preview >.4. 
The workbench analyzes the proposed change and presents you with a preview of the changes that
would take place if you rename this resource. 


Since renaming a compilation unit will affect the import statements in other compilation units, there
are other compilation units affected by the change.  These are shown in a list of changes in the
preview pane.


5. 
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On the Refactoring preview page, you can scroll through the proposed changes and select or deselect
changes, if necessary.  You will typically accept all of the proposed changes.


6. 


Click OK to accept all proposed changes.7. 


You have seen that a refactoring action can cause many changes in different compilation units.  These changes
can be undone as a group.


In the menu bar, select Refactor > Undo Rename TestCase.java to TestCase2.java.1. 
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The refactoring changes are undone, and the workbench returns to its previous state. You can undo
refactoring actions right up until you change and save a compilation unit, at which time the
refactoring undo buffer is cleared.


2. 
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Moving and copying Java elements
In this section, you will use refactoring to move a resource between Java packages.  Refactoring actions
change the structure of your code without changing its semantic behavior.


In the Package Explorer view, select the MyTestCase.java file from the test package and drag it into
the junit.samples package. Dragging and dropping the file is similar to selecting the file and choosing
Refactor > Move from the context menu.


1. 


You will be prompted to select whether or not to update references to the file you are moving.
Typically, you will want to do this to avoid compile errors. You can press the Preview button to see
the list of changes that will be made as a result of the move.


2. 


Press Finish. The file is moved, and its package declaration changes to reflect the new location.3. 


The context menu is an alternative to using drag and drop.  When using the menu, you must specify a target
package in the Move dialog, in addition to selecting the update references options you've already seen.


Select the MyTestCase.java file and from its context menu, select Refactor > Move.1. 
In the Move dialog, expand the hierarchy to browse the possible new locations for the resource. Select
the junit.samples package, then click OK. The class is moved, and its package declaration is updated
to the new location.


2. 
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Navigate to a Java element's declaration
Open the junit.samples.money.MoneyTest.java file in the Java editor.1. 
On the first line of the MoneyTest class declaration, select the superclass TestCase and either


from the menu bar select Navigate > Open Declaration or♦ 
press F3.♦ 


The TestCase class opens in the editor area and is also represented in the Outline view.
Note: This command also works on methods and fields.


2. 
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With the TestCase.java editor open and the class declaration selected:
from the menu bar select Navigate > Open Type Hierarchy or♦ 
press F4.♦ 


3. 


The Hierarchy view opens with the TestCase class displayed.4. 
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Note: You can also open editors on types and methods in the Hierarchy view.
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Type Hierarchy View
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Viewing the type hierarchy
In this section, you will learn about using the Hierarchy view by viewing classes and members in a variety of
different ways.


In the Package Explorer view, find junit.framework.TestCase.java. From its context menu, select
Open Type Hierarchy. You can also open type hierarchy view:


from the menu bar by selecting Navigate > Open Type Hierarchy.♦ 
from the keyboard by pressing F4 after selecting TestCase.java.♦ 


1. 


The buttons in the view tool bar control which part of the hierarchy is shown.  Click the Show the
Type Hierarchy button to see the class hierarchy, including the base classes and subclasses. The small
arrow on the left side of the type icon of TestCase indicates that the hierarchy was opened on this
type.


2. 


Click the Show the Supertype Hierarchy button to see a hierarchy showing the type's parent elements
including implemented interfaces. This view shows the results of going up the type hierarchy.


3. 
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In this "reversed hierarchy" view, you can see that TestCase implements the Test interface.
Click the Show the Subtype Hierarchy button in the view toolbar.4. 


Click the Lock View and Show Members in Hierarchy button in the toolbar of the member pane,
then select the runTest() method in the member pane. The view will now show all the types
implementing runTest().


5. 
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In the Hierarchy view, click the Show the Supertype Hierarchy button. Then on the member pane,
select countTestCases() to display the places where this method is declared.


6. 
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In the Hierarchy view select the Test element and select Focus On 'Test' from its context menu. Test
is presented in the Hierarchy view.


7. 


Activate the Package Explorer view and select the package junit.framework. Use Open Type
Hierarchy from its context menu. A hierarchy is opened containing all classes of the package. For
completion of the tree, the hierarchy also shows some classes from other packages. These types are
shown by a type icon with a white fill.


8. 
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Use Previous Type Hierarchies to go back to a previously opened element. Click on the arrow next to
the button to see a list of elements or click on the button to edit the history list.


9. 


From the menu bar, select Window > Preferences. Go to Java and select Open a new Type
Hierarchy Perspective. Then click OK.


10. 


In the Hierarchy view, select the Test element again, and activate Open Type Hierarchy from the
Navigate menu bar. The resource containing the selected type is shown in a new perspective (the
Hierarchy perspective), and its source is shown in the Java editor.  By setting the preference option
for viewing type hierarchy perspectives, you can have more than one type hierarchy in your
workbench and switch between them as needed.


11. 


Java views


Using the Hierarchy view


Type Hierarchy view
Java Base preference page
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Searching the workbench
In this section, you will search the workbench for Java elements.


In the Search dialog, you can perform file, text or Java searches. Java searches operate on the structure of the
code. File searches operate on the files by name and/or text content. Java searches are faster, since there is an
underlying indexing structure for the code structure. Text searches allow you to find matches inside comments
and strings.


Performing a Java search from the workbench


In the Java perspective, click the Search button in the workbench toolbar or use Search > Java from
the menu bar.


1. 


If it is not already selected, select the Java Search tab.2. 
In the Search string field, type runTest. In the Search For area, select Method, and in the Limit To
area, select References.
Verify that the Scope is set to Workspace.


Then click Search. While searching you may click Cancel at any time to stop the search. Partial
results will be shown.


3. 


In the Java perspective, the Search view shows the search results.4. 
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Use the Show Next Match and Show Previous Match buttons to navigate to each match. If the file in
which the match was found is not currently open, it is opened in an editor.
When you navigate to a search match using the Search view buttons, the file opens in the editor at the
position of the match. Search matches are tagged with a search marker in the vertical ruler.


5. 


Searching from a Java view


Java searches can also be performed from specific views, including the Outline, Hierarchy view and the
Package Explorer view.
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In the Package Explorer view, double−click junit.framework.Assert.java to open it in an editor.1. 
In the Outline view, select the fail(String) method, and from its context menu, select References >
Workspace.


2. 


Searching from an editor


From the Package Explorer view, open junit.framework.TestCase.java. In the editor, select the class name
TestCase and from the context menu, select References > Workspace.
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Continuing a search from the search view


The Search Results view shows the results for the TestCase search. Select a search result and open the context
menu. You can continue searching the selected element's references and declarations.
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Performing a file search


In the Java perspective, click the Search button in the workbench toolbar or select Search > File from
the menu bar.


1. 


If it is not already selected, select the File Search tab.2. 
In the Containing text field, type TestCase. Make sure that the File name patterns field is set to
*.java. The Scope should be set to Workspace. Then click Search.


3. 
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To find all files of a given file name pattern, leave the Containing Text field empty.4. 


Viewing previous search results


In the Search Results view, click the arrow next to the Previous Search Results toolbar button to see a menu
containing the list of the most recent searches. You can choose items from this menu to view previous
searches.  The list can be cleared by choosing Clear History.


The Previous Search Results button will display a dialog with the list of all previous searches from the
current session.
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Selecting a previous search from this dialog will let you view that search.


Java search


Conducting a Java search using the search dialog
Conducting a Java search using pop−up menus


Refactoring actions
Refactoring wizard
Refactoring preferences
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Running your programs
In this section, you will learn more about running Java programs in the workbench.


In the Package Explorer view, find junit.textui.TestRunner.java and double−click it to open it in an
editor.


1. 


In the Outline view, notice that the TestRunner class has an icon which indicates that the class defines
a main method.


2. 


Right click on TestRunner.java in the Package Explorer and select Java Application from the
cascading Run menu. This will launch the selected class as a local Java application. The Run context
menu item is also available in other places, such as the Outline view.


3. 


Notice that the program has finished running and the following message appears in the Console view
telling you that the program needs an execution argument.  Running a program as a Java Application
uses the default settings for launching the selected class and does not allow you to specify any
arguments.


4. 


To specify arguments, use the drop−down Run menu in the toolbar and select Run....5. 
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This time, the Launch Configurations dialog opens with the TestRunner launch configuration
selected. A launch configuration allows you to configure how a program is launched, including its
arguments, classpath, and other options.  (A default launch configuration was created for you when
you chose Run > Java Application).


6. 


Select the Arguments tab and type junit.samples.VectorTest in the Program arguments area.7. 


Click Run. This time the program runs correctly, indicating the number of tests that were run.8. 


Switch to the Debug perspective. In the Debug view, notice that a process for the last program launch
was registered when the program was run.


By default, the Debug view automatically removes any terminated launches when a new launch is
created. This preference can be configured on the Launching preference page located under the
Run/Debug preference page.


9. 
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Note: You can relaunch a terminated process by selecting Relaunch from its context menu.
Select the drop−down menu from the Run button in the workbench toolbar. This list contains the
previously launched programs. These programs can be relaunched by selecting them in the history
list.


10. 


From the context menu in the Debug view (or the equivalent toolbar button), select Remove All
Terminated to clear the view of terminated launch processes.


11. 


Changing debugger launch options
Connecting to a remote VM with the Remote Java application launch configuration
Disconnecting from a VM
Launching a Java program
Running and debugging


Debug view
Run and debug actions
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Debugging your programs
In this section, you will debug a Java program.


In the Package Explorer view in the Java perspective, double−click junit.samples.VectorTest.java to
open it in an editor.


1. 


Place your cursor on the vertical ruler along the left edge of the editor area on the following line in the
setUp() method:


fFull.addElement (new Integer(1));


and double−click on the ruler to set a breakpoint.


The breakpoint icon indicates the status of the breakpoint.  The plain blue breakpoint icon indicates
that the breakpoint has been set, but not yet installed.  


Note: Once the class is loaded by the Java VM, the breakpoint will be installed and a checkmark
overlay will be displayed on the breakpoint icon.


2. 


In the Package Explorer view, select the junit.samples package and select the Run menu. Within the
Run menu, select Debug As, and then Java Application.  When you run a program from a package,
you will be prompted to choose a type from all classes in the package that define a main method. 


3. 


Select the VectorTest − junit.samples − /JUnit item in the dialog, then click OK.4. 
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The program will run until the breakpoint is reached.  When the breakpoint is hit, the Debug
perspective opens, and execution is suspended. Notice that the process is still active (not terminated)
in the Debug view. Other threads might still be running.


5. 
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Note: The breakpoint now has a checkmark overlay since the class VectorTest was loaded in the Java
VM.
In the editor in the Debug perspective, select new Vector() from the line above where the
breakpoint is set, and from its context menu, select Inspect.


6. 
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The expression is evaluated in the context of the current stack frame, and a pop−up appears which
displays the results. You can send a result to the Expressions view by pressing the key binding
displayed in the pop−up.


7. 


Expressions that you evaluate while debugging a program will be listed in this view. To delete an
expression after working with it, select the expression and choose Remove from its context menu.


8. 


The Variables view (available on a tab along with the Expressions view) displays the values of the
variables in the selected stack frame. Expand the fFull tree in the Variables view until you can see
elementCount.


9. 


The variables (e.g., elementCount) in the Variables view will change when you step through
VectorTest in the Debug view.  To step through the code, click the Step Over button.  Execution will
continue at the next line in the same method (or, if you are at the end of a method, it will continue in
the method from which the current method was called).


10. 


Try some other step buttons (Step Into, Step Return) to step through the code.  Note the differences in
stepping techniques.


11. 


You can end a debugging session by allowing the program to run to completion or by terminating it.
You can continue to step over the code with the Step buttons until the program completes.♦ 
You can click the  Resume button to allow the program to run until the next breakpoint is
encountered or until the program is completed.


♦ 


You can select Terminate from the context menu of the program's process in the Debug view
to terminate the program.


♦ 


12. 
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Breakpoints
Remote debugging
Local debugging


Adding breakpoints
Resuming the execution of suspended threads
Running and debugging
Suspending threads


Debug preferences
Debug view
Run and debug actions
Breakpoints view
Console view
Display view
Expressions view
Variables view
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Evaluating expressions
In this section, you will evaluate expressions in the context of your running Java program.


Debug junit.samples.VectorTest.java to the breakpoint in the setUp() method and select Step Over
twice to populate fFull.  (See the Debugging your Programs section for full details.)


1. 


Open the Display view by selecting Window > Show View > Display and type the following line in
the view:


fFull.size()


2. 


Select the text you just typed, and from its context menu, select Display.  (You can also choose
Display Result of Evaluating Selected Text from the Display view toolbar.)


3. 


The expression is evaluated and the result is displayed in the Display view.4. 


On a new line in the Display view, type the following line:


fFull.toArray()


5. 


Select this line, and select Inspect from the context menu.  (You can also choose Inspect Result of
Evaluating Selected Text from the Display view toolbar.)


6. 


A lightweight window opens with the value of the evaluated expression.7. 


Debugger
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Evaluating expressions
Displaying the result of evaluating an expression
Inspecting the result of evaluating an expression
Viewing compilation errors and warnings


Expressions view
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Evaluating snippets
In this section, you will evaluate Java expressions using the Java scrapbook. Java scrapbook pages allow you
to experiment with Java code fragments before putting them in your program.


In the File menu select New > Other > Java > Java Run/Debug > Scrapbook Page. You will be
prompted for a folder destination for the page.


1. 


In the Enter or select the folder field, type or browse below to select the JUnit project root directory.2. 
In the File name field, type MyScrap. 3. 
Click Finish when you are done.  A scrapbook page resource is created for you with the jpage file
extension.  (The jpage file extension will be added automatically if you do not enter it yourself.)  The
scrapbook page opens automatically in an editor.


4. 
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In the editor, type System.get and then use content assist (Ctrl+Space) to complete the snippet as
System.getProperties().


5. 


Select the entire line you just typed and select Display from the context menu.  You can also select
Display Result of Evaluating Selected Text from the toolbar.


6. 
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When the evaluation completes, the result of the evaluation is displayed and highlighted in the
scrapbook page.


7. 


You can inspect the result of an evaluation by selecting text and choosing Inspect from the context
menu (or selecting Inspect Result of Evaluating Selected Text from the toolbar.)


8. 


When you are finished evaluating code snippets in the scrapbook page, you can close the editor.  Save
the changes in the page if you want to keep the snippets for future use.


9. 


Debugger


Creating a Java scrapbook page
Displaying the result of evaluating an expression
Inspecting the result of evaluating an expression
Viewing compilation errors and warnings


New Java Scrapbook Page wizard
Java scrapbook page
Expressions view
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Using the Java browsing perspective
In this section you will use the Java browsing perspective to browse and manipulate your code. Browsing Java
elements with the Package Explorer gives an overview of using the Package Explorer to browse elements. In
contrast to the Package Explorer, which organizes all Java elements in a tree, consisting of projects, packages,
compilation units, types, etc., the browsing perspective uses distinct views to present the same information.
Selecting an element in one view, will show its content in another view.


To open a browsing perspective activate Window > Open Perspective > Java Browsing from within the Java
perspective or use the context menu of the Open a Perspective toolbar button.


The views of the perspective are connected to each other in the following ways:


Selecting an element in the Projects views shows its packages in the Packages view.• 
The Types view shows the types contained in the package selected in the Packages view.• 
The Members view shows the members of a selected type. Functionally, the Members view is
comparable to the Outline view used in the normal Java perspective.


• 


Selecting an element in the Members view reveals the element in the editor. If there isn't an editor
open for the element, double−clicking on the element will open a corresponding editor.


• 
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All four views are by default linked to the active editor. This means that the views will adjust their content
and their selection according to the file presented in the active editor. The following steps illustrate this
behavior:


Select junit.extensions in the Packages view.1. 
Open type TestSetup in the editor by double−clicking it in the Types view.2. 
Now give back focus to the editor opened on file TestCase.java by clicking on the editor tab. The
Packages, Types and Members view adjust their content and selections to reflect the active editor.
The Packages view's selection is set to junit.framework and the Types view shows the content of the
junit.framework packages. In addition, the type TestCase is selected.


3. 


Functionally, the Java browsing perspective is fully comparable to the Java perspective. The context menus
for projects, packages, types, etc. and the global menu and tool bar are the same. Therefore activating these
functions is analogous to activating them in the Java perspective.
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Writing and running JUnit tests
In this section, you will be using the JUnit testing framework to write and run tests. To get started with JUnit
you can refer to the JUnit Cookbook.


Writing Tests


Before you can write JUnit tests you have to add the junit.jar library to your build class path. The Eclipse
installation includes JUnit in the org.junit plug−in:


Create a project "JUnitTest"1. 
Open the project's build path property page (on the project's context menu choose Properties > Java
Build Path)


2. 


Switch to the Libraries tab3. 
Add the junit.jar contained in org.junit in the plug−ins directory as an external JAR to your project.4. 


Optionally, if you want to browse the JUnit source, then attach the junitsrc.zip to the junit.jar. The source zip
is located in the org.eclipse.jdt.source plug−in in src/org.junit_3.8.1.


Now that the JUnitTest project has access to the JUnit classes you can write your first test. You implement the
test in a subclass of TestCase. You can do so either using the standard Class wizard or the specialized Test
Case wizard:


Open the New wizard (File > New > JUnit Test Case).1. 
Enter "TestFailure" as the name of your test class:2. 
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Click Finish to create the test class.3. 


Add a test method that fails to the class TestFailure. A quick way to enter a test method is with the test
template. To do so type "test" followed by Ctrl+Space to activate code assist and select the "test" template.
Change the name of the created method to testFailure and invoke the fail() method. Also change the visibility
modifier such that the test method is public.


public void testFailure() {
    fail();
}


Now you are ready to run your first test.


Running Tests


To run TestFailure, and activate the Run drop−down menu in the toolbar and select Run as > JUnit Test. You
can inspect the test results in the JUnit view. This view shows you the test run progress and status:
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The view is shown in the current perspective whenever you start a test run. A convenient arrangement for the
JUnit view is to dock it as a fast view. The JUnit view has two tabs: one shows you a list of failures and the
other shows you the full test suite as a tree. You can navigate from a failure to the corresponding source by
double clicking the corresponding line in the failure trace.


Dock the JUnit view as a fast view, remove the fail() statement in the method testFailure() so that the test
passes and rerun the test again. You can rerun a test either by clicking the Rerun button in the view's tool bar
or you can re−run the program that was last launched by activating the Run drop down. This time the test
should succeed. Because the test was successful, the JUnit view doesn't pop up, but the success indicator
shows on the JUnit view icon and the status line shows the test result. As a reminder to rerun your tests the
view icon is decorated by a "*" whenever you change the workspace contents after the run.


 − A successful test run


 − A successful test run, but the workspace contents has changed since the last test run.


In addition to running a test case as described above you can also:
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Run all tests inside a project, source folder, or package −  
Select a project, package or source folder and run all the included tests with Run as > JUnit Test.
This command finds all tests inside a project, source folder or package and executes them.


• 


Run a single test method −
Select a test method in the Outline or Package Explorer and with Run as > JUnit Test the selected
test method will be run.


• 


Rerun a single test −
Select a test in the JUnit view and execute Rerun from the context menu.


• 


Customizing a Test Configuration


When you want to pass parameters or customize the settings for a test run you open the Launch Configuration
Dialog. Select Run....in the Run drop−down menu in the toolbar:


In this dialog you can specify the test to be run, its arguments, its run−time class path, and the Java run−time
environment.
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Debugging a Test Failure


In the case of a test failure you can follow these steps to debug it:


Double click the failure entry from the stack trace in the JUnit view to open the corresponding file in
the editor.


1. 


Set a breakpoint at the beginning of the test method.2. 
Select the test case and execute  Debug As>JUnit Test from the Debug drop down.3. 


A JUnit launch configuration has a "keep alive" option. If your Java virtual machine supports "hot code
replacement" you can fix the code and rerun the test without restarting the full test run. To enable this option
select the Keep JUnit running after a test run when debugging checkbox in the JUnit launch configuration.


Creating a Test Suite


The JUnit TestSuite wizard helps you with the creation of a test suite. You can select the set of classes that
should belong to a suite.


Open the New wizard1. 
Select Java > JUnit > JUnit Test Suite and click Next.2. 
Enter a name for your test suite class (the convention is to use "AllTests" which appears by default).3. 
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Select the classes that should be included in the suite. We currently have a single test class only, but
you can add to the suite later.


4. 


You can add or remove test classes from the test suite in two ways:


Manually by editing the test suite file• 
By re−running the wizard and selecting the new set of test classes.• 


Note: the wizard puts 2 markers, //$JUnit−BEGIN$ and //$JUnit−END$, into the created Test suite
class, which allows the wizard to update existing test suite classes. Editing code between the markers is not
recommended.
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Project configuration tutorial
In this section, you will create and configure a new Java project to use source folders and to match some
existing layout on the file system. Some typical layouts have been identified. Choose the sub−section that
matches your layout.


Java projects
Java views


Working with build paths
Creating a new Java project
Creating a Java project with source folders
Creating a new source folder
Using the Package Explorer


New Java Project Wizard
Package Explorer View
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Detecting existing layout


Layout on file system


The source files for a product are laid out in one directory "src".• 
The class files are in another directory "bin".• 


Steps for defining a corresponding project


Open a Java perspective, select the menu item File > New > Project.... to open the New Project
wizard.


1. 


Select Java project in the list of wizards and click Next.2. 
On the next page, type "Product" in the Project name field.3. 
In Project layout group, change selection to Create separate source and output folders.


In Location group, change selection to Create project at external location.


Click Browse... and choose the "Product" directory.


4. 
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Click Next.


Ensure that the source and output folders are detected.


5. 
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Warning: If the preference Window > Preferences > Java > Compiler > Build Path > Scrub output
folder when cleaning projects is checked, clicking Finish will scrub the "bin" directory in the file
system before generating the class files.
Click Finish.6. 
You now have a Java project with a "src" folder which contains the sources of the "Product"
directory.


7. 
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Note: This solution creates a ".project" file and a ".classpath" file in the "Product" directory. If you do not
wish to have these files in the "Product" directory, you should use linked folders as shown in the Sibling
products in a common source tree section.


Java projects
Java views


Working with build paths
Creating a new Java project
Creating a Java project with source folders
Creating a new source folder
Using the Package Explorer


New Java Project Wizard
Package Explorer View
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Sibling products in a common source tree


Layout on file system


The source files for products are laid out in one big directory that is version and configuration
managed outside Eclipse.


• 


The source directory contains two siblings directories "Product1" and "Product2".• 


Steps for defining corresponding projects


Open a Java perspective, select the menu item File > New > Project.... to open the New Project
wizard.


1. 


Select Java project in the list of wizards and click Next.2. 
On the next page, type "Product1" in the Project name field. Click Next.3. 
On the next page, Select "Product1" source folder and click Add Folder....4. 
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In New Source Folder dialog, type "JavaSourceFiles" in the Folder name field.


Click Advanced. Check Link to folder in the file system.


Click Browse.... and choose the "JavaSourceFiles" directory in "Product1".


5. 


Click OK to close the dialog.6. 
Click Yes in confirmation dialog to have "Product1/bin" as default output folder.7. 
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Your project source setup now looks as follows:8. 


Click Finish.9. 
Repeat these steps for "Product2".10. 
You now have two Java projects which respectively contain the sources of "Product1" and
"Product2".


11. 
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Java projects
Java views


Working with build paths
Creating a new Java project
Creating a Java project with source folders
Creating a new source folder
Using the Package Explorer


New Java Project Wizard
Package Explorer View
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Organizing sources


Layout on file system


In this section, you will create a new Java project and organize your sources in separate folders. This
will prepare you for handling more complex layouts.


• 


Let's assume you want to put your sources in one folder and your tests in another folder:• 


Steps for defining a corresponding project


Open a Java perspective, select the menu item File > New > Project.... to open the New Project
wizard.


1. 


Select Java project in the list of wizards and click Next.2. 
On the next page, type "MyProject" in the Project name field. Click Next.3. 
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On the next page, Select "MyProject" source folder and click Add Folder....


In New Source Folder dialog, type "sources" in the Folder name field.


4. 


Click OK to close the dialog.5. 
Click Yes in confirmation dialog to have "MyProject/bin" as your default output folder.6. 
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Click again on Add Folder....7. 
In Source Folder Selection, click on Create New Folder....8. 
In New Folder dialog, type "tests" in the Folder name field.9. 
Click OK twice to close the two dialogs.10. 
Your project setup now looks as follows:11. 


Click Finish12. 
You now have a Java project with a "sources" and a "tests" folders. You can start adding classes to
these folders or you can copy them using drag and drop.


13. 


 Basic tutorial


 Organizing sources 426







Java projects
Java views


Working with build paths
Creating a new Java project
Creating a Java project with source folders
Creating a new source folder
Using the Package Explorer


New Java Project Wizard
Package Explorer View
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Overlapping products in a common source tree


Layout on file system


The Java source files for products are all held in a single main directory.• 
Products are separated into four siblings packages "product1", "product2", "product3" and "product4".• 


Steps for defining corresponding "Product1" and "Product2" projects


Open a Java perspective, select the menu item File > New > Project.... to open the New Project
wizard.


1. 


Select Java project in the list of wizards and click Next.2. 
On the next page, type "Product1" in the Project name field. Click Next.3. 
On the next page, Select "Product1" source folder and click Add Folder....4. 
In New Source Folder dialog, type "src" in the Folder name field.


Click Advanced. Check Link to folder in the file system.


Click Browse.... and choose the "AllJavaSourceFiles" directory.


5. 


Click OK to close the dialog.6. 
Click Yes in confirmation dialog to have "Product1/bin" as default output folder.7. 
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Expand the "src" source folder. Select Included and click Edit....8. 
In Inclusion patterns section of Inclusion and Exclusion Patterns dialog, click Add....


Type "com/xyz/product1/" in the Add Inclusion Pattern dialog.


Click OK to validate and close the dialog.


9. 


The Inclusion and Exclusion Patterns dialog now looks as follows:


Click OK to validate and close the dialog.


10. 


Your project source setup now looks as follows:11. 
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Click Finish.
Repeat these steps for "Product2", including "com/xyz/product2/" instead.12. 
You now have two Java projects which respectively contain the sources of "product1", "product2".13. 
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Java projects
Java views


Working with build paths
Creating a new Java project
Creating a Java project with source folders
Creating a new source folder
Using the Package Explorer


New Java Project Wizard
Package Explorer View


 Basic tutorial


 Overlapping products in a common source tree 431







Product with nested tests


Layout on file system


The Java source files for a product are laid out in a package directory.• 
Source files of tests are laid out in a nested package directory.• 


Steps for defining a corresponding project


Open a Java perspective, select the menu item File > New > Project.... to open the New Project
wizard.


1. 


Select Java project in the list of wizards and click Next.2. 
On the next page, type "Product1" in the Project name field. Click Next.3. 
On the next page, Select "Product1" source folder and click Add Folder....4. 
In New Source Folder dialog, type "src" in the Folder name field.


Click Advanced. Check Link to folder in the file system.


Click Browse.... and choose the "JavaSourceFiles" directory.


5. 


Click OK to close the dialog.6. 
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Click Yes in confirmation dialog to have "Product1/bin" as default output folder.7. 


Click Add Folder....8. 
Expand "Product1", then "src" and select "tests".9. 


Click OK. You get an information dialog saying that exclusion filters have been added. Click OK.10. 
Your project source setup now looks as follows:11. 
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Click Finish.12. 
You now have a Java project with a "src" folder and a "tests" folder which contain respectively the
"JavaSourceFiles" directory and the "tests" directory.


13. 
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Java projects
Java views


Working with build paths
Creating a new Java project
Creating a Java project with source folders
Creating a new source folder
Using the Package Explorer


New Java Project Wizard
Package Explorer View
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Products sharing a common source framework


Layout on file system


The Java source files for two products require a common framework.• 
Projects and common framework are in separate directories which have their own source and output
folders.


• 


Steps for defining corresponding projects


Open a Java perspective, select the menu item File > New > Project.... to open the New Project
wizard.


1. 


Select Java project in the list of wizards and click Next.2. 
On the next page, type "Product1" in the Project name field. Click Next.3. 
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On the next page, Select "Product1" source folder and click Add Folder....4. 
In New Source Folder dialog, type "src" in the Folder name field.


Click Advanced. Check Link to folder in the file system.


Click Browse.... and choose the "JavaSourceFiles" directory in "Product1".


5. 


Click OK to close the dialog.6. 
Click again on Add Folder....7. 
In New Folder dialog, type "src−common" in the Folder name field.


Click Advanced. Check Link to folder in the file system.


8. 
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Click Browse.... and choose the "JavaSourceFiles" directory in "CommonFramework".


Click OK to close the dialog.9. 
Check that "Product1/bin" is in the Default output folder field.10. 


Click Finish.11. 
Repeat these steps for "Product2".12. 
You now have two Java projects which respectively contain the sources of "Product1" and "Product2"
and which are using the sources of "CommonFramework".


13. 
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Note: Files in "src−common" are shared. So editing "Common.java" in "Product1" will modify
"Common.java" in "Product2". However they are compiled in the context of their respective projects. Two
"Common.class" files will be generated; one for each project. If the two projects have different compiler
options, then different errors could be reported on each "Common.java" file.


Java projects
Java views


Working with build paths
Creating a new Java project
Creating a Java project with source folders
Creating a new source folder
Using the Package Explorer


New Java Project Wizard
Package Explorer View
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Nesting resources in output directory


Layout on file system


The Java source files for a product are laid out in "sources" directory.• 
Java class files are laid out in "deliverable" directory.• 
Project needs to use some libraries located in "deliverables/libraries" directory:• 


Steps for defining a corresponding project


Open a Java perspective, select the menu item File > New > Project.... to open the New Project
wizard.


1. 


Select Java project in the list of wizards and click Next.2. 
On the next page, type "Product" in the Project name field. Click Next.3. 
On the next page, Select "Product" source folder and click Remove.


Type "Product/deliverables" in Default output folder field.


Then click on Add Folder....


4. 


In New Source Folder dialog, type "sources" in the Folder name field.


Click Advanced. Check Link to folder in the file system.


Click Browse.... and choose the "sources" directory in "Product".


5. 
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Click OK to close the dialog.6. 
Click again on Add Folder....7. 


In Source Folder Selection dialog, click on Create New Folder...


Type "deliverables" in the Folder name field.


Click Advanced. Check Link to folder in the file system.


Click Browse.... and choose the "deliverables" directory in "Product".


8. 
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Click OK twice to close the two dialogs.9. 
You project setup now looks as follows:10. 


Expand "Product/deliverables" and select Excluded


Click on Edit... and click on Add... in Exclusion patterns part of the Inclusion and Exclusion
Patterns dialog


Type "libraries/" in Add Exclusion Pattern dialog and click OK to validate and close the dialog


11. 
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Click OK to close the dialog.12. 
Your project source setup now looks as follows:13. 


Click Finish.14. 
Open project properties (using Alt−Enter or contextual menu)15. 
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Select Java Build Path page and go to Libraries tab


Click on Add JARs... and expand "Product" hierarchy to select jar files in "libraries" directory


Click OK.16. 
You now have a Java project with a "sources" folder and an output folder which contains nested
library resources.


17. 


Java projects
Java views
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Working with build paths
Creating a new Java project
Creating a Java project with source folders
Creating a new source folder
Using the Package Explorer


New Java Project Wizard
Package Explorer View


 Basic tutorial
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Concepts
Java projects• 
Java builder• 
Java perspectives• 
Java views• 
Java editor• 
Quick Fix• 
Templates• 
Java search• 
Refactoring support• 
Build classpath• 
Classpath variables• 
Debugger• 
Scrapbook• 
Local debugging• 
Remote debugging• 
Breakpoints• 
String externalization• 
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Tasks
Changing the appearance of the Java tools


Showing and hiding elements
Showing and hiding system files◊ 
Showing and hiding CLASS files generated for inner types◊ 
Showing and hiding libraries◊ 
Showing and hiding empty packages◊ 
Showing and hiding empty parent packages◊ 
Showing and hiding Java files◊ 
Showing and hiding non−Java elements◊ 
Showing and hiding non−Java projects◊ 
Showing and hiding members◊ 
Showing and hiding override indicators◊ 
Showing and hiding method return types◊ 
Showing and hiding import declarations◊ 
Showing and hiding package declarations◊ 


♦ 


Showing full or compressed package names♦ 
Sorting elements in Java views♦ 
Customizing the debugger and console


Changing the active perspective when launching◊ 
Changing the appearance of the console view◊ 


♦ 


• 


Creating Java elements
Creating a new Java project


Creating a Java project as its own source container◊ 
Creating a Java project with source folders◊ 


♦ 


Creating a new source folder
Creating a new source folder with exclusion filter◊ 
Creating a new source folder with specific output folder◊ 


♦ 


Creating a new Java package♦ 
Creating a new Java class


Creating a top−level class◊ 
Creating a nested class◊ 
Creating a new class in an existing compilation unit◊ 


♦ 


Creating a new Java interface
Creating a top−level interface◊ 
Creating a nested interface◊ 
Creating a new interface in an existing compilation unit◊ 


♦ 


• 


Creating JAR Files
Creating a new JAR file♦ 
Setting advanced options♦ 
Defining the JAR file's manifest♦ 
Regenerating a JAR File♦ 


• 


Creating Javadoc documentation
Specifying the location of the Javadoc command♦ 
Using the Generate Javadoc wizard


Selecting types for Javadoc generation◊ 
Configuring Javadoc arguments for standard doclet◊ 
Configuring Javadoc arguments◊ 


♦ 


• 


Using the Hierarchy view• 
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Changing the appearance of the Hierarchy view♦ 
Opening a type hierarchy on a Java element♦ 
Opening a type hierarchy on the current text selection♦ 
Opening a type hierarchy in its own perspective♦ 
Overriding a method using the Hierarchy view♦ 
Finding overridden methods♦ 


Using the Package Explorer
Filtering elements♦ 
Moving folders, packages and files♦ 


• 


Using the Java editor
Generating getters and setters♦ 
Showing single elements or whole Java files♦ 
Managing import statements


Adding required import statements◊ 
Organizing existing import statements◊ 
Setting the order of import statements◊ 


♦ 


Using the local history
Comparing a Java element with a local history edition◊ 
Replacing a Java element with a local history edition◊ 
Restoring a deleted workbench element◊ 


♦ 


Using content assist♦ 
Formatting Java code


Formatting files or portions of code◊ 
Setting code formatting preferences◊ 


♦ 


Viewing documentation and information
Viewing marker help◊ 
Viewing Javadoc information◊ 


♦ 


Using templates♦ 
Writing your own templates♦ 
Converting line delimiters♦ 
Finding and replacing


Using the Find/Replace dialog◊ 
Using Incremental Find◊ 
Finding Next or Previous Match◊ 


♦ 


Changing the encoding used to show the source♦ 
Using Quick Fix♦ 
Using structured selection♦ 
Commenting and uncommenting lines of code♦ 
Shifting lines of code left and right♦ 
Using Surround with try/catch♦ 


• 


Externalizing Strings
Finding strings to externalize♦ 
Finding unused and incorrectly used keys in property files♦ 
Using the Externalize Strings wizard


Key/value page◊ 
Property file page◊ 


♦ 


• 


Navigating the JDT workbench
Opening an editor for a selected element♦ 
Showing an element in the Package Explorer view♦ 
Opening a type in the Package Explorer view♦ 
Opening an editor on a type♦ 


• 
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Opening a package♦ 
Refactoring


Refactoring steps
Refactoring without preview◊ 
Refactoring with preview◊ 
Previewing refactoring changes◊ 


♦ 


Copying and moving Java elements♦ 
Extracting a method


Parameters page◊ 
Problems page◊ 


♦ 


Renaming a package
Parameters page◊ 


♦ 


Renaming a compilation unit
Parameters page◊ 


♦ 


Renaming a class or interface
Parameters page◊ 


♦ 


Renaming a method
Parameters page◊ 


♦ 


Renaming a field
Parameters page◊ 


♦ 


Renaming a local variable
Parameters page◊ 


♦ 


Renaming method parameters
Parameters page◊ 


♦ 


Changing method signature
Parameters page◊ 


♦ 


Extracting a local variable
Parameters page◊ 


♦ 


Extracting a constant♦ 
Inlining a local variable♦ 
Inlining a method♦ 
Inlining a constant♦ 
Self encapsulating a field


Parameters page◊ 
♦ 


Replacing a local variable with a query♦ 
Pulling members up to superclass


Parameters page◊ 
♦ 


Pushing members down to subclasses♦ 
Moving static members between types


Parameters page◊ 
♦ 


Moving an instance method to a component♦ 
Converting a local variable to a field♦ 
Converting an anonynous inner class to a nested class♦ 
Converting a nested type to a top level type♦ 
Extracting an interface from a type♦ 
Replacing references to a type with references to one of its subtypes♦ 
Undoing a refactoring operation♦ 
Redoing a refactoring operation♦ 


• 


Searching
Conducting a Java search using the search dialog♦ 
Conducting a Java search using pop−up menus♦ 


• 
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Building
Building a Java program


Viewing compilation errors and warnings◊ 
Building automatically◊ 
Building manually◊ 
Building circular projects◊ 
Building without cleaning output location◊ 


♦ 


Working with build paths
Viewing and editing a project's build path◊ 
Adding a library folder to the build path◊ 
Adding a JAR file to the build path◊ 
Adding a classpath variable to the build path◊ 
Attaching source to a JAR file◊ 
Attaching source to a library folder◊ 
Attaching source to a classpath variable◊ 
Defining a class path variable◊ 
Deleting a class path variable◊ 


♦ 


Working with JREs
Assigning the default JRE for the workbench◊ 
Adding a new JRE definition◊ 
Overriding the default system libraries for a JRE definition◊ 
Editing a JRE definition◊ 
Choosing a JRE for launching a project◊ 
Deleting a JRE definition◊ 


♦ 


• 


Running and debugging
Launching a Java program♦ 
Launching a Java applet♦ 
Creating a Java application launch configuration♦ 
Setting execution arguments♦ 
Relaunching a program♦ 
Local debugging


Preparing to debug◊ 
Launching a Java program in debug mode◊ 
Suspending threads◊ 
Resuming the execution of suspended threads◊ 
Stepping through the execution of a program◊ 
Inspecting Values◊ 
Evaluating expressions◊ 


♦ 


Remote debugging
Using the remote Java application launch configuration◊ 
Disconnecting from a VM◊ 


♦ 


Breakpoints
Adding breakpoints◊ 
Removing breakpoints◊ 
Enabling and disabling breakpoints◊ 
Setting method breakpoints◊ 
Applying hit counts◊ 
Managing conditional breakpoints◊ 
Catching Java exceptions◊ 


♦ 


• 


Using the scrapbook
Creating a Java scrapbook page♦ 


• 
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Inspecting the result of evaluating an expression♦ 
Displaying the result of evaluating an expression♦ 
Running an expression♦ 
Using code assist♦ 
Scrapbook error reporting


Viewing compilation errors◊ 
Viewing runtime exceptions◊ 


♦ 
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Parameters page


Extract Method Parameters Page


In the Method name field, type a name for the new method that will be extracted.• 
In the Access Modifier list, specify the method's visibility (public, default, protected, or private).• 
You can Add thrown runtime exceptions to method signature by selecting the corresponding
checkbox.


• 


You can rearrange and rename the parameters for the new method.• 
Click OK to perform a quick refactoring, or click Preview to perform a controlled refactoring.• 


Related Topics:


See Refactoring without Preview• 
See Refactoring with Preview• 
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Problems page
The three top−most mistakes when extracting a method are:


The selection does not cover statements or an expression from a method body.• 
The selection does not cover a whole set of statements or an expression.• 


You can use the Edit > Expand Selection To actions to expand an selection to a valid expression or set of
statements.


On the problems pages, you can press F1 to link to a detailed description of errors.
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Parameters page


Rename Package Parameters Page


In the Enter new name field, type a new name for the package.• 
If you do not want to update references to the renamed package, deselect the Update references to the
renamed element checkbox.


• 


If you want to update Javadoc references to the renamed package, select the Update references in
Javadoc comments checkbox.


• 


If you want to update references in regular (not Javadoc) comments, select the Update references in
regular comments checkbox.


• 


If you want to update references in string literals, select the Update references in string literals
checkbox.


• 


Click OK to perform a quick refactoring, or click Preview to perform a controlled refactoring.• 


Note: References in Javadoc comments, regular comments and string literals are updated based on textual
matching. It is recommended that you perform a controlled refactoring and review the suggested changes if
you select one of these options.


See Refactoring without Preview
See Refactoring with Preview
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Parameters page


Rename Compilation Unit Parameters Page


In the Enter new name field, type a new name for the compilation unit.• 
If you do not want to update references to the renamed compilation unit, deselect the Update
references to the renamed element checkbox.


• 


If you want to update Javadoc references to the renamed compilation unit, select the Update
references in Javadoc comments checkbox.


• 


If you want to update references in regular (not Javadoc) comments, select the Update references in
regular comments checkbox.


• 


If you want to update references in string literals, select the Update references in string literals
checkbox.


• 


Click OK to perform a quick refactoring, or click Preview to perform a controlled refactoring.• 


Note: References in Javadoc comments, regular comments and string literals are updated based on textual
matching. It is recommended that you perform a controlled refactoring and review the suggested changes if
you select one of these options.


See Refactoring without Preview
See Refactoring with Preview
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Parameters page


Rename Type Parameters Page


In the Enter new name field, type a new name for the class or interface.• 
If you do not want to update references to the renamed class or interface, deselect the Update
references to the renamed element checkbox.


• 


If you want to update Javadoc references to the renamed class or interface, select the Update
references in Javadoc comments checkbox.


• 


If you want to update references in regular (not Javadoc) comments, select the Update references in
regular comments checkbox.


• 


If you want to update references in string literals, select the Update references in string literals
checkbox.


• 


Click OK to perform a quick refactoring, or click Preview to perform a controlled refactoring.• 


Note: References in Javadoc comments, regular comments and string literals are updated based on textual
matching. It is recommended that you perform a controlled refactoring and review the suggested changes if
you select one of these options.


Refactoring without Preview
Refactoring with Preview
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Parameters page


Parameters Page for the Rename Method Refactoring Command


In the Enter new name field, type a new name for the method.• 
If you do not want to update references to the renamed method, deselect the Update references to the
renamed element checkbox.


• 


Click OK to perform a quick refactoring, or click Preview to perform a controlled refactoring.• 


See Refactoring without Preview
See Refactoring with Preview
See Showing a Type's Compilation Unit in the Packages View
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Parameters page


Parameters Page for the Rename Field Refactoring Command


In the Enter new name text field, type a new name for the field that you're renaming.• 
If you do not want to update references to the renamed field, deselect the Update references to the
renamed element checkbox.


• 


If you want to update Javadoc references to the renamed field, select the Update references in
Javadoc comments checkbox.


• 


If you want to update references in regular (not Javadoc) comments, select the Update references in
regular comments checkbox.


• 


If you want to update references in string literals, select the Update references in string literals
checkbox.


• 


If the refactoring finds accessor (getter/setter) methods to the field you're renaming, it offers you to
rename them as well (and update all references to them):


If you want to rename the getter, select the Rename Getter checkbox♦ 
If you want to rename the setter, select the Rename Setter checkbox♦ 


• 


Click OK to perform a quick refactoring, or click Preview to perform a controlled refactoring.• 


Note: The refactoring detects getters / setters using preferences set on Window > Preferences > Java > Code
Generation preference page.
Note: References in Javadoc comments, regular comments and string literals are updated based on textual
matching. It is recommended that you perform a controlled refactoring and review the suggested changes if
you select one of these options.


Related Topics:


See Refactoring without Preview• 
See Refactoring with Preview• 
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Parameters page


Parameters Page for the Change Method Signature Refactoring Command


Click in the Name column on the row containing the parameter you want to change or select the row
and press Edit and type a new name for the parameter.


• 


See Refactoring without Preview
See Refactoring with Preview
See Showing a Type's Compilation Unit in the Packages View
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Parameters Page for the Change Method Signature Refactoring Command


Select one or more parameters and use the Up and Down buttons to reorder the parameters (you can
see a signature preview below the parameter list)


• 


Use the Add button to add a parameter; you can then edit its type, name and default value in the table• 
Press Preview to see the preview or OK to perform the refactoring without seeing the preview• 


This refactoring changes the signature of the selected method and all methods that override it.
Also, all references will be updated to use the signature.


Related Topics:


See Refactoring without Preview• 
See Refactoring with Preview• 
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Parameters Page for the Extracting Local Variable Refactoring Command


In the Variable name field, enter a name for the extracted variable• 
Optionally, clear the Replace all occurrences of the selected expression with references to the local
variable checkbox if you want to replace only the expression you selected when invoking the
refactoring.


• 


Optionally, select Define the local variable as 'final'• 
Press Preview to see the preview of the changes or OK to perform the refactoring without preview• 


Related Topics:


See Refactoring without Preview• 
See Refactoring with Preview• 
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Parameters Page for the Self Encapsulate Field Refactoring Command


In the Getter name field, enter the name for the getter.• 
In the Setter name field, enter the name for the setter.• 
Use the Insert new method after combo−box to indicate the location for the getter and/or setter
methods.


• 


Select one radio button from the Access modifier group to specify the new method's visibility.• 
In the class in which the field is declared, read and write accesses can be direct or you can use getter
and setter.


Select the use getter and setter radio button if you want the refactoring to convert all these
accesses to use getter and setter.


♦ 


Select the keep field reference radio button if you do not want the refactoring to modify the
current field accesses in the class in which the field is declared.


♦ 


• 


Press Preview to perform refactoring with preview or press OK to perform refactoring without
preview.


• 


Related Topics:


See Refactoring without Preview• 
See Refactoring with Preview• 
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Parameters Page for the Pulling members up to superclass Refactoring Command


Select the destination class• 
In the list, select the members that you want to pull up or declare abstract• 
Press the Edit button to specify the action that you want to perform for the selected members (you can
also edit the table cells in−place.)


• 


Press Next to see the next page or press Finish to perform the refactoring• 
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In the left pane, select the methods that you want to be deleted after pull up (so that the superclass
implementation can be used instead).
Note: the methods originally selected when invoking the refactoring are pre−selected in the left pane


• 


Press Next to see the preview or press Finish to perform the refactoring• 


Related Topics:


See Refactoring without Preview• 
See Refactoring with Preview• 
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Parameters Page for the Moving static members between types Refactoring Command


Use the text field to enter the destination type name or press the Browse button to see a list of types.• 
Press Preview to see a preview or press OK to perform the refactoring without preview.• 


Related Topics:


See Refactoring without Preview• 
See Refactoring with Preview• 
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Building circular projects
To enable building circular projects:


Select the Window > Preferences > Java > Compiler > Build Path page.
Then set the option Circular dependencies to Warning.


To disable building circular projects:


Select the Window > Preferences > Java > Compiler > Build Path page.
Then set the option Circular dependencies to Error.


To enable building a single project involved in a cycle:


Select the project, and from its pop−up menu, select Properties.
In the Properties dialog, select the Java Compiler > Build Path page.
Then set the option Circular dependencies to Warning.


To disable building a single project involved in a cycle:


Select the project, and from its pop−up menu, select Properties.
In the Properties dialog, select the Java Compiler > Build Path page.
Then set the option Circular dependencies to Error.


Java builder
Build class path


Building a Java program
Building manually
Viewing compilation errors and warnings
Working with build paths
Adding a JAR file to the build path
Adding a library folder to the build path
Viewing and editing a project's build path


Java Build path
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Building without cleaning the output location
To build projects without cleaning the output location:


Select the Window > Preferences > Java > Compiler > Build Path page.
Then set the Scrub output folders on full build check box.


To build projects after cleaning the output location:


Select the Window > Preferences > Java > Compiler > Build Path page.
Then clear the Scrub output folders on full build check box.


To build a single project without cleaning the output location:


Select the project, and from its pop−up menu, select Properties.
In the Properties dialog, select the Java Compiler > Build Path page.
Then set the Scrub output folders on full build check box.


To build a single project after cleaning the output location:


Select the project, and from its pop−up menu, select Properties.
In the Properties dialog, select the Java Compiler > Build Path page.
Then clear the Scrub output folders on full build check box.


Java builder
Build class path


Building a Java program
Building manually
Viewing compilation errors and warnings
Working with build paths
Adding a JAR file to the build path
Adding a library folder to the build path
Viewing and editing a project's build path


Java Build path
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Attaching source to a library folder
You can attach source to a library folder to enable source−level stepping and browsing of classes contained in
a library folder. Unless its source code is attached to a library folder in the workbench, you will not be able to
view the source for the library folder.


To attach source to a library folder:


Select the project, and from its pop−up menu, select Properties.
In the Properties dialog, select the Java Build Path page.


1. 


On the Libraries tab, select the library folder to which you want to attach source.
Expand the node by clicking on the plus and select the node Source Attachment. Click the Edit button
to bring up the source attachment dialog.


2. 


Fill in the Location path field depending on the location, choose between the workspace, an external
file or external folder.


3. 


Click OK.4. 


Java development tools (JDT)


Attaching source to variables
Creating a new JAR file
Stepping through the execution of a program


Java Build Path
Source Attachment dialog
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Launching a Java applet
If your Java program is structured as an applet, you can use the Java Applet launch configuration.  This
launch configuration uses information derived from the workbench preferences and your program's Java
project to launch the program.


In the Package Explorer, select the Java compilation unit or class file you want to launch.1. 
From the pop−up menu, select Run > Java Applet. Alternatively, select Run > Run As > Java Applet
in the workbench menu bar, or select Run As > Java Applet in the drop−down menu on the Run tool
bar button. 


2. 


Your program is now launched.3. 


You can also launch a Java applet by selecting a project instead of the compilation unit or class file.  You will
be prompted to select a class from those classes that extend Applet.  (If only one applet class is found in the
project, that class is launched as if you selected it.)


Debugger


Re−launching a program
Running and debugging
Stepping through the execution of a program


Debug view
Package Explorer
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Launching a Java program in debug mode
Launching a program in debug mode allows you to suspend and resume the program, inspect variables, and
evaluate expressions using the debugger.


To launch a Java program in debug mode,


In the Package Explorer, select the Java compilation unit or class file you want to launch.1. 
Select Run > Debug As > Java Application. 
or Select Debug As > Java Application in the drop−down menu on the Debug tool bar button. 


2. 


Your program is now launched and the launched process appears in the Debug view. 3. 


If you want your program to stop in the main method so that you can step through its complete execution,
create a Java Application launch configuration and check the Stop in main checkbox on the Main tab. 


You can also debug a Java program by selecting a project instead of the compilation unit or class file.  You
will be prompted to select a class from those classes that define a main method.  (If only one class with a main
method is found in the project, that class is launched as if you selected it.)


Java views
Java editor
Debugger


Connecting to a remote VM with the Java Remote Application launcher
Re−launching a program
Running and debugging
Setting execution arguments
Stepping through the execution of a program


Debug view
Package Explorer
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Inspecting values
When stack frame is selected, you can see the visible variables in that stack frame in the Variables view.


The Variables view shows the value of primitive types.  Complex variables can be examined by expanding
them to show their members.
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Using code assist
The scrapbook editor supports code assist similarly to the regular Java editor.


For example, type TestCase in the scrapbook editor and press Ctrl+Space. Code assist prompts you with
possible completions.


Java Content Assist
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Scrapbook error reporting
Java scrapbook errors are reported in the scrapbook page editor.


Viewing compilation errors
Viewing runtime exceptions
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Viewing compilation errors
If you try to evaluate an expression containing a compilation error, it will be reported in the scrapbook editor.


For example, type and select the (invalid) expression System.println("hi") in the editor and click
Execute in the toolbar.


The error message The method println(java.lang.String) is undefined for the type java.lang.System appears in
the editor at the point of the error.
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Reference
Java Development Toolkit (JDT) Basics


JDT Actions
File Actions◊ 
Edit Actions◊ 
Source Actions◊ 
Refactor Actions◊ 
Navigate Actions◊ 
Search Actions◊ 
Project Actions◊ 
Run Actions◊ 
Java Toolbar Actions◊ 
Java editor◊ 
Run and Debug Actions◊ 


♦ 
• 


Views and editors
Java Editor


Java Content Assist◊ 
Quick fix◊ 


♦ 


Java Scrapbook Page♦ 
Breakpoints View


Go to File for Breakpoint◊ 
Add Java Exception Breakpoint◊ 
Suspend Policy◊ 
Hit Count◊ 
Uncaught◊ 
Caught◊ 
Modification◊ 
Access◊ 
Exit◊ 
Entry◊ 
Select All◊ 
Enable◊ 
Disable◊ 
Remove Selected Breakpoints◊ 
Remove All Breakpoints◊ 
Show Qualified Names in Breakpoints View◊ 
Show Supported Breakpoints◊ 
Breakpoint Properties◊ 


♦ 


Console View
Copy◊ 
Select All◊ 
Find/Replace◊ 
Go To Line◊ 
Clear the Console◊ 
Terminate◊ 


♦ 


Debug View♦ 
Display View


Evaluating Expressions◊ 
Inspect◊ 


♦ 


• 
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Display◊ 
Clear◊ 


Expressions View
Select All in the Expressions View◊ 
Copy Variables in the Expressions View◊ 
Remove Selected Expressions◊ 
Remove All Expressions◊ 
Change Variable Values in the Expressions View◊ 
Show Constants in the Expressions View◊ 
Show Static Fields in the Expressions View◊ 
Show Qualified Names in the Expressions View◊ 
Show Type Names in the Expressions View◊ 
Show Detail Pane for the Expressions View◊ 
Add/Remove Watchpoint◊ 
Inspect◊ 
Open Declared Type◊ 
Show Type Names◊ 


♦ 


Variables View
Inspecting Values◊ 
Show Qualified Names in Variables View◊ 
Show Type Names in Variables View◊ 
Show Detail Pane in Variables View◊ 
Add/Remove Watchpoint◊ 
Show Static Fields in Variables View◊ 
Show Constants in Variables View◊ 
Change Variable Values in the Variables View◊ 
Inspect in the Variables View◊ 


♦ 


Type Hierarchy view♦ 
Package Explorer view


Java Element Filters dialog◊ 
♦ 


Java Outline view♦ 
Menus


File Menu♦ 
Edit Menu♦ 
Source Menu♦ 
Refactor Menu♦ 
Navigate Menu♦ 
Search Menu♦ 
Project Menu♦ 
Run Menu


Step Commands◊ 
Run and Debug Actions◊ 


♦ 


• 


Toolbar
Java Toolbar Actions♦ 
Java Editor Toolbar Actions♦ 
Run and Debug Actions♦ 


• 


Preferences
Java


Appearance◊ 
Classpath Variables◊ 
Code Formatter◊ 


♦ 
• 
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Code Generation◊ 
Compiler◊ 
Java Editor


Templates⋅ 
◊ 


Installed JREs◊ 
JUnit◊ 
New Project◊ 
Organize Imports◊ 
Refactoring◊ 
Task Tags◊ 


Debug
Console Preferences◊ 


♦ 


Dialogs
Java Element Filters♦ 
Open Type dialog♦ 
Create Getter and Setter♦ 
Override Methods♦ 


• 


Property Pages
Javadoc Location♦ 
Java Build Path♦ 
Java Compiler♦ 
Java Task Tags♦ 
Source Attachment♦ 


• 


Wizards
Externalize Strings wizard♦ 
JAR file exporter♦ 
Javadoc generation♦ 


• 


New Wizards
New Java Project Wizard


Java Settings Page◊ 
Attaching Source to JAR Files and Variables◊ 


♦ 


New Java Package Wizard♦ 
New Java Class Wizard♦ 
New Java Interface Wizard♦ 
New Source Folder Wizard♦ 
New Java Scrapbook Page Wizard♦ 


• 


Search
Java Search Tab♦ 
Java Search Actions♦ 


• 


Refactoring
Refactor Actions♦ 
Refactor Wizard♦ 
Refactor Preferences♦ 
Extract Method Errors♦ 


• 


Frequently−Asked Questions: JDT• 
Icons• 
Glossary• 


 Basic tutorial


Reference 483







Go to file for breakpoint
If the resource containing the selected breakpoint is not open and/or active, this command causes the file to be
opened and made active, focusing on the line with which the breakpoint is associated.


Breakpoints


Adding breakpoints
Removing breakpoints
Launching a Java program
Running and debugging
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Add Java exception breakpoint
This command allows you to add a Java exception breakpoint. In the resulting dialog:


In the Choose an Exception field, type a string that is contained in the name of the exception you
want to add. You can use wildcards as needed ("* " for any string and "? " for any character).


• 


In the exceptions list, select the exception you want to add.• 
Check or clear the Caught and Uncaught check boxes as needed to indicate on which exception type
you want to suspend the program.


• 


Breakpoints


Catching Java exceptions
Adding breakpoints
Removing breakpoints
Launching a Java program
Running and debugging
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Suspend policy
This action toggles the suspend policy of a breakpoint between suspending all of the threads in the VM and
the thread in which the breakpoint occurred.


Breakpoints


Adding breakpoints
Removing breakpoints
Launching a Java program
Running and debugging
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Hit count
This option sets the hit count for the selected breakpoint. The hit count keeps track of the number of times that
the breakpoint is hit. When the breakpoint is hit for the nth time, the thread that hit the breakpoint suspends.
The breakpoint is disabled until either it is re−enabled or its hit count is changed.


Breakpoints


Adding breakpoints
Removing breakpoints
Launching a Java program
Running and debugging
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Uncaught
When this option is turned on, execution stops when the exception is thrown and is not caught in the program.


Breakpoints


Catching exceptions
Adding breakpoints
Removing breakpoints
Launching a Java program
Running and debugging


Add Java exception breakpoint


 Uncaught 488







Caught
When this option is turned on, execution stops when the exception is thrown and is caught in the program.


Breakpoints


Catching exceptions
Adding breakpoints
Removing breakpoints
Launching a Java program
Running and debugging


Add Java exception breakpoint
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Modification
When this option is turned on, the watchpoint causes execution to suspend on modification of a field.


Breakpoints


Adding breakpoints
Removing breakpoints
Launching a Java program
Running and debugging
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Access
When this option is turned on, the watchpoint causes execution to suspend on access of a field.


Breakpoints


Adding breakpoints
Removing breakpoints
Launching a Java program
Running and debugging
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Exit
When this option is turned on, the breakpoint causes execution to suspend on exit of the method.


Setting method breakpoints
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Entry
When this option is turned on, the breakpoint causes execution to suspend on entry of the method.


Setting method breakpoints
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Select all
This command selects all breakpoints in the Breakpoints view
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Enable
This command enables the selected breakpoints.
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Disable
This command disables the selected breakpoints. A disabled breakpoint does not cause the execution of a
program to be suspended.
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Remove selected breakpoint
This command removes the selected breakpoint(s).
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Remove all breakpoints
This command removes all breakpoints in the workbench.
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Show qualified names
This option can be toggled to show or hide qualified names.
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Show supported breakpoints
When this action is toggled on, the breakpoints view only displays breakpoints applicable to the selected
debug target.
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Properties
This action realizes a breakpoint properties dialog for the currently selected breakpoint


Adding breakpoints
Applying hit counts
Catching Java exceptions
Removing breakpoints
Enabling and disabling breakpoints
Managing conditional breakpoints
Setting method breakpoints
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Copy
This command copies all selected text from the Console view onto the clipboard.
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Select all
This command selects all text in the current pane of the Console view.
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Find/Replace
This command allows you to search for an expression and replace it with another expression.
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Go to line
This command allows you to go to the specified line in the console. The line is specified in the resulting
dialog.
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Clear
This command clears all content in the Console view.
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Terminate
This command terminates the process that is currently associated with the console
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Inspect
You can type an expression in the Display view and then use the Inspect command to evaluate the expression
and inspect the result in the Expressions view.
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Display
You can type an expression in the Display view and then use the Display command to display its value.
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Clear the display
This command clears the display view.
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Select all
This command selects all expressions in the Expressions view
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Copy
This command copies a text representation of all selected expressions and variables onto the clipboard.
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Remove selected expressions
This command removes the selected expressions from the Expressions view.
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Remove all expressions
This command removes all expressions from the Expressions view.
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Change variable value
This command allows you to change the value of the selected variable.
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Show constants
This option can be toggled to show or hide constants (static final fields).
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Show static fields
This option can be toggled to show or hide static fields.
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Show qualified names
This option can be toggled to show or hide qualified names.
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Show type names
This option can be toggled to show or hide type names.
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Add/Remove watchpoint
This command allows you to add or remove a field watchpoint for the current selected variable in the
Expressions view.
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Inspect
This command causes the selected variables to be inspected.


 Inspect 521







Open declared type
This command allows you open an editor on the declared type of the currently selected variable in the
Expressions view


 Open declared type 522







Show qualified names
This option can be toggled to show or hide qualified names.
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Show type names
This option can be toggled to show or hide type names.
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Add/Remove watchpoint
This command allows you to add or remove a field watchpoint for the current selected variable in the
Variables view.
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Change variable value
This command allows you to change the value of the selected variable.
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Inspect
This command causes the selected variable(s) to be inspected.
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Step commands
Many of the commands in this menu allow you to step through code being debugged. See Debug View
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JUnit


Option Description Default


Show the JUnit results view only
when an error or failure occurs


If enabled, the JUnit view is only brought to the
front when an error or failure occurs.


On


Stack trace filter patterns Packages, classes, or patterns that should not be
shown in the stack trace of a test failure.


default filter
patterns


Using JUnit
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Task Tags
On this preference page, the task tags can be configured. When the tag list is not empty, the compiler will
issue a task marker whenever it encounters one of the corresponding tag inside any comment in Java source
code. Generated task messages will include the tag, and range until the next line separator or comment ending.


Command Description


New... Adds a new task tag. In the resulting dialog, specify a name and priority for the new task tag. 


Remove Removes the selected task tag. 


Edit... Allows you to edit the selected task tag. In the resulting dialog, edit the name and/or priority
for the task tag. 


There is a default task tag named TODO with a Normal priority.
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Open type
This command allows you to browse the workbench for a type to open in an editor or type hierarchy


Choose a type: In this field, type the first few characters of the type you want to open in an editor.
You can use wildcards as needed ("*" for a string, "?" for a character, "<" of end of line).


• 


Matching types: This list displays matches for the expression you type in the Choose a type field.• 
Qualifier: This list displays the packages or declaring types that contain the selected matching type.• 


Opening an editor on a type


Navigate actions
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Java Task Tags page
The options in this page indicate the task tags for a Java project.
You can reach this page through


the Java task tags property page (File > Properties > Java Task Tags) from the context menu on a
created project or the File menu


• 


A project can either reuse workspace default settings or use its own custom settings.


Option Description


Use workspace
settings


Default mode indicating that the project is using the global workspace settings.
When selected, it allows to open the page for configuring the workspace task tags
preferences.


Use project settings Once selected, task tags can be configured for this project as in task tags
preferences. At any time, it is possible to revert to workspace defaults, by using
the button Restore Defaults.


Global task tags preferences
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Refactoring
The goal of refactoring support is to allow for improving your code without changing its behaviors. When you
refactor your code, your goal is to make a system−wide coding change without affecting the semantic
behavior of the system. The JDT automatically manages refactorings for you.


The workbench optionally allows you to preview all the impending results of a refactoring action before you
finally choose to carry it out.


Refactoring commands are available from the context menus in many views and editors and the Refactor
menu in the menu bar.


Refactoring support


Refactoring actions
Refactoring wizard
Refactoring preference page


Tips and Tricks


Editing source


Content assist Content assist provides you with a list of suggested completions for partially
entered strings. In the Java editor press Ctrl+Space or invoke Edit > Content
Assist.
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Content assist
in Javadoc
comments


Content assist is also available in Javadoc comments.


Suppress types
in code assist


To exclude certain types from appearing in content assist, use the type filter feature
configured on the Java > Type Filters preference page. Types matching one of
these filter patterns will not appear in the Open Type dialog and will not be
available to code assist, quick fix and organize imports. These filter patterns do not
affect the Package Explorer and Type Hierarchy views.


Content assist
for variable,


method
parameter and


field name
completions


You can use content assist to speed up the creation of fields, method parameters
and local variables. With the cursor positioned after the type name of the
declaration, invoke Edit > Content Assist or press Ctrl+Space.


If you use a name prefix or suffix for fields, local variables or method parameters,
be sure to specify this in the Code Style preference page (Window > Preferences
> Java > Code Style).
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Parameter
Hints


With the cursor in a method argument, you can see a list of parameter hints. In the
Java Editor press Ctrl+Shift+Space or invoke Edit > Parameter Hints.


Content assist
on anonymous


classes


Content assist also provides help when creating an anonymous class. With the
cursor positioned after the opening bracket of a class instance creation, invoke Edit
> Content Assist or press Ctrl+Space.


This will create the body of the anonymous inner class including all methods that
need to be implemented.


Toggle between
inserting and


replacing code
assist


When code assist is invoked on an existing identifier, code assist can either replace
the identifier with the chosen completion or do an insert. The default behavior
(overwrite or insert) is defined in Window > Preferences > Java > Editor > Code
Assist.
You can temporarily toggle the behavior while inside the content assist selection
dialog by pressing and holding the Ctrl key while selecting the completion.


Incremental
content assist


Check Insert common prefixes automatically on the Java > Editor > Syntax
preference tab to use shell−style incremental completion in the Java editor. If the
available completions do not have a common prefix, the proposal popup is
displayed.


Create Getter
and Setters


dialog


To create getter and setter methods for a field, select the field's declaration and
invoke Source > Generate Getter and Setter.


If you use a name prefix or suffix be sure to specify this in the Code Style
preference page (Window > Preferences > Java > Code Style)
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Use content
assist to create


Getter and
Setters


Another way to create getters and setters is using content assist. Set the cursor in
the type body between members and press Ctrl+Space to get the proposals that
create a getter or setter method stub.


Delete Getters
and Setters


together with a
field


When you delete a field from within a view, Eclipse can propose deleting its Getter
and Setter methods. If you use a name prefix or suffix for fields, be sure to specify
this in the Code Style preference page (Window > Preferences > Java > Code
Style).


Create delegate
methods


To create a delegate method for a field select the field's declaration and invoke
Source > Generate Delegate Methods. This adds the selected methods to the type
that contains a forward call to delegated methods. This is an example of a delegate
method:


Use Drag &
Drop for


refactoring


You can move Java compilation units between packages by Drag & Drop − all
missing imports will be added and references updated.


Use Drag &
Drop to move


and copy Java
code elements


You can move and copy Java elements such as methods and fields by Drag &
Drop. This will not trigger refactoring − only the code will be copied or moved.


Use Templates
to create a


method


You can define a new template (Preferences > Java > Editor > Templates) that
contains a method stub. Templates are shown together with the Content Assist
(Ctrl+Space) proposals.
There are also existing templates, such as 'private_method', 'public_method',
'protected_method' and more.
Use the Tab key to navigate between the values to enter (return type, name and
arguments).
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Use Quick Fix
to create a new


method


Start with the method invocation and use Quick Fix (Ctrl+1) to create the method.


Use Quick Fix
to change a


method
signature


Add an argument to a method invocation at a call site. Then use Quick Fix
(Ctrl+1) to add the required parameter in the method declaration.


Use Content
Assist to create


a constructor
stub


At the location where you want to add the new constructor, use code assist after
typing the first letters of the constructor name.


Create new
fields from
parameters


Do you need to create new fields to store the arguments passed in the constructor?
Use quick assist (Ctrl + 1) on a parameter to create the assignment and the field
declation and let Eclipse propose a name according to your Code Style preferences.


Use Content
Assist to


override a
method


Invoke Content Assist (Ctrl+Space) in the type body at the location where the
method should be added. Content assist will offer all methods that can be
overridden. A method body for the chosen method will be created.


Use Quick Fix
to add


unimplemented
methods


To implement a new interface, add the 'implements' declaration first to the type.
Even without saving or building, the Java editor will underline the type to signal
that methods are missing and will show the Quick Fix light bulb. Click on the light
bulb or press Ctrl+1 (Edit > Quick Fix) to choose between adding the
unimplemented methods or making your class abstract.
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Override a
method from a


base class


To create a method that overrides a method from a base class:
Select the type where the methods should be added and invoke Source > Override
/ Implement Methods. This opens a dialog that lets you choose which methods to
override.


Rename in File To quickly do a rename that doesn't require full analysis of dependencies in other
files, use the 'rename in file' Quick Assist. In the Java Editor, position the cursor in
an identifier of a variable, method or type and press Ctrl+1 (Edit > Quick Fix)
The editor is switched to the linked edit mode (like templates) and changing the
identifier simultaneously changes all other references to that variable, method or
type.


Use Quick Fix
to handle


exceptions


Dealing with thrown exceptions is easy. Unhandled exceptions are detected while
typing and marked with a red line in the editor.


Click on the light bulb or press Ctrl+1 to surround the call with a try catch
block. If you want to include more statements in the try block, select the
statements and use Source > Surround With try/catch Block. You can
also select individual statements by using Edit > Expand Selection to and
selecting Enclosing, Next or Previous.


• 


If the call is already surrounded with a try block, Quick Fix will suggest
adding the catch block to the existing block.


• 
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If you don't want to handle the exception, let Quick Fix add a new thrown
exception to the enclosing method declaration


• 


At any time you can convert a catch block to a thrown exception. Use Ctrl+1 (Edit
> Quick Fix) on a catch block.


Less typing for
assignments


Instead of typing an assignment, start with the expression that will be assigned.


Now use Ctrl+1 (Edit > Quick Fix) and choose 'Assign statement to new local
variable' and Quick Assist will guess a variable name for you.


Less work with
cast expressions


Don't spend too much time with typing casts. Ignore them first and use quick assist
to add them after finishing the statement.
For example on assignments:


Or in for method arguments:
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Or for method call targets


Surround lines To surround statements with an if / while / for statement or a block, select the lines
to surround and press Ctrl+1 (Edit > Quick Fix). This lists all templates that
contain the variable ${line_selection}.


Templates can be configured on Window > Preferences > Java > Editor >
Templates. Edit the corresponding templates or define your own templates to
customize the resulting code.


Create your
own templates


To create your own templates, go to the Java > Editor > Templates preference
page and press the New button to create a template. For example, a template to
iterate backwards in an array would look like this:


for (int ${index} = ${array}.length − 1; ${index} >= 0; ${index}−−){
   ${cursor}
}


Code assist can
insert argument


names
automatically


You can have code assist insert argument names automatically on method
completion. This behavior can be customized on the Java > Editor > Code Assist
preference page (see the Fill argument names on method completion checkbox.)
For example, when you select the second entry here,


code assist will automatically insert argument names:
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you can then use the Tab key to navigate between the inserted names.


Code assist can also guess argument names − based on their declared types. This
can be configured by the Guess filled argument names checkbox on the Java >
Editor > Code Assist preference page.


Remove
surrounding


statement


To remove a surrounding statement or block, position the cursor at the opening
bracket and press Ctrl+1 (Edit > Quick Fix).


How was that
word spelled


again?


You can enable spell−checking support in the Java editor on the Java > Editor >
Spelling preference page. Spelling errors are displayed in the Java editor and
corresponding Quick Fixes are available:


You can make the dictionary also available to the content assist. However, there is
currently no dictionary included in Eclipse. The required format is just a list of
words separated by newlines and the Quick Fixes allow you to add new words to
the dictionary on−the−fly. Contributions of dictionaries would be welcome.


Structured
selections


You can quickly select Java code syntactically using the Structured Selection
feature.
Highlight the text and press Alt+Shift+Arrow Up or select Edit > Expands
Selection To > Enclosing Element from the menu bar − the selection will be
expanded to the smallest Java−syntax element that contains the selection. You can
then further expand the selection by invoking the action again.


Find the
matching


bracket


To find a matching bracket select an opening or closing bracket and press
Ctrl+Shift+P (Navigate > Go To > Matching Bracket). You can also double
click before an opening or after a closing bracket − this selects the text between the
two brackets.
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Smart Javadoc Type '/**' and press Enter. This automatically adds a Javadoc comment stub
containing the standard @param, @return and @exception tags.


The templates for the new comment can be configured in Window > Preferences
> Java > Code Style > Code Templates


Use the local
history to revert


back to a
previous edition


of a method


Whenever you edit a file, its previous contents are kept in the local history. Java
tooling makes the local history available for Java elements, so you can revert back
to a previous edition of a single method instead of the full file.


Select an element and use Replace With > Local History to revert back to a
previous edition of the element.
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Use the local
history to


restore removed
methods


Whenever you edit a file, its previous contents are kept in the local history. Java
tooling makes the local history available for Java elements, so you can restore
deleted methods selectively.


Select a container and use Restore from Local History to restore any removed
members.


Customizable
code generation


The Java > Code Style > Code Templates preference page allows you to
customize generated code and comments in a similar way to normal templates.
These code templates are used whenever code is generated. (These new templates
replace the 'filecomment' and 'typecomment' templates previously used for code
generation in R2.1.)


The check box 'Automatically add comments...' allows you to decide if features
that create new methods or types add comments automatically or if they are added
explicitly with 'Add Javadoc Comment'.


Sort members
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You can Sort Members of a Java compilation unit according to a category order
defined in the Java > Appearance > Members Sort Order preference page.
You'll find the action under Source > Sort Members


Wrap Strings You can have String literals wrapped when you edit them. For example, if you
have code like this:


String message= "This is a very long message.";


position your caret after the word "very" and press Enter. The code will be
automatically changed to:


String message= "This is a very" + 
           " long message.";


This behavior can be customized in the Java > Editor > Typing preference page.


Smart Typing
and how to


control it


The Java editor's Smart Typing features ease your daily work. You can configure
them on the Typing tab of the Java > Editor preference page.


Note that the Smart semicolon positioning and Smart brace positioning are
disabled by default. When Close brackets and parenthesis is enabled, you usually
have to press an additional key to position the cursor behind the automatically
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inserted bracket or parenthesis before entering an opening brace or semicolon.
Smart semicolon positioning and Smart brace positioning automatically
position the semicolon or brace behind the inserted bracket or parenthesis. You can
undo this automatic positioning by pressing backspace right afterwards.


Fix your code
indentation


with one key
stroke


A useful feature is Source > Correct Indentation. Select the code where the
indents are incorrect and invoke the action.


Quick menus
for source and


refactoring
actions


The refactoring and source actions can be accessed via a quick menu. Select the
element to be manipulated in the Java editor or in a Java view and press
Alt+Shift+S for the quick source menu or Alt+Shift+T for the quick refactor
menu.


Find unused
code


The Java compiler detects unreachable code, unused variables, parameters, imports
and unused private types, methods and fields. The setting is on the Java >
Compiler preference page.
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These settings are also detected as you type and a quick fix is offered to remove the
unneeded code.


Javadoc
comment
handling


The Eclipse Java compiler can process Javadoc comments. Search reports
references in doc comments, and refactoring updates these references as well. This
feature is controlled from the Java > Compiler > Javadoc preference tab (or set
for an individual project using Project > Properties > Java Compiler >
Javadoc).
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When turned on, malformed Javadoc comments are marked in the Java editor and
can be fixed using Edit > Quick Fix (Ctrl+1):


Searching


Locate
variables and


their
read/write


access


You can locate variables and see their read/write status by selecting an
identifier (variable, method or type reference or declaration) and invoking
Search > Occurrences in File. This marks all references of this identifier
in the same file. The results are also shown in the search view, along with
icons showing the variable's read or write access.


Alternatively, use the new Mark Occurrences feature to dynamically
highlight occurrences. You can search over several files by using the
general search features (Search > References).


Search for
methods with


a specific
return type


To search for methods with a specific return type, use "* <return type>"
as follows:


Open the search dialog and click on the Java Search tab.• 
Type '*' and the return type, separated by a space, in the Search
string.


• 


Select the Case sensitive checkbox.• 
Select Method and Declarations and then click Search.• 
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Remove
Javadoc


results from
Java search


By default Java Search finds references inside Java code and Javadoc. If
you don't want to find references inside Javadoc, you can disable this
behavior by unchecking Process Javadoc comments of Java >
Compiler > Javadoc preference page.


Trace method
call chains


with the Call
Hierarchy


Have you ever found yourself searching for references to methods again
and again? Use the new Call Hierarchy to follow long or complex call
chains without losing the original context: Just select a method and invoke
Navigate > Open Call Hierarchy (Ctrl+Alt+H).


Code navigation and reading


Open on a
selection in the


Java editor


There are two ways that you can open an element from its reference in the
Java editor.


Select the reference in the code and press F3 (Navigate > Open
Declaration)


• 


Hold Ctrl and move the mouse pointer over the reference• 
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The hyperlink style navigation can be configured in Preferences > Java
> Editor > Navigation.


In−place
outlines


Press Ctrl+F3 in the Java editor to pop up an in−place outline of the
element at the current cursor position. Or press Ctrl+O (Navigate >
Quick Outline) to pop up an in−place outline of the current source file.


In−place
outlines show


inherited
members


Press Ctrl+O or Ctrl+F3 again to add inherited members to an open
In−place outline. Inherited members have a gray label. Filter and sort the
outline with the menu in the upper right corner.


In−place hierarchy
Find out which are the possible receivers of a virtual call using the 'quick hierarchy'. Place the cursor


inside the method call and press Ctrl+T (Navigate > Quick Hierarchy). The view shows all types that
implement the method with a full icon.
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Press Ctrl+T again to switch to the Supertype hierarchy.


Advanced highlighting
 The Java editor can highlight source code according to its semantics (for example: static fields, local


variables, static method invocations). When advanced highlighting is enabled via the Java > Editor > Syntax
preference tab, the advanced highlighting options show up in the list.


There are also options for highlighting operators and brackets.


Initially folded regions
 The Default Java Folding allows you to define the initally folded regions on the Folding tab of the


Java > Editor preference page. The options supported are: comments, inner types, methods and imports.
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Mark occurrences
 When working in the editor, turn on Mark Occurrences in the toolbar ( ) or press (Alt+Shift+O).


You'll see within a file, where a variable, method or type is referenced.


Selecting a return type shows you the method's exit points. Select an exception to see where it is thrown.


Fine tune 'mark occurrences' on Preferences > Java > Editor > Mark Occurrences..Go to next / previous
methodTo quickly navigate to the next or previous method or field, use


Ctrl+Shift+Arrow Up (Navigate > Go To > Previous Member) or Ctrl+Shift+Arrow Down (Navigate >
Go To > Next Member)Control your navigation between annotations
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 Use the Next / Previous Annotation toolbar buttons or Navigate > Next Annotation (Ctrl+.) and
Navigate > Previous Annotation (Ctrl+,) to navigate between annotations in a Java source file. With the


button drop−down menus, you can configure on which annotations you want to stop:


Reminders in your Java codeWhen you tag a comment in Java source code with "TODO" the Java compiler
automatically creates a corresponding task as a reminder. Opening the task navigates you back to the "TODO"


in the code. Use the Java > Task Tags preference page to configure any other special tags (like "FIXME")
that you'd like to track in the task list.


Select variables on endings in Open and Go To dialogsOpen and Go To dialogs now support the end
character '<'. To see all types in the Open Type dialog that end with "Test" enter the pattern "*Test<".


If '<' is not included in the pattern, a '*' will be appended to the pattern. If you enter "*Test" in the Open Type
dialog you will see all types containing "Test" somewhere in the type name. Make hovers stickyYou can


open the text from a hover in a scrollable window by pressing F2 (Edit > Show Tooltip Description). You
can select and copy content from this window.
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Hovers in the Java editorYou can see different hovers in the Java editor by using the modifier keys (Shift,
Ctrl, Alt).


When you move the mouse over an identifier in the Java editor, by default a hover with the Javadoc extracted
from the corresponding source of this element is shown. Holding down the Ctrl key shows you the source


code.


You can change this behavior and define the hovers for other modifier keys in Preferences > Java > Editor >
Hovers.Open and configure external Javadoc documentationIf you want to open the Javadoc
documentation for a type, method or field with Shift+F2 (Navigate > Open External Javadoc), you first
have to specify the documentation locations to the elements parent library (JAR, class folder) or project
(source folder).
For libraries open the build path page (Project > Properties > Java Build Path), go to the Libraries, expand
the node of the library where you can edit the 'Javadoc location' node. The documentation can be local on
your file system in a folder or archive or on a web server.


For types, methods or fields in source folders, go to the (Project > Properties > Javadoc Location).


Java views
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Declaration
view


There is a new Declaration view (Window > Show View > Other > Java
> Declaration) which shows the source of the element selected in the Java
editor or in a Java view.


Javadoc view There is a Javadoc view (Window > Show View > Other > Java >
Javadoc) which shows the Javadoc of the element selected in the Java
editor or in a Java view. The Javadoc view uses the SWT Browser widget
to display HTML on platforms which support it.


Type
hierarchy


view supports
grouping by


defining type


The type hierarchy method view lets you sort the selected type's methods
by its defining types. For example, for AbstractList you can see that it
contains methods that were defined in Object, Collection and List:
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Tricks in the
type hierarchy Focus the type hierarchy on a new type by pressing F4 (Navigate >


Open Type Hierarchy) on an element or a selected name.
• 


You can open the Hierarchy view not only on types but also on
packages, source folders, JAR archives and Java projects.


• 


You can Drag & Drop an element onto the Hierarchy view to focus
it on that element.


• 


You can change the orientation (from the default vertical to
horizontal) of the Hierarchy view from the view's toolbar menu.


• 


Find out
where a


method is
implemented


in the
hierarchy


To find out which types in a hierarchy override a method, use the 'Show
Members in Hierarchy' feature.


Select the method to look at and press F4 (Navigate > Open Type
Hierarchy). This opens the type hierarchy view on the method's
declaring type.


• 


With the method selected in the Hierarchy view, press the 'Lock
View and Show Members in Hierarchy' tool bar button.


• 


The hierarchy view now shows only types that implement or define
the 'locked' method. You can for example see that 'isEmpty()' is
defined in 'List' and implemented in 'ArrayList' and 'Vector' but not
in 'AbstractList'.


• 
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Hierarchical
vs. flat layout


of packages


An option on the Java Packages view (and Package Explorer view) allows
you to change the way packages are displayed. Hierarchical displays
packages in a tree, with sub−packages below packages; Flat displays them
in the standard arrangement, as a flat list with all packages and
sub−packages as siblings.


Logical
packages


The Java Packages view (Java Browsing perspective) coalesces packages
of the same name across source folders within a project. This shows the
Packages view containing a logical package.


Compress
package


names


If your package names are very long you can configure a compressed name
that appears in the viewers. Configuration of the compression pattern is
done in Preferences > Java > Appearance
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Using this example, packages are rendered the following way:


Various


JUnit Select a JUnit test method in a view and choose Run > JUnit Test from
the context menu or Run > Run As > JUnit Test from the main menu.
This creates a launch configuration to run the selected test.


Hide JUnit
view until
errors or


failures occur


You can make the JUnit view open only when there are errors or failures.
That way, you can have the view set as a fast view and never look at it
when there are no failing tests. While there are no problems in your tests
you will see this icon  (the number of small green squares will grow,
indicating progress) while running them and this icon  after they are
finished. If, however, errors or failures occur, the icon will change to 
(or  if tests are finished) and the JUnit view will appear. This behavior
can be configured via the Java > JUnit preference page.


Content assist
in dialog fields


Content Assist (Ctrl+Space) is now also available in input fields of various
Java dialogs. Look for small light bulb icon beside the field when it has
focus.
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Content Assist is e.g. implemented in the New Java Class, New Java
Interface, and New JUnit Test wizards, as well as in the refactoring dialogs
for Change Method Signature and moving static members.


The Extract Local Variable, Convert Local Variable to Field, and
Introduce Parameter refactorings offer content assist proposals for the new
element name.


Structural
compare of
Java source


A structural comparison of Java source ignores the textual order of Java
elements like methods and fields and shows more clearly which elements
were changed, added, or removed.
For initiating a structural comparison of Java files you have two options:


Select two Java compilation units and choose Compare With >
Each Other from the view's context menu. If the files have
differences, they are opened into a Compare Editor. The top pane
shows the differing Java elements; double clicking on one of them


• 
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shows the source of the element in the bottom pane.
In any context where a file comparison is involved (e.g. a CVS
Synchronization) a double click on a Java file not only shows the
content of the file in a text compare viewer, but it also performs a
structural compare and opens a new pane showing the results.


• 


You can even ignore comments and formatting changes when performing
the structural compare: turn on the Ignore Whitespace option via the
Compare Editor's toolbar button, or the CVS Synchronization View's drop
down menu.


Structural
compare of


property files


A structural comparison of Java property files (extension: .properties)
ignores the textual order of properties and shows which properties were
changed, added, or removed.
For initiating a structural comparison of property files you have two
options:


Select two files in the Package Explorer or Navigator and choose
Compare With > Each Other from the view's context menu. If
the files have differences, they are opened into a Compare Editor.
The top pane shows the affected properties; double clicking on one
of them shows the source of the property in the bottom pane.


• 


In any context where a file comparison is involved (e.g. a CVS
Synchronization) a double click on a property file not only shows
the content of the file in a text compare viewer, but it also
performs a structural compare and opens a new pane showing the
results.


• 
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Define prefixes
or suffixes for


fields,
parameters


and local
variables


In addition to configuring the prefix or suffix for fields, you can also
specify the prefix or suffix for static fields, parameters, and local variables.
These settings on the Java > Code Style preference page are used in
content assist, quick fix, and refactoring whenever a variable name is
computed.


Organize
Imports works


on more than
single files


You can invoke Organize Imports on sets of compilation units, packages,
source folders or Java projects.


Format more
than one file


Select all Java files to format and choose Source > Format to format them
all. The format action is also available on packages, source folders or Java
projects.


Use project
specific


compiler
settings


Each project can use the global compiler settings or you can define project
specific settings. Select the project and open the Java compiler page in the
project properties (Project > Properties > Java Compiler)
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You can also configure project specific settings for the Java Task tags
(TODO tasks).


Use a specific
JRE for a


project


When creating new projects the JRE that is added by default is the one
selected in Preferences > Java > Installed JRE's. To set a project
specific JRE, open the project's Java Build path property page (Project >
Properties > Java Build Path), then the Libraries page, select 'JRE
System Library' and press Edit. In the 'Edit Library' dialog you can select
either the default JRE or a project specific JRE to add to new projects.


Propagating
deprecation


tag


The Java compiler can be configured to diagnose deprecation using
options on the Java > Compiler > Advanced page.


Using this configuration, the result is:
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If you're unable to fix a usage of a deprecated construct, we recommend
that you tag the enclosing method, field or type as deprecated. This way,
you acknowledge that you did override a deprecated construct, and the
deprecation flag is propagated to further dependents.


Recovering
from abnormal
inconsistencies


In the rare event of a dysfunction, JDT could reveal some inconsistencies
such as:


missing results in a Java Search or Open Type• 
invalid items in package explorer• 


To make it consistent again, the following actions need to be performed in
this exact order:


Close all projects using navigator Close Project menu action1. 
Exit and restart Eclipse2. 
Open all projects using navigator Open Project menu action3. 
Manually trigger a clean build of entire workspace (Project >
Clean...)


4. 


Debugging


Launching
from the


Context Menu


Launching is now available from the context menu of many items. You can
launch from a source file, package, method, type, etc. by choosing Run (or
Debug) > Java Application from the context menu.
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Evaluations in
the debugger


Snippet evaluation is available from a number of places in the debugger.
Choosing Display or Inspect from the context menu of the editor or
Variables view will show the result in a pop−up whose result can be sent to
the Display or Expressions views.


View
Management


in Non−Debug
perspectives


The Debug view automatically manages debug related views based on the
view selection (displaying Java views for Java stack frames and C views for C
stack frames, for example). By default, this automatic view management only
occurs in the Debug perspective, but you can enable it for other perspectives
via the View Management preference page available from the Debug view
toolbar pulldown.


Environment
Variables


You can now specify the environment used to launch Java applications via the
Environment tab.
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String
Substitutions


Variables are now supported for many parameters of Java Application launch
configurations. Most fields that support variables have a Variables... button
next to them. The Main Type field supports variables as well; the
${java_type_name} variable allows you to create a configuration that will run
the selected type.


Logical
Structures


The Logical Structures toggle on the Variables view toolbar presents
alternate structures for common types. JDT provides logical views for Maps,
Collections, and SWT Composites.


Default VM
Arguments


If you specify the same arguments to a certain VM frequently, you can
configure Default VM Arguments in the Installed JREs preference page.
This is more convenient than specifying them for each launch configuration.


Stop in Main You can use Stop in main in a Java Application launch configuration to cause
your program to stop at the first executable line of the main method when you
run it under debug mode.
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Conditional
breakpoints


You can use conditional breakpoints in Breakpoint Properties... to control
when a breakpoint actually halts execution. You can specify whether you want
the breakpoint to suspend execution only when the condition is true, or when
the condition value changes.


Disabling
breakpoints


If you find yourself frequently adding and removing a breakpoint in the same
place, consider disabling the breakpoint when you don't need it and enabling it
when needed again. This can be done using Disable Breakpoint in the
breakpoint context menu or by unchecking the breakpoint in the Breakpoints
view.


You can also temporarily disable all breakpoints using the Skip All
Breakpoints action in the Breakpoints view toolbar. This will tell the
debugger to skip all breakpoints while maintaining their current enabled state.
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Changing
variable values


When a thread is suspended in the debugger, you can change the values of
Java primitives and Strings in the Variables view. From the variable's context
menu, choose Change Variable Value. You can also change the value by
typing a new value into the Details pane and using the Assign Value action in
the context menu (CTRL−S key binding).


Variable
values in hover


help


When a thread is suspended and the cursor is placed over a variable in the Java
editor, the value of that variable is displayed as hover help.


Drop to Frame When stepping through your code, you might occasionally step too far, or step
over a line you meant to step into. Rather than restarting your debug session,
you can use the Drop to Frame action to quickly go back to the beginning of
a method. Select the stack frame corresponding to the Java method you wish
to restart, and select Drop to Frame from Debug view toolbar or the stack
frame's context menu. The current instruction pointer will be reset to the first
executable statement in the method. This works for non−top stack frames as
well.


Note that Drop to frame is only available when debugging with a 1.4 or higher
VM, or the J9 VM. There are some situations where a JVM may be unable to
pop the desired frames from the stack. For example, it is generally impossible
to drop to the bottom frame of the stack or to any frame below a native
method.


Hot code
replace


The debugger supports Hot Code Replace when debugging with a 1.4 or
higher VM, or the J9 VM. This lets you make changes to code you are
currently debugging. Note that some changes such as new or deleted methods,
class variables or inner classes cannot be hot swapped, depending on the
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support provided by a particular VM.


Stepping into
selections


The Java debugger allows you to step into a single method within a series of
chained or nested method calls. Simply highlight the method you wish to step
into and select Step into Selection from the Java editor context menu.


This feature works in places other than the currently executing line. Try
debugging to a breakpoint and stepping into a method a few lines below the
currently instruction pointer.


Controlling
your console


Output displayed in the console can be locked to a specific process via the Pin
Console action in the Console view toolbar. There's also a Scroll Lock action
that stops the console from automatically scrolling as new output is appended.


Creating
watch items


A watch item is an expression in the Expressions view whose value is
updated as you debug. You can create watch items from the Java editor by
selecting an expression or variable and choosing Watch from its context menu
or the top−level Run menu.


Watch points A watch point is a breakpoint that suspends execution whenever a specified
variable is accessed or modified. To set a watchpoint, select a variable in the
Outline view and choose Toggle Watchpoint from its context menu. To
configure a watchpoint, select the watchpoint in the Breakpoints view and
choose Properties... from its context menu. The most important properties for
this type of breakpoint are the Access and Modification checkboxes which
control when the breakpoint can suspend execution.
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Threads and
Monitors view


The debugger's Threads and Monitors view shows which threads are holding
locks and which are waiting to acquire locks.


Step filters Step filters prevent the debugger from suspending in specified classes and
packages when stepping into code. Step filters are established in Window >
Preferences > Java > Debug > Step Filtering. When the Use Step Filters
togggle (on the debug toolbar and menu) is on, step filters are applied to all
step actions. In the Debug view, the selected stack frame's package or
declaring type can be quickly added to the list of filters by selecting Filter
Type or Filter Package from the stack frame's context menu.
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Using the
scrapbook


If you want to experiment with API or test out a new algorithm, it's frequently
easier to use a Java scrapbook page than create a new class. A scrapbook page
is a container for random snippets of code that you can execute at any time
without a context. To create a scrapbook page, create a new file with a .jpage
extension (or use the New wizard − Java > Java Run/Debug > Scrapbook
Page). Enter whatever code you wish to execute, then select it. There are three
ways to execute your code:


Execute the selected code and place the returned result in the
Expressions view


• 


Execute the selected code and place the String result right in the
scrapbook page


• 


Execute the selected code (and ignore any returned result)• 


These actions are in the workbench toolbar and also in the scrapbook page's
context menu.


Editing
launch


configurations


Holding down the Ctrl key and making a selection from the Run or Debug
drop−down menu opens the associated launch configuration for editing. The
launch configuration can also be opened from the context menu associated
with any item in the Debug view.


Favorite
launch


configurations


Launch configurations appear in the Run/Debug drop−down menus in most
recently launched order. However it is possible to force a launch configuration
to always appear at the top of the drop−downs by making the configuration a
'favorite'. Use the Organize Favorites... action from the appropriate drop
down menu to configure your favorite launch configurations.


Detail
formatters


In the Variables & Expressions views, the detail pane shows an expanded
representation of the currently selected variable. By default, this expanded
representation is the result of calling toString() on the selected object, but you
can create a custom detail formatter that will be used instead by choosing New
Detail Formatter from the variable's context menu. This detail formatter will
be used for all objects of the same type. You can view and edit all detail
formatters in the Java > Debug > Detail Formatters preference page.
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Running code
with compile


errors


You can run and debug code that did not compile cleanly. The only difference
between running code with and without compile errors is that if a line of code
with a compile error is executed, one of two things will happen:


If the 'Suspend execution on compilation errors' preference on the
Java > Debug preference page is set and you are debugging, the
debug session will suspend as if a breakpoint had been hit. Note that if
your VM supports Hot Code Replace, you could then fix the
compilation error and resume debugging


• 


Otherwise, execution will terminate with a 'unresolved compilation'
error


• 


It is important to emphasize that as long as your execution path avoids lines of
code with compile errors, you can run and debug just as you normally do.


Word wrap in
Variables view


The details area of the debugger's Variables and Expressions views supports
word wrap, available from the view drop−down menu.
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Code assist in
the debugger


Code assist is available in many contexts beyond writing code in the Java
editor:


When entering a condition for a breakpoint• 
In the Details pane of the Variables & Expressions view• 
When entering a Details Formatter code snippet• 
When entering code in a Scrapbook page• 
In the Display view• 


Command line
details


You can always see the exact command line used to launch a program in run
or debug mode by selecting Properties from the context menu of a process or
debug target, even if the launch has terminated.
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Stack trace
hyperlinks


Java stack traces in the console appear with hyperlinks. When you place the
mouse over a line in a stack trace, the pointer changes to the hand and the
stack trace is underlined. Pressing the mouse button opens the associated Java
source file and positions the cursor at the corresponding line. Pressing the
mouse button on the exception name at the top of the stack trace will create an
exception breakpoint.


What's New in 3.0


Here are some of the more interesting or significant changes made to the Java development tools for the 3.0
release of Eclipse since 2.1:


Java Editor


Folding in the
Java editor


The Java editor now supports folding of code regions. Hovering over a
folded Java element lets you peek at the hidden code:
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Currently, import statements, comments, types and method bodies can be
folded. Whether folding should be enabled on new editors can be
configured on the Folding tab on the Java > Editor preference page:


JDT UI provides an extension point to extend the set of available foldings.


Advanced
highlighting


The Java editor can now highlight source code according to its semantics
(for example: static fields, local variables, static method invocations).
When advanced highlighting is enabled via the Java > Editor > Syntax
preference tab, the new advanced highlighting options show up in the list.
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There are also new options for highlighting operators and brackets, and
Italic is a newly supported style.


Quick type
hierarchy view


Select a type, method, or package reference in the Java editor and press
Ctrl+T to see a quick type hierarchy view. For methods, you see all
subtypes and supertypes that provide this method.


Repeat CTRL+T to toggle between the normal type hierarchy and the
supertype hierarchy view.


Quick Outline
shows


inherited
members


The quick outline (Source > Open Outline, Ctrl+O) in the Java editor now
shows inherited members after repeating the key sequence Ctrl+O:
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Likewise for Quick Structure (Ctrl+F3).


Smart Insert
typing mode in


Java editor


The Java editor now has a Smart Insert mode which can be toggled via
Edit > Smart Insert Mode (Ctrl+Shift+Insert).


In Smart Insert mode, the editor provides Java−specific extras which can be
configured on the Java > Editor > Typing preference tab. The Smart
Semicolon and Smart Opening Brace options for example move the caret to
the end of the line before inserting the semicolon or closing brace,
respectively.


Update
imports on


paste


Copying or cutting Java code also captures information about which import
declarations are needed by the copied code. The needed imports are now
added automatically when the code is pasted. This feature can be
configured with the Java > Editor > Typing > Update imports on paste
preference setting.


Improved
cursoring


through Java
names


The Java editor's word−at−a−time actions now respect the typical
"CamelCase" notation of Java identifiers. For example, Next Word on the
identifier "getFoo" makes an additional stop between "get" and "Foo".
Cursoring behavior for Java names is controlled by an option on the Java >
Editor > Navigation preference page.


New code
formatter


The Java code formatter has many improvements to offer: The Java >
Code style > Code Formatter preference page lets you choose from
existing profiles, define your own, and share them with others.
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The new formatter is highly configurable, with over 140 options covering
everything from brace positions to wrap lines up to Javadoc comment
formatting.


Format
multiple files


The Format command is also enabled on Java projects, source folders, and
packages. When invoked, all contained source files will be formatted
according to the currently configured formatter settings.
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Spell−checking Spell−checking support has been added to the Java editor. After enabling it
and specifying a dictionary on the Java > Editor > Spelling preference
page, spelling errors are displayed in the Java editor and corresponding
Quick Fixes become available.


Optionally, you can make the dictionary available to the content assist.
However, there is currently no dictionary included in Eclipse. The required
format is just a list of words separated by new line characters and the Quick
Fixes allow you to add new words to the dictionary on−the−fly.
Contributions of dictionaries would be welcome.


Block
commenting


A text selection in the Java editor can be quickly turned into a block
comment using Source > Add Block Comment. Conversely, the Source >
Remove Block Comment command removes the block comment
enclosing the cursor position.


Toggle The old Source > Comment and Source > Uncomment commands in the
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Comment
command


Java editor have been replaced by the Source > Toggle Comment (Ctrl+/)
command that uncomments the currently selected source lines if all of them
are commented and comments them otherwise. (You can bind keyboard
shortcuts to the old commands, which are still available, via the
Workbench > Keys preference page.)


Incremental
content assist


Check Insert common prefixes automatically on the Java > Editor >
Code Assist preference tab to use shell−style incremental completion in the
Java editor. If the available completions do not have a common prefix, the
proposal pop−up is displayed.


Dynamically
marking


occurrences in
file


Occurrences of the selected element can be marked in the Java editor with
the new Mark Occurrences toolbar button ( ) or command
(Alt+Shift+O). On the Java > Editor > Mark Occurrences preference
page, you can configure the elements to be marked.


The occurrences of the selected element are marked using Occurrences
annotations, whose presentation can be configured using the Annotation
preference page (Workbench > Editors > Annotations).


When the selected element changes, the marked occurrences are
automatically updated. By default, marked occurrences are sticky, i.e.
remain highlighted even when there is no valid Java element at the current
caret position.


Marked occurrences can quickly be removed using the Remove Occurrence
Annotations source command (Alt+Shift+U).
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Highlight
method exit


points


Placing the cursor on the return type of a method highlights all method exit
points. Highlighting exit points can be enabled via the preference Java >
Editor > Mark Occurrences.


Mark
locations of


thrown
exceptions


When an exception is selected, places where that exception is thrown can
be marked in the Java Editor by triggering the action Search > Exception
Occurrences. The places are marked automatically if occurrence marking
is turned on via the Java > Editor > Mark Occurrences preference page.


Java editor
shows


overridden
methods


The new Override Indicator annotation (see Workbench > Editors >
Annotations preference page) flags a method that implements or overrides
another one. By default, override and implements icons appear in the
left−hand vertical ruler; click on the icon to navigate to the super method:


Multiple
annotations


shown in
roll−over


hover


When multiple annotations are displayed in the text editor's ruler, they are
displayed side by side when hovering over them. Warnings and actions,
such as quick fixes, setting breakpoints, and adding bookmarks, can be
accessed separately. This functionality is disabled by default, but can be
enabled on the Java > Editor > Hovers preference tab.
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New Quick
Assist cue


As you type in a Java editor a Quick Assist cue (green light bulb) appears
in the left margin when there's a Quick Assist available. Use Edit > Quick
Fix (Ctrl+1) or click on the light bulb to see the proposals. This feature can
be enabled by checking Lightbulb for quick assists from the Java >
Editor > Appearance preference tab.


Linked mode
for Quick


Fixes


Several Quick Fix results now appear in linked (template) mode. Use Tab
and Shift+Tab after the invocation of a Quick Fix to navigate between a
generated return type, method name, argument types and argument names.
Examples of Quick Fixes using the linked mode:


Create new method• 
Create new field, parameter or local variable• 
Add new argument• 
Assign statement to new local or field• 


The linked mode offers additional suggestions: Different names, types, or
arguments.


Example of argument guessing:


Example of exception guessing:


Improved
identifier
guessing


When adding fields, variables or parameters, quick fixes try to guess good
names for new identifiers. Using the new linked mode feature, more than
one suggestion is now offered .
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Improved
Quick fixes for


parameter
mismatches


Several new Java quick fixes for mismatched parameters have been added,
including offers to cast, swap, add, or remove arguments or method
parameters.


New Quick
Assists


New Quick Assists have been added to the Java editor. Try Ctrl+1 on


variables, to split and join its variable declaration• 
an 'if' statement, to convert its body into a block or to add a new
'else' block


• 


a method parameter, to assign it to a new field• 
a method declaration. to create the method in a supertype• 


Create getters
and setters
with code


assist


Aside from creating overriding methods, code assist also offers to create
getters, setters, default constructors and method stubs. Set the cursor in the
type body between members and press Ctrl+Space to get the proposals that
create a method stub.
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Fast ways to
create a


constructor


The new Java command Source > Generate Constructor using Fields
creates a new constructor that initializes selected fields. You choose the
fields to be initialized from extra constructor parameters whose order is
controlled via up/down buttons in the dialog.


The Source > Add Constructors from Superclass command now pops up
a dialog so that you can choose which of the superclass's constructors
should be inserted into the current class. The quick assist feature can still be
used to insert without prompting.


Java Debugger


Pop−ups for
inspect/display


Evaluation pop−ups are now used for all Display and Inspect results.
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Logical Structure The Java debugger now allows certain Java types, including collections and
maps, to be displayed in a more compact and meaningful form. These
logical structures are controlled by a toggle button in the Variables view.


System thread
filter


System threads are now filtered out from the Debug View by default. The
Show System Threads command in the view's drop−down menu toggles
the filter on/off.


Step Into
Selection on any


line


The Java debugger's Step Into Selection command is no longer restricted
to the currently executing line.


Class prepare
breakpoints


Breakpoints can be set on a class prepare event. The program will be
suspended when the specified class or interface is first loaded by the Java
VM.
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Exception
breakpoint
hyperlinks


Exception breakpoints can be now created directly from a stack trace in the
console. Clicking on the hyperlink that appears under the exception name
at the beginning of a stack trace opens a properties dialog on the newly
created (or already existing) exception breakpoint.


Breakpoints in
external source


You can now put a breakpoint in external source code (i.e., source code
that is not on the build classpath of a Java project). The breakpoint creation
actions on the Run menu automatically create external breakpoints
whenever the debugger is displaying external source.


Refactorings
update


breakpoints and
launch


configurations


Breakpoints and launch configurations are now updated as a consequence
of Java source code refactorings such as renaming a Java project, source
file, or type declaration.


Restart option
when hot code


replace fails


When changes are made in the host Java VM that hot code replace does not
support, you now have the option to Restart the VM in addition to choosing
Continue or Terminate.
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Default VM
arguments can be
associated with a


JRE


The Java > Installed JREs preference page now lets you associate a set of
default VM arguments with each JRE. These arguments will be passed to
the VM whenever it is used.


Refactoring


Quick menus
for source


and
refactoring


actions


The refactoring and source commands can be accessed via a quick menu.
Select the element to be manipulated in the Java editor or in a Java view
and press Alt+Shift+S for the quick source menu or Alt+Shift+T for the
quick refactor menu.
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Refactorings
update


references in
Javadocs


Rename, Move, and Change Method Signature refactorings now update
references in Javadoc comments too. This includes references in @see and
@link tags, as well as @param and @throws clauses.


The Rename dialog has been simplified as a consequence:


The old option Update references in Javadoc comments has been folded
into Update references. The old options Update references in regular
comments and Update references in string literals have been merged into
Update textual matches in comments and strings.


Generalize
Type


refactoring


Select a declaration of a variable, parameter, field, or method return type in
a Java editor and choose Refactoring > Generalize Type.


The wizard shows the supertype hierarchy for the variable. Selecting one
of the available types updates the declaration.
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Introduce
Factory


refactoring


Select a constructor declaration or call in the Java editor and choose
Refactoring > Introduce Factory.


A static factory method is created that calls the now−private constructor,
and all calls to the given constructor are replaced with calls to the new
factory method.


Introduce
Parameter
refactoring


Select an expression in a Java editor and choose Refactoring > Introduce
Parameter.
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The containing method is given a new parameter and the selected
expression is copied to the argument list of all the call sites.


Improved
Change
Method


Signature
refactoring


In the Java editor, select a method and choose Refactoring > Change
Method Signature.
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The refactoring now


renames parameters in overriding methods as well,• 
updates references in javadocs• 
offers Content Assist (Ctrl+Space) in the parameter type column,• 
allows to change the method name,• 
allows to change thrown exceptions.• 


Furthermore, editing in the parameters table has been streamlined such that
you can use standard navigation keys (Tab, Shift+Tab, Arrow Up &
Down). Editing can be started by clicking into a cell, or pressing F2 or
Enter.


Extract
Method from


inner types


For Java code contained in an anonymous, local, or non−static member
type, the Extract Method refactoring now allows the new method to be
created in an outer type.


Extract
method finds


duplicate
code


fragments


Extract method now finds duplicate code fragments and helps extracting
them into the new method as well. For example, when extracting the
expression foo(a) + bar(b) from the snippet:
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the resulting code is:


Java Tools − General


Method call
hierarchy


You can open a view that shows a method call hierarchy by choosing
Navigate > Open Call Hierarchy (Ctrl+Alt+H) in the Java editor or any of
the Java views that show methods.
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Javadoc view There is a new Javadoc view (Window > Show View > Other > Java >
Javadoc) which shows the Javadoc of the element selected in the Java editor
or in a Java view. The Javadoc view uses the SWT Browser widget to display
HTML on platforms which support it.


Declaration
view


There is a new Declaration view (Window > Show View > Other > Java >
Declaration) which shows the source of the element selected in the Java
editor or in a Java view.
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Type filters The set of types that show up in code assist and quick fix proposals can now
be filtered using the new Java > Type Filters preference page. Types
matching one of these filter patterns on the list will not show up in the Open
Type dialog, and will not be available in quick fix and code assist proposals.
These filters do not affect whether the types show up in the Package Explorer
and Type Hierarchy views.


Improved
filtering
support


Java−specific view menus which contain a "Filters..." entry now contain
adjacent checkable entries for recently changed filters.
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External
Javadoc out
of archives


If you have Javadoc documentation stored in an archive, you no longer need
to unpack the archive. The Javadoc location property dialog now supports
documentation in archives. Select a JAR and bring up its property page (or
equivalently Project > Properties > Java Build Path > Libraries > Javadoc
location) to attach documentation to a JAR.


Use Navigate > Open External Javadoc (Shift+F2) to open Javadoc in a
browser.


Grouping
options in


search view


You can switch the new Search view to flat or hierarchical layout mode in the
view menu. Java search results in hierarchical mode can now be grouped by
project, package, file, or type.


Match filters
in Java
search


Java search results can be filtered. You can filter out Javadoc comments,
import statements, read accesses, and write accesses. Only filters applicable to
the current search will be shown.


 Basic tutorial


Java Tools − General 593







Search local
and


anonymous
types


Local and anonymous types are now fully supported in search operations. In
particular, you can now search for references to a selected local type. Also,
search results are now properly rooted inside local or anonymous types
(instead of always inside the outermost enclosing method).


Local types Local and anonymous types now show up in the various Java−specific views
by default, along with filters on the views to hide them.


Deprecated
elements


Types, fields and methods marked as deprecated are now rendered with a
slash.
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References
in Javadoc
comments


The Java infrastructure now includes references in Javadoc comments. You
can see this in several places, including Search, Organize Imports, linked
renames in the editor, and editor occurrence markers.


Content
assist in


dialog fields


Content Assist (Ctrl+Space) is now also available in input fields of various
Java dialogs. Look for small light bulb icon beside the field when it has focus.
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Working sets
support in


Type
Hierarchy


view


The Type Hierarchy view now supports filtering by a working set. Once a
working set is selected in the view menu, the hierarchy view only shows Java
types contained in the given working set, extended by parent types needed to
complete the tree (the latter are shown with white−filled images).
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Interfaces in
package type


hierarchy


The type hierarchy opened on packages (F4) now also shows interfaces of this
package. Same for hierarchies on source folders, projects, and JARs.
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Improved
NLS wizard


The NLS wizard (Source > Externalize Strings) has been updated to work
on already externalized files:


rename pre−existing keys and values• 
rename multiple key prefixes simultaneously• 
change already externalized strings to 'ignored' or to the original,
untagged (internalized) state or vice versa


• 


improved inserting of new keys in the property files• 


User−defined
libraries


You can now group external JARs into a named library. Create user−defined
libraries on the Java > Build Path > User Library preference page, and then
add them to the build path on the project's properties.


Similarly to class path variable entries, the class path entry for a user library
references user libraries by name (not to the JARs to the local file system).
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Java Compiler


Eclipse Java
compiler is


JCK1.4a
compliant


The Eclipse Java compiler in 1.4 mode is JCK1.4a compliant; in 1.3
mode it is JCK1.3a compliant.


Inclusion
pattern for


source folder


Any source folder on the Java build path can now be associated with
some inclusion patterns, so as to selectively include some Java source
files. This is complementary to exclusion patterns already available for
selectively excluding certain source files. Note that both can actually be
combined under the following rule: if you specify both, an exclusion
pattern always take precedence over an inclusion one. E.g.,
{include="src/", exclude="src/sub"} denotes the 'src/' tree without the
'src/sub/' subtree. The include and exclude patterns can be specified via
the project's build path property.
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Find indirect
access to static


members in
Java code


The Java compiler can now find and flag indirect accesses to static
members. The option to turn this checking on is found on the Java >
Compiler > Style preference page (by default they are not reported).


Indirect access to static members is a compatibility issue for generated
class file. For class files compatible with JDK versions prior to 1.2, the
compiler resolves indirect static references to the declaring class (Y in
the example); for class files compatible with JDK versions since 1.2, the
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compiler resolves static references to the type of the receiver (X in the
example).


Find accidental
boolean


assignments


The Java compiler can now find accidental boolean assignments.The
option to turn this checking on is found on the Java > Compiler > Style
preference page (by default they are not reported):


Java compiler
option for


flagging
unqualified


instance field
accesses


The Java compiler can now find and flag non−qualified references to an
instance field. This check can be enabled from Java > Compiler > Style
preference page (off by default).


This option supports a coding style where all references to instance fields
are qualified in order to make them visibly distinct from references to
local variables.


Java compiler
option for


flagging finally
block which


cannot
complete
normally


The Java compiler can now find and flag finally blocks which cannot
complete normally (as defined in the Java Language Specification).
Finally blocks which cannot complete normally can be confusing and are
considered bad practice. This check can be enabled from Java >
Compiler > Style preference page (Warn by default).


Empty control
flow statement


The Java compiler can now flag an empty statement used as the body of
a control flow statement. See preference under Java > Compiler > Style
> Empty statement


Java compiler
option for


flagging
undocumented


empty blocks


The Java compiler can now find and flag empty blocks which are not
documented with a comment. Totally empty method and type bodies are
also suspicious. This check can be enabled from Java > Compiler >
Style preference page (off by default).
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Find variables
that hide


another field or
variable


The Java compiler can now find local variable declarations and fields
which hides another field or variable. The option to turn this checking on
is found on the Java > Compiler >Advanced preference page (by
default they are not reported):


Find
unnecessary


type checks in
Java code


The Java compiler can now find and flag unnecessary casts or
'instanceof' operations. The option to turn these checks on is found on the
Java > Compiler > Unused Code preference page (by default they are
not reported).


Java compiler
option for


flagging
unnecessary


checked
exceptions


The Java compiler can now find and flag unnecessary checked
exceptions that are declared but not thrown. This check can be enabled
from Java > Compiler > Unused Code preference page (off by default).


Note that a given method can always declare to throw fewer checked
exceptions than declared in the superclass (or interface).


Quick Fixes for
the new


compiler
options


The new Java compiler options come with the corresponding Quick
Fixes:


Unnecessary declaration of thrown exception:


 Unqualified access to instance field:
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Unnecessary cast:


Press Ctrl+1 on a warning or error, or click on the light bulb to get
suggested Quick Fixes.


Javadoc
comment
handling


The Eclipse Java compiler now processes Javadoc comments. Search
reports references in doc comments, and refactoring updates these
references as well. This feature is controlled from the Java > Compiler
> Javadoc preference tab (or set for an individual project using Project
> Properties > Java Compiler > Javadoc).


When turned on, malformed Javadoc comments are marked in the Java
editor:
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Quick fixes for
problems in


Javadoc
comments


After enabling the new problem markers in Javadoc comments (previous
item), you can use Quick fix in the Java editor to correct missing Javadoc
tags. Simply click on the light bulb or use Edit > Quick Fix (Ctrl+1).


Inlining JSR
bytecode


The Java compiler can now optionally avoid generating class files using
the JSR bytecode instruction (typically used in compiling try−finally
blocks), instead inlining the instructions for the corresponding
subroutine. The generated class files are a bit bigger but generally load
faster. This mode is anticipating support for the JSR 202. See preference
under Java > Compiler > Compliance and Classfiles.


JUnit Integration


Running
individual JUnit


test requiring
special set−up


JUnit now supports decorating an individual test for a test run. This is
done by implementing a public static setUpTest(Test) method in your
TestCase class as shown here:


The setUpTest method is automatically used when a test is about to be 
executed individually (including re−running a failed test). The result
returned by setUpTest is run instead of the given test, with the common
use being to wrap the given test with special set−up or tear−down.


Improved string
compare in
JUnit view


When a JUnit test fails because a string is not as expected, clicking on
the magnifier button in the tool bar to view the differences between the
strings in a compare viewer:
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